While working screen-monitor goes blank & doesn't respond to keyboard or/and mouse

Bug #193709 reported by Shirish Agarwal on 2008-02-20
4
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Hi all,
   I get the following symptons :-

I am on Hardy 8.04 with all updates.
1. While working many a times the screen/monitor goes blank
 2. When it goes blank then I don't get access back by clicking either on mouse or keyboard.
 3. I have to restart the system either cold-starting or using SysRQ magic.
This is the output of gconftool-2 -R /apps/gnome-power-manager
shirish@Mugglewille:~$ gconftool-2 -R /apps/gnome-power-manager
  display_state_change = true
  /apps/gnome-power-manager/general:
   check_type_cpu = false
   can_hibernate = true
   invalid_timeout = 500
   network_sleep = false
   use_time_for_policy = true
   use_profile_time = true
   policy_suppression_timeout = 5
   ignore_inhibit_requests = false
   debug = false
   can_suspend = true
   installed_schema = 3
  /apps/gnome-power-manager/battery:
  /apps/gnome-power-manager/ui:
   show_actions_in_menu = true
   enable_sound = true
   icon_policy = charge
   cpufreq_show = false
  /apps/gnome-power-manager/actions:
   sleep_type_battery = nothing
   critical_ups = shutdown
   critical_battery = shutdown
   event_when_closed_battery = true
   low_ups = nothing
   sleep_type_ac = suspend
  /apps/gnome-power-manager/ac:
   button_lid = blank
   cpufreq_policy = nothing
   sleep_display = 60
  /apps/gnome-power-manager/backlight:
   idle_dim_battery = true
   idle_brightness = 30
   dpms_method_battery = default
   dpms_method_ac = default
   idle_dim_time = 30
   brightness_battery = 70
   enable = true
   idle_dim_ac = false
   battery_reduce = true
   brightness_ac = 100
  /apps/gnome-power-manager/buttons:
   hibernate = hibernate
   power = interactive
   suspend = nothing
   lid_ac = blank
   lid_battery = blank
  /apps/gnome-power-manager/thresholds:
   percentage_action = 2
   time_action = 120
   percentage_critical = 3
   time_critical = 300
   time_low = 1200
   percentage_low = 10
  /apps/gnome-power-manager/statistics:
   smooth_data = true
   graph_type = power
   data_max_time = 21600
   show_events = true
   show_axis_labels = true
  /apps/gnome-power-manager/lowpower:
   on_ac = false
   on_ups = true
   on_battery = true
  /apps/gnome-power-manager/ambient:
   correction_scale = 200
   v4l_device = default
   dim_policy = none
   enable = true
   poll_timeout = 60
   correction_factor = 50
  /apps/gnome-power-manager/timeout:
   sleep_computer_battery = 0
   sleep_display_battery = 300
   sleep_computer_ac = 0
   sleep_display_ac = 0
  /apps/gnome-power-manager/lock:
   hibernate = true
   gnome_keyring_suspend = false
   blank_screen = false
   gnome_keyring_hibernate = true
   use_screensaver_settings = false
   suspend = true
  /apps/gnome-power-manager/ups:
  /apps/gnome-power-manager/notify:
   fully_charged = true
   low_power = true
   estimated_data = true
   inhibit_lid = true
   sleep_failed = true
   perhaps_recall = true
   low_capacity = true
   discharging = true
  /apps/gnome-power-manager/cpufreq:
   policy_battery = ondemand
   policy_ac = nothing
   performance_ac = 85
   consider_nice = false
   performance_battery = 25
  /apps/gnome-power-manager/keyboard:
   brightness_battery = 50
   brightness_ac = 100

Attaching the lspci as well as dmesg

Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :

First I thought it is bug #30969 hence I added this section in xorg.conf . I have added them today itself but can't say if it works or not until few days.

Section "ServerFlags"
   Option "BlankTime" "0"
   Option "StandbyTime" "0"
   Option "SuspendTime" "0"
   Option "OffTime" "0"
  EndSection

This is the output of get-edid , don't ask me the last 2 lines which are unreadable. I can also send the get-edid to a file but don't get anywhere.

get-edid: get-edid version 1.4.1

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
 Function supported
 Call successful

 VBE version 300
 VBE string at 0x11110 "Intel(r)845G/845GL/845GE/845GV Graphics Chip Accelerated VGA BIOS"

VBE/DDC service about to be called
 Report DDC capabilities

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
 Function supported
 Call successful

 Monitor and video card combination does not support DDC1 transfers
 Monitor and video card combination supports DDC2 transfers
 0 seconds per 128 byte EDID block transfer
 Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
 Read EDID

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
 Function supported
 Call successful

������A
   ��帞YJ�& HL��1YEYaY��1hEh�@qO� �� ^c `2� � BZ 414122
 �PHILIPS 107E5�2� G

Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :

shirish@Mugglewille:~$ aptitude show xserver-xorg-video-intel
Package: xserver-xorg-video-intel
State: installed
Automatically installed: yes
Version: 2:2.2.0.90-2ubuntu2
Priority: optional
Section: x11
Maintainer: Ubuntu Core Developers <email address hidden>
Uncompressed Size: 664k
Depends: libc6 (>= 2.7-1), libdrm2 (>= 2.3.0), xserver-xorg-core (>= 2:1.4)
Conflicts: 915resolution, xserver-xorg-driver-i810, xserver-xorg-video-i810-modesetting,
           xserver-xorg-video-intel-modesetting
Replaces: xserver-xorg (< 6.8.2-35), xserver-xorg-driver-i810, xserver-xorg-video-i810-modesetting,
          xserver-xorg-video-intel-modesetting
Provides: xserver-xorg-video-2
Description: X.Org X server -- Intel i8xx, i9xx display driver
 This package provides the driver for the Intel i8xx and i9xx family of chipsets, including i810, i815, i830,
 i845, i855, i865, i915, i945 and i965 series chips.

 This package also provides an XvMC (XVideo Motion Compensation) driver for i810 and i815 chipsets.

 More information about X.Org can be found at: <URL:http://www.X.org> <URL:http://xorg.freedesktop.org>
 <URL:http://lists.freedesktop.org/mailman/listinfo/xorg>

 This package is built from the X.org xf86-video-intel driver module.

If any more info. is needed please tell me.

Shirish Agarwal (shirishag75) wrote :

Hi all,
 The Intel driver is upto 2:2.2.0.90-2ubuntu7 but my issue is still there, the section I added to Server in x.org as in comment 3 didn't do anything for me :(

Shirish Agarwal (shirishag75) wrote :

Mine is a desktop not a laptop.

Ted Gould (ted) wrote :

Can you switch to a virtual terminal using Ctrl+Alt+F1? What happens when you do that?

Shirish Agarwal (shirishag75) wrote :

When the screen is locked/sleeping/suspended or whatever it doesn't respond. Tried everything, even changing to all & any virtual terminals, don't get anywhere.

Vincenzo Ciancia (vincenzo-ml) wrote :

I would also try logging it to the host remotely (after installing sshd) just to know if the machine is deadlocked or not). By the way does "everything" include "ctrl+alt+backspace"?

Shirish Agarwal (shirishag75) wrote :

Vincenzo that is on my mind but don't have the resources (yet) for doing so. Once I have that, there are number of things I would like to try out. Yes, it did escape the the crtl+alt+backspace combo for trying to get back the gdm . Will try when it lock or whatever it does again & report back.

Shirish Agarwal (shirishag75) wrote :

Vincenzo,
  Tried everything excluding the laptop sshd stuff, but as far as CTRL+ALT+Backspace is concerned, that also doesn't work. Attaching the msot recent .xsession-errors file in the hope something can be done.

Shirish Agarwal (shirishag75) wrote :
Vincenzo Ciancia (vincenzo-ml) wrote :

Shirish: (note that I am not a developer, just helping triaging the bug) - I am worried that you attached dmesg of the rebooted pc. You have to get /var/log/dmesg.0 I suppose, try to attach that.

Shirish Agarwal (shirishag75) wrote :

Vincenzo: Thank you, understood. I am attaching the /var/log/dmesg.0 in the hopes something gets noticed in there.

Shirish Agarwal (shirishag75) wrote :

Also giving the dmesg.1.gz for just in case.

Aaron Sarna (shoofy) wrote :

I think I may be seeing a similar bug. If I have the gnome-screensaver process running and I have g-p-m set to turn off the monitor when I close my laptop lid, when I close the lid and open it again I get the same issue you have. My bug only occurs when fglrx is installed.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Intrepid Ibex. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in gnome-power-manager:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gnome-power-manager:
status: Incomplete → Invalid
Alchera (barrysuridge) wrote :

Monitor going into standby after a period of inactivity and unable to "wake up" via mouse or keyboard.

Open gconf-editor. Open apps and scroll down to gnome-power-manager~actions and set sleep_type_acc to 'nothing'. Reload the desktop.

The problem went away (for me).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers