Sleep / hibernate seriously crashes Gnome on AMD64

Bug #174482 reported by slowtrain on 2007-12-06
6
Affects Status Importance Assigned to Milestone
gnome-power
Expired
Low
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

I recently installed Ubuntu Gutsy on a HP computer with an AMD64 X2 (4200+) chip. A serious constraint on my using Ubuntu is that I cannot sleep or hibernate it without badly crashing Gnome. The computer does go into sleep and hibernate, but when it wakes up gnome crashes. On wakeup from sleep, for example, the gnome gui is completely gone, the screen has gone into what looks like a terminal, and the following error messages occur (I copied and typed these by hand, so there might be some errors, though I am an accurate typist):

atiixp: coedec reset timeout
pnp failed to activate device 00:09
pnp failed to activate device 00:0a.
ata1.00: ACPI cmd ef/03:46:00:00:00:a0 failed (Emask=0x1 Stat=0x51 Err=0x04)
ata1.00:revalidation failed (errno=-5)
ata1.00: ACPI cmd ef/03:46:00:00:00:a0 failed (Emask=0x1 Stat=0x51 Err=0x04)
ata1.00: revalidation failed (errno=1)
usb_endpoint usbdev1.1_ep00: PM: resume from 0 parent usb1 still 2
usb_endpoint usbdev1.1_ep81: PM: resume from 0, parent 1-0:1.0 still 2
usb_device usbdev1.1: PM: resume from 0, parent usb1 still 2

There is no command line after these messages. Pressing return does nothing. I then switched terminals using Alt-F2 (which shows a login command line), did nothing, and came back to Alt-F1. Now the earlier messages are gone, but the following displays:

MP-BIOS bug: 8254 timer not connected to IO-APIC
Loading, please wait...
kinit: name_to_dev_t(/dev/disk/by-uuid/60dd5023-e9a9-40ad-a561-00665052e4be)
= sda5(8,5)
kinit: trying to resume from
/dev/disk/by-uuid/60dd5023-e9a9-40ad-a561-00665052e4b3
kinit: No resume image, doing normal boot

There is now a login command line, I use it to log into root and use 'shutdown -r now'.

On reboot, problems persist. The Ubuntu splash screen comes up and the load bar starts showing some loading of software, but it pauses very early and nothing happens. I now cannot switch terminals (Alt-F2 does not work) and have to force a shutdown using the power key. On reboot, everything works fine again.

slowtrain (pmuhl830) wrote :

I should add two things: First, this problem is consistently replicable--every time I suspect or hibernate, gnome crashes. Second, the problem first occurred just after I installed Ubuntu, so I think this is not a matter of interactions with software I've since installed. On the Gentoo website, gnome-power-manager-2.20.1 is hard masked for AMD64, indicating they have run into serious problems w/ that version on AMD64.

Ted Gould (ted) wrote :

It seems that Gentoo has hard masked it for all architectures:

http://packages.gentoo.org/package/gnome-extra/gnome-power-manager

Which is likely because of this bug:

http://bugs.gentoo.org/show_bug.cgi?id=196490

Which is reported fixed:

http://bugzilla.gnome.org/show_bug.cgi?id=497908

Just to be clear though, you're saying that suspend works on your computer under Gentoo?

slowtrain (pmuhl830) wrote :

Hi Ted: Thanks for the reply! You're right, it is masked for all architectures. I have not, however, tried gnome-power-manager under Gentoo on my computer. I simply noticed that the recent version of the power manager was hard masked in Gentoo because I thought that's what was running under Ubuntu. Actually, on closer inspection, Ubuntu is running what looks like a slightly earlier version that has been modified for Ubuntu. That earlier version (though not modified for Ubuntu) gets a clean bill of health in Gentoo for AMD64, according to the portage page. But, I haven't tried it.

Cheers, Slowtrain

slowtrain (pmuhl830) wrote :

Just to be clear: The version of gnome-power-manager running under Ubuntu *should* work for AMD64, but it does not on my AMD64 system. This leaves several possibilities, among them: the report on the Gentoo site saying gnome-power-manager works for AMD64 is false (which is unlikely) or something done by Ubuntu to adapt that version of gnome-power-manager to Ubuntu has created a bug.

So Ubuntu experts: strike one against global warming by fixing this problem!

Slowtrain

atotic (a-totic) wrote :

I have the same problem, but I am running Ubuntu on a brand new stock laptop. Intel Core Duo. Problems started occuring when I enabled suspend/resume. I can never resume without crashing the OS. On resume, the screen blinks a few times, goes to terminal mode, and complains:
Dec 22 19:38:04 totic kernel: [ 4012.488000] usb_endpoint usbdev4.8_ep00: PM: resume from 0, parent 4-1 still 1
Shortly afterwards, system goes into hard reset. This happens every time.

Workaround: do not suspend.

If you need any more info, I'll be happy to try out solutions, collect logs, etc.

mtopro (matt-mtopro) wrote :

I also have a brand new 64bit laptop that consistantly crashes with a 64 bit Intel Core Duo 2.4ghz. It has a fresh install of Ubuntu 8.04 (no M$oft) and will consistently crash upon resuming a session . atotic stated the issue very well above.

If you use the laptop for any type of business, it can be a bit embarrassing if you forget and don't completely shut down since you know that upon wakeup it will crash and then you need to reboot. It is also tough to work without the suspend / hibernate function as the batteries seem to run out pretty quick.

I would also be happy to help if that is possible..

slowtrain (pmuhl830) wrote :

mtopro: sorry to hear about your having this problem. I know it's difficult enough to deal w/ on a desktop that I hate keeping on all day. Ubuntu 8.04 does, however, solve the sleep / hibernate problem for my AMD64 desktop. I'm guessing they Ubuntu wizards are working hard on this problem. I wonder if it may be an idea to report this separately as an 8.04 problem?

mtopro (matt-mtopro) wrote :

Good idea slowtrain. Thank you, I will do it.

Changed in gnome-power:
status: Unknown → Confirmed
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in gnome-power-manager:
status: New → Incomplete
Changed in gnome-power:
status: Confirmed → Invalid
slowtrain (pmuhl830) wrote :

H Daniel: No, I've not had this problem in 8.10--thank heavens!

Chris Coulson (chrisccoulson) wrote :

Thank you for your feedback. Because it seems you are no longer experiencing this bug, I will close this bug report now. Please feel free to report any other bugs you find.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-power:
importance: Unknown → Low
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.