Screen is not locked when laptop lid is closed

Bug #156226 reported by Marko Djukic on 2007-10-23
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned
gnome-screensaver (Ubuntu)
Undecided
Unassigned

Bug Description

On Gutsy, just recently upgraded from Feisty, I have the screensaver set to lock screen in System -> Preferences -> Screensaver.

When I close the laptop lid the screen is blanked, however when opened again it is not locked. It does lock when the screensaver time is reached (eg. on mine after 10min).

This is a regression from Feisty where this worked perfectly: as soon as the lid was closed the screen would be locked.

It looks something similar to this bug:
https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/29881

soccermonstar13 (will-morrel) wrote :

I have the same problem. I installed the Gutsy Beta and upgraded to the Final Release.

Jacob Peddicord (jpeddicord) wrote :

I also have this problem; closing the lid does nothing. If I look inside the laptop while closed, I also notice that the screen turns back on after a few seconds. So, when shut, my system is unlocked and the screen is still on. It worked normally up until Gutsy RC, but I never thought much of it until recently.

Jacek Zmudzki (jacek-zmudzki) wrote :

I have exactly the same problem as Jacob.
When i set gnome-power-manager to suspend on lid close, it suspends without problems.
Typing "sudo xset dpms force off" in the Terminal switches off the screen.

Closing and opening the Lid produces following output in /var/log/acpid:

[Fri Oct 26 20:49:13 2007] received event "video VID 00000080 00000000"
[Fri Oct 26 20:49:13 2007] notifying client 5138[107:116]
[Fri Oct 26 20:49:13 2007] notifying client 5580[0:0]
[Fri Oct 26 20:49:13 2007] executing action "/etc/acpi/videobtn.sh"
[Fri Oct 26 20:49:13 2007] BEGIN HANDLER MESSAGES
[Fri Oct 26 20:49:13 2007] END HANDLER MESSAGES
[Fri Oct 26 20:49:13 2007] action exited with status 0
[Fri Oct 26 20:49:13 2007] completed event "video VID 00000080 00000000"
[Fri Oct 26 20:49:13 2007] received event "button/lid LID 00000080 00000003"
[Fri Oct 26 20:49:13 2007] notifying client 5138[107:116]
[Fri Oct 26 20:49:13 2007] notifying client 5580[0:0]
[Fri Oct 26 20:49:13 2007] executing action "/etc/acpi/lid.sh"
[Fri Oct 26 20:49:13 2007] BEGIN HANDLER MESSAGES
[Fri Oct 26 20:49:13 2007] END HANDLER MESSAGES
[Fri Oct 26 20:49:13 2007] action exited with status 0
[Fri Oct 26 20:49:13 2007] completed event "button/lid LID 00000080 00000003"
[Fri Oct 26 20:49:19 2007] received event "video VID 00000080 00000000"
[Fri Oct 26 20:49:19 2007] notifying client 5138[107:116]
[Fri Oct 26 20:49:19 2007] notifying client 5580[0:0]
[Fri Oct 26 20:49:19 2007] executing action "/etc/acpi/videobtn.sh"
[Fri Oct 26 20:49:19 2007] BEGIN HANDLER MESSAGES
[Fri Oct 26 20:49:19 2007] END HANDLER MESSAGES
[Fri Oct 26 20:49:19 2007] action exited with status 0
[Fri Oct 26 20:49:19 2007] completed event "video VID 00000080 00000000"
[Fri Oct 26 20:49:19 2007] received event "button/lid LID 00000080 00000004"
[Fri Oct 26 20:49:19 2007] notifying client 5138[107:116]
[Fri Oct 26 20:49:19 2007] notifying client 5580[0:0]
[Fri Oct 26 20:49:19 2007] executing action "/etc/acpi/lid.sh"
[Fri Oct 26 20:49:19 2007] BEGIN HANDLER MESSAGES
[Fri Oct 26 20:49:19 2007] END HANDLER MESSAGES
[Fri Oct 26 20:49:19 2007] action exited with status 0
[Fri Oct 26 20:49:19 2007] completed event "button/lid LID 00000080 00000004"

soccermonstar13 (will-morrel) wrote :

Hmm... my screen does not turn back on like yours does. It stays off after I close it. However the screen won't lock when I close the lid... it will only lock when the screensaver is activated after a certain amount of time.

Pedro Villavicencio (pedro) wrote :

Did you tried activating the /apps/gnome-power-manager/lock/use_screensaver_settings key with gconf-editor? does that works for you ?

Marko Djukic (djukic) wrote :

Hi Pedro,

You're right, that fixes it. Ticking the setting use_screensaver_settings will now lock the screen when I close the lid.

Thanks,

Marko

soccermonstar13 (will-morrel) wrote :

Ah, Pedro's solution works for me as well. Thanks very much.

Jacek Zmudzki (jacek-zmudzki) wrote :

Yes, this solves the problem with the lock screen but my backlight is still on :(

Gerhard Kremer (gerhardusm2002) wrote :

It looks like a problem with ACPI. Check out bug #173519; this may be a duplicate.

Chris Jones (cmsj) wrote :

It seems reasonable to confirm this, since it's been seen by several people (myself included)

Changed in gnome-power-manager:
status: New → Confirmed
Chris Jones (cmsj) wrote :

I'm marking this as invalid for gnome-screensaver because I'm pretty sure it's gnome-power-manager at fault.

Changed in gnome-screensaver:
status: New → Invalid

I don't think it's connected to GNOME, Chris. I get the same error under pure Kubuntu Gutsy.

I think the problem is with ACPI. As I said above, I suspect this is bug #173519 duplicated.

Chris Jones (cmsj) wrote :

Gerhard: I think the problem is simply that /apps/gnome-power-manager/lock/use_screensaver_settings should be on by default, that fixes the regression.

What makes you think this is a duplicate of bug #173519? This bug is about closing the lid and re-opening it not locking the screen.

My mistake. I get strange behavior when closing and re-opening the lid, but not specifically locking the screen. I mis-read the bug report. My apologies.

KIAaze (zohn-joidberg) wrote :

I confirm this bug on Hardy.

Pedro's solution worked for me too, but I see no reason why this option isn't available in the Screensaver or power-management dialog.

(That said, I still don't know why the "gnome-screensaver-preferences" dialog doesn't offer all the extensive settings available in xscreensaver... One day, I might be switching to KDE completely...)

Emmet Hikory (persia) wrote :

It appears to me that the upstream behaviour is to have /apps/gnome-power-manager/lock/blank_screen true in gconf, but that our package sets this to false in debian/gconf-defaults. I strongly suspect this was because this was perceived as a duplicate key to one in gnome-screensaver, and only affects those who activate DPMS without either a timeout or suspending (essentially limited to lid-close).

Daniel Hahler (blueyed) wrote :

I have tried it with both /apps/gnome-power-manager/lock/blank_screen and /apps/gnome-power-manager/lock/use_screensaver_settings enabled: the screen appears to get locked only after the screensaver kicks in, not when closing the lid.

I have set the lid action to "Blank screen" in gnome-power-preferences.

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers