Rediculous number of software brightness steps. 18 vs. 8 before on ThinkPad

Bug #149780 reported by Paul Sladen on 2007-10-06
8
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned
hal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Software brightness control now has ~18-20 brightness steps, instead of eight. This is far too many. Ideally 8-12 steps, even 16 at a push would be fine.

It takes 2-3 key presses for each "step change" in the backlight brightness.

Ideally gnome-power-manager would use a small number of generalised steps, or a number of steps that exactly matched those that the hardware reports it is capable of, ensuring that each key press causes an immediate visible change.

4lorne (4lorne) wrote :

I can confirm this bug on my Lenovo ThinkPad T60

Suggested cause:
Using /sys/class/backlight/* to control the brightness rather than /proc/acpi/ibm/brightness

Suggested Solution:
Use the ibm section of /usr/lib/hal/scripts/linux/hal-system-lcd-{get,set}-brightness-linux rather than the "we have /sys/class/backlight" section. This, in turn, uses /proc/acpi/ibm/brightness.

I've attached a little work around that I figured out. It changes the keys/values in the Backlight entry of hal so that hal uses the ibm section. It is an alteration to the file found at /usr/share/hal/fdi/information/10freedesktop/10-laptop-panel-hardware.fdi

Does this work for anyone else?

Also, I'm not familiar with the syntax of the FDI files. I just set the linux.sysfs_path to an empty string. What's the syntax to have it removed?

Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please attach the resulting log file of: gnome-power-bugreport.sh &> gpm.log to the report? You might also want to take a look to the Debugging instructions located at https://wiki.ubuntu.com/DebuggingGNOMEPowerManager for submit any other logs related to your problem.Thanks in advance.

Changed in gnome-power-manager:
status: New → Incomplete
4lorne (4lorne) wrote :

Here's the log. I was made after implementing my fix above, but I don't think that makes a difference.

4lorne (4lorne) wrote :

No longer much of an issue on Hardy Beta. Though, maybe by design, brightness goes down two steps at a time (5 total), but up every step (8 total levels).

enigma_0Z (enigma-0za) wrote :

... I don't really think this is a good feature, if it's by design, IMO it's poor design. Is this a HAL issue or GPM?

Charlie Kravetz (charlie-tca) wrote :

This bug report is being closed due to your comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in hal:
status: New → Fix Released
Changed in gnome-power-manager:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers