Ubuntu

Can't access shutdown menu when gnome-power-manager isn't enabled is sessions options

Reported by Saivann Carignan on 2007-09-11
6
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned
gnome-session (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

If Gnome Power Manager isn't checked in the session options inside the System / Preferences Menu, the whole system freezes when I click the red icon in the right corner of the screen to shutdown my system.

The menu with Shutdown, Restart, Logout, Hibernate, etc. takes more than a minute to appear. The system is completely freeze during that whole minute.

It's still possible to shutdown the computer, but it takes anormal time.

This bug happens in Gutsy tribe 6 with all updates.

Lucazade (lucazade) wrote :

This happens to me too!
Using Gutsy beta from scratch!
:-)

Lucazade (lucazade) wrote :

There is a thread on the official forum, don't know if useful :-)
http://ubuntuforums.org/showthread.php?t=559991

jcarminati (jcarminati) wrote :

Same problem here (I didn't know that it's related to the Gnome Power Manager which I've problably disabled).

AlunJ (alunjames) wrote :

Same issue here with Gutsy beta installed from scratch.

I have not changed any 'Gnome Power Manager' related settings myself, but it does not appear in my Session options, however the process gnome-power-manager is running.

Also note that this freeze/delay only occurs when I first click the power icon in the upper right, if I then cancel the shutdown menu I can then click the icon again and it appears instantly as it should.

AlunJ (alunjames) wrote :

forgot to add im using 64bit.

Saivann Carignan (oxmosys) wrote :

Does somebody can confirm if adding/removing a entry for gnome-power-manager in "sessions" fixes the problem? It does in my case but this would need to be confirmed

Alunj : Yes, we speak exactly about the same bug.

Lucazade (lucazade) wrote :

switching off gnome-power-manager in sessions cause hanging
the shutdown dialog..
switching on gnome-power-manager the shutdown dialog appears
immediately so no problem.

I'd like to switch off gnome-power-manager on my pc as usual and use
this feature only on my notebook (t40 ibm).

ps gutsy fully updated.

Changed in gnome-power-manager:
status: New → Confirmed
Ed (ed0x01) wrote :

I had the same problem, but I turned off the bluetooth manager in "sessions" (I don't have bluetooth) and that fixed it. (upgraded to Gutsy from Fiesty, 64bit).

Changed in gnome-power-manager:
importance: Undecided → Low

I have bluetooth disabled, still I have the problem described.

Update: the problem seems to be gone by removing compiz (which I was not using anyway).

WillTH (thornton-will2003) wrote :

Same problem here.

I am using Compiz (reason I got Ubuntu in first place!) and was having real problems with the cpu scaling and system freezes making my PC unuseable. After much searching and testing I gave up on looking for a solution and switched the scaling function off in the bios and by disabling the gnome power manager etc. At last I can use the PC to do some work and make some money instead of screaming at the operating system (that I so want to love!). This is my first foray into Linux...

Was it a good idea to turn the power manager off? I use a Pundit that has a tight little box (oo er) and employs Q fan technology... chip seems to be happy with it off though?? How best to check temps fan speeds etc?

So with gpm off i have a useable operating system where i can work/surf/play and do everything except shut down the pc without planning the event some time in advance.

Problem as described above. Selecting shut down freezes desktop (except mouse) for minute+ and then panel with shut down options appears as normal and shut down/log out can be initiated. I have also checked that selecting cancel here takes you back to the desktop as you would expect and the next time you then select shut down the panel works correctly and promptly.

System info.

Asus Pundit P1-AH2
AMD Athlon(tm) 64 X2 Dual Core Processor 4000+
512MB DDR
C51PV [GeForce 6150]
Gutsy 7.10
Kernel Linux 2.6.22-14-generic
Gnome 2.20.1

Seems crazy to me that you should be forced to use the power manager or have to put up with a bug like this that makes the distro look very amateurish?? The in/out screens are the shop windows and a lot of browsers will look and wonder what horrors lie below..

Hope there will be a fix soon.

Saivann Carignan (oxmosys) wrote :

This bug is still not fixed in Hardy and can be reproduced without compiz enabled.

Since gnome-power-manager is disabled when the bug happens, I think that it's not the good package name. I change it for gnome-panel which should be the good package name.

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in gnome-panel:
assignee: nobody → desktop-bugs
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers