[Gutsy] Closing Lid causes All Screens to Blank

Bug #138102 reported by TJ on 2007-09-07
4
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Gutsy Tribe-5 64-bit, Nvidia restricted driver 100.14.11.

On a laptop PC with Nvidia GeForce Go 7600. External display connected to S-Video port. Xorg configured with two screens.

:0.0 - standard DFP (laptop lid)
:0.1 - S-Video display

Power Management set to "Blank Screen" when laptop lid is closed.

Closing the DFP lid whilst watching a DVD on screen 1 causes both screen 0 & 1 to be blanked. Desired behaviour is for only the DFP to be blanked.

Kjell Braden (afflux) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ .
Furthermore, we need your /etc/X11/xorg.conf for debugging this issue.
Thanks again and we appreciate your help.

Changed in gnome-power-manager:
assignee: nobody → afflux
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in gnome-power-manager:
status: Incomplete → Invalid
Steve Langasek (vorlon) wrote :

xorg.conf is not relevant here, this is a gnome-power-manager bug, not an X bug. This bug is completely reproducible on Ubuntu 8.04, so I'm reopening this report and marking it confirmed.

I'll try to explain in my own terms what I'm seeing, which I recognize as reflected in TJ's description so I'm sure it's the same issue.

I have gnome-power-manager configured to blank the screen when the laptop lid is closed on AC power; I furthermore have gnome-screensaver set up to require a password to unlock the screen.

When I'm using my laptop on its own and I close the lid, the screensaver correctly activates and the screen is locked, so that when I open the lid I have to enter a password to get access. This is good.

I recently purchased an LCD which I've started using via my laptop's VGA output. My chipset is fully supported by xrandr, and the display is automatically detected by xrandr --auto, the desktop is automatically resized to use the larger resolution of the LCD, and the same windows are shown on both displays via clone mode. This is also good.

Because of the current disposition of my desk (i.e. - cluttered), I then proceed to close up my laptop, using only the external monitor, and external keyboard/mouse.

The screensaver then engages, because I've closed the lid. While superficially correct, this is no longer good, because it means I have to unlock my screen immediately afterwards to continue using my laptop.

I believe the correct behavior here would be for gnome-power-manager to detect that an additional screen is present, and to *not* trigger the screensaver on lid close events when this is the case. Enabling the screensaver if the external display is subsequently disconnected (which I think should be detectable in the xrandr case, possibly not in the nvidia case since nvidia doesn't use xrandr) would be ok, but logically, the reason I want the screen to lock when I close my lid is that I've put the machine into a state that I'm definitively not using it - I can't reach the keyboard and I can't see the screen. When an external monitor is attached, this is no longer the case, and gnome-power-manager should be made clever enough to account for this.

Changed in gnome-power-manager:
status: Invalid → Confirmed
Kjell Braden (afflux) on 2008-06-30
Changed in gnome-power-manager:
assignee: afflux → nobody
Pedro Villavicencio (pedro) wrote :

Thanks for the report TJ , It has been a long time without any comment or a duplicate in this bug report and It is possible that the bug has been fixed. May you please try to reproduce it with the latest Stable Release of Ubuntu the Natty Narwhal and add the respective comments to the report? You can learn how to get that release at http://www.ubuntu.com/download . Thanks again and we appreciate your help.

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Incomplete
Steve Langasek (vorlon) wrote :

The behavior is the same all the way through natty.

The only thing that has changed now is that in oneiric, gnome-power-manager's behavior is completely unconfigurable, so closing the lid even when connected to main power causes the machine to suspend (ignoring the previously-configured settings). So I guess in that sense, this bug doesn't exist in oneiric.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Confirmed
Matthew Paul Thomas (mpt) wrote :

Bug 243751 may be a duplicate of this bug, though (as Steve said) there it's suspending rather than blanking.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers