[gutsy] on 100% battery charged, g-p-m incorrectly notifies of removal of power cable and switch to battery

Bug #137077 reported by Gavin McCullagh on 2007-09-03
2
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

on several occasions now, after my laptop (dell latitude l400) battery has been charging, apparently at the point of reaching full charge I am notified by a popup message saying the laptop is now working on battery and the power cable has been removed. This is not true. The applet shows a battery as does the graph even though the ac cable is clearly online and /proc confirms this.

gavinmc@tilly:~$ cat /proc/acpi/ac_adapter/ACAD/state
state: on-line
gavinmc@tilly:~$ cat /proc/acpi/battery/BAT1/info
present: yes
design capacity: 2800 mAh
last full capacity: 3094 mAh
battery technology: rechargeable
design voltage: 11100 mV
design capacity warning: 250 mAh
design capacity low: 100 mAh
capacity granularity 1: 10 mAh
capacity granularity 2: 25 mAh
model number: SI-QT17
serial number:
battery type: LION
OEM info: SANYO

See screenshot to be added.

Gavin McCullagh (gmccullagh) wrote :

It should be noted that after some minutes g-p-m does correctly go back to saying the machine is running on AC power.

However, the notification of ac cable removal is incorrect and might well confuse some.

lod (altoas) wrote :

Same on me with MSI Megabook ER710X

Kjell Braden (afflux) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in gnome-power-manager:
assignee: nobody → afflux
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in gnome-power-manager:
status: Incomplete → Invalid
Gavin McCullagh (gmccullagh) wrote :

Sorry, I have been slow to get back to this.

I can confirm that this problem still exists, having upgraded the laptop to hardy.

Attached is a screenshot on the very latest hardy from 25/03/2007.

Gavin McCullagh (gmccullagh) wrote :

reopening as suggested

Changed in gnome-power-manager:
status: Invalid → New
Kjell Braden (afflux) on 2008-04-05
Changed in gnome-power-manager:
assignee: afflux → nobody
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 beta or later?

Changed in gnome-power-manager:
status: New → Incomplete
Gavin McCullagh (gmccullagh) wrote :

I no longer have a working Latitude L400 I'm afraid, sorry.

Kjell Braden (afflux) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gnome-power-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers