[gutsy tribe 3] screen brightness meter randomly displays on macbook

Bug #129109 reported by Christer Edwards on 2007-07-29
26
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Medium
Unassigned

Bug Description

It seems a new feature in Gutsy automagically updates the brightness levels on events such as lid close, battery-only, etc. Anytime I open the lid on my C2D macbook the brightness returns to full (have not tested to see if it returns to other 'custom' levels).

The problem is intermittent as the brightness display meter continues to reappear for a few minutes into continued use.

The brightness hotkeys are supported on this hardware, it is simply a cosmetic issue of the brightess meter continuing to pop up for a few minutes after logging in, re-attaching the power, opening the lid, etc.

I think this is the same issue I'm experiencing. It's not just MacBook and not just after an obvious triggering event. It pops up when I'm on a/c as well as on battery. It usually appears when I first move the mouse after a few minutes of reading. And I do not have display dimming enabled on either a/c or battery. And I even went into gconf editor and unchecked the enable key for ambient brightness adjustments (which has been speculated in forums as the problem). Nothing I've tried works. I'm on a Toshiba Satellite laptop.

Brian Murray (brian-murray) wrote :

Just to be absolutely clear - the brightness meter pops up even though nothing changes with the brightness as display dimming is not enabled.

Further symptoms: I'm running on the battery right now (dimming not enabled) and the meter keeps popping up but the meter progress bar is blank - as if the display were 100% dimmed. So I tested the brightness with the keyboard controls and it turns the display is in fact fully dimmed. But, again, I rechecked the preferences and dimming is not enabled - either a/c or battery.

Update: Yesterday (8/1/2007) I was on the computer most of the day and never saw said meter once. This morning (8/2/2007) after installing updates the meter has returned with a vengeance. Every few minutes it pops back up. I'm running on a/c and dimming is not enabled, nor does the appearance of the meter actually dim anything. I also rechecked my ambient settings in gconf. 'Dim policy' is 'none' and 'enable' box is not checked.

Erik (echakr) wrote :

Confirmed on Apple PowerBook G4 / gutsy

Ryan Grieve (thegrieve) wrote :

This also happens on my Thinkpad r60e, I often get the dialog popping up and showing me the brightness without changing it. Occasionally it sets itself to fully dimmed without actually dimming the display. Recently the dialog has also refused to disappear.

This seems to have been fixed for me with the latest updates. Aug 7, 2007 1400UTC with all updates available installed. I can't pinpoint the last time I saw the meter appear, but I realize I haven't seen it in a few days now.

Linux macbook 2.6.22-9-generic #1 SMP Fri Aug 3 00:50:37 GMT 2007 i686 GNU/Linux

power is connected during my regular use. Have not tested while on battery power.

Tested on battery and a/c and I also have not seen the meter in a while.

Brian Murray (brian-murray) wrote :

Looking at the gnome-power-manager package (by clicking on the Overview tab - if you are interested) it appears that there was a new release of it on 2007-08-06. The package version is 2.19.6-0ubuntu2. Can everyone please confirm that they have this version installed ('dpkg -l gnome-power-manager') and whether or not it resolves the issue for them? Thanks in advance.

Brian Murray (brian-murray) wrote :

This is likely a duplicate of 122666.

dpkg -l gnome-power-manager :
...
ii gnome-power-ma 2.19.6-0ubuntu frontend for gnome-powermanager

confirmed on my machine.

Also confirmed on mine and haven't seen the meter lately:

ii gnome-power-mana 2.19.6-0ubuntu2 frontend for gnome-powermanager

Roland Dreier (roland.dreier) wrote :

On my system (thinkpad X60s), with

ii gnome-power-mana 2.19.6-0ubuntu2 frontend for gnome-powermanager

this is definitely still happening. In fact as I type this into the comment box, the brightness meter has stayed stuck on my screen the whole time.

Also something seems to be setting the brightness about 20 times a second; my kernel logs are spammed with a continuous stream of

[ 3556.044000] set_level status: 0
[ 3556.096000] set_level status: 0
[ 3556.148000] set_level status: 0
[ 3556.200000] set_level status: 0
[ 3556.248000] set_level status: 0
[ 3556.300000] set_level status: 0
[ 3556.348000] set_level status: 0
[ 3556.404000] set_level status: 0
[ 3556.456000] set_level status: 0
[ 3556.504000] set_level status: 0

which comes from the ACPI video driver.

This is on a i386 gutsy system, completely up-to-date as of August 15.

Brian Murray (brian-murray) wrote :

Roland - do you also have a macbook?

Roland Dreier (roland.dreier) wrote :

No, as I said I am using a thinkpad X60s.

I killed my running gnome-power-manager and ran

    gnome-power-manager --no-daemon --verbose

After letting my computer sit idle for a couple minutes (with the screen open), I came back to g-p-m spewing messages and the brightness meter stuck on the screen. I'm attaching the g-p-m log output.

Although g-p-m's log has lots of "emitting button-pressed : brightness-up" messages, I did not touch my computer to get it into this state.

This seems to be very easy to reproduce, so let me know if there's anything else you would like me to try.

Roland Dreier (roland.dreier) wrote :

By the way, I do agree that my g-p-m log looks similar to Jarmo Ilonen's log at the end of bug #122666, so that may be a duplicate.

Ryan Grieve (thegrieve) wrote :

Fixed for me.

Can't say when, but its at least 2 weeks.

Colin Watson (cjwatson) wrote :

Moving milestone forward.

I don't have this issue anymore. Fresh beta gutsy x86 install

Bryce Harrington (bryce) wrote :

Christer, as others have reported this issue is fixed, could you re-test on Gutsy and see if it's working for you as well, so this bug can be closed?

(For what it's worth, I'm noticing very annoying behaviors with the screen brightness meter on battery with Hardy, however it's not exactly the same as described in this bug, so I'm not certain what I'm seeing is a regression or not.)

Yes, this has been fixed for me as well since the final release. I have not tested in Hardy, but that sounds like another bug for another day ;)

Changed in gnome-power-manager:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers