[gutsy] brightness always appears after Idle

Bug #122666 reported by Solid1986Snake on 2007-06-27
18
Affects Status Importance Assigned to Milestone
gnome-power
Fix Released
Wishlist
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Always when my Notebook gets out of idle the PopUp Brightness appears, even if option "dim if idle" is unchecked in Power Managment

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. With which version of Ubuntu did you notice this issue? Thanks in advance.

This appears in Gutsy up to up-to-date Version....

Brian Murray (brian-murray) wrote :

Confirmed using gnome-power-manager version 2.19.5-0ubuntu1. Steps to reproduce:

1) In Power Manager Preferences uncheck "Dim display when idle" in the "On Battery Power" tab
2) Be idle for a while
3) Watch brightness applet pop up after idle period
4) Be active
5) Watch brightness applet pop up again

Hi, seems that I postet this bug twice, sorry.... its my first post here...

look here: Bug #123606
https://bugs.launchpad.net/ubuntu/+source/gnome-volume-manager/+bug/123606

Chris Lovett (70phr3) wrote :

I can also confirm this on an Intel 945 chipset with up-to-date Gutsy

Martin Pitt (pitti) wrote :

Oliver, are you still the g-p-m Meister? If not, who can I bother with that?

Changed in gnome-power-manager:
assignee: nobody → ogra
Jarmo Ilonen (trewas) wrote :

Thinkpad X41 and gnome-power-manager 2.19.6-0ubuntu2. I have the same issue, "dim display when idle" is unchecked, but after the laptop has been idle for a while, the brightness is changed to whatever value is in "set display brightness to:". I think this started happening for me only a week or so ago and I assumed that g-p-m 2.19.6 broke this and that the following changelog entry is the culprit:

   * Try to discover the laptop backlight type by checking the backlight
     state before we try and set it. Fixes #436717
    .....
 -- Oliver Grawert <email address hidden> Thu, 02 Aug 2007 11:44:34 +0200

However, that doesn't fit to the original filing date of this bug, so I am not certain if the underlying bug is the same (or maybe I did not notice it earlier).

A log from "gnome-power-manager --no-daemon --verbose" is attached. It shows all the lines which appear when the laptop has been idle for a while and g-p-m decides to change the brightness to full. No buttons were pressed while that log was generated, even if the log claims so.

As a side note, fixing a brightness related bug #61184 would be appreciated :P

Changed in gnome-power:
status: Unknown → Fix Released
Henrik Nilsen Omma (henrik) wrote :

Moving milestone.

Henrik Nilsen Omma (henrik) wrote :

Moving milestone to beta.

nmcaramelo (nmcaramelo) wrote :

I made a recent update of Power Manager to the version 2.20.0 and I am now having some problems, after this update it left to control the brightness of my PC and doesn't Dim the display when Idle for x seconds/minutes.

My PC is a Lenovo T61 with a Intel 945 chipset, I'm using Gutsy version.

Note: Sorry for my English, is not very good.

nmcaramelo (nmcaramelo) wrote :

It seems that everything is working again, except when the battery state is critical it doesn't suspend or shut down. I have selected in the option "when battery power is critically low: - Shutdown.", the computer simply goes down without battery.

Gabriel Rota (gabriel-rota) wrote :

On my dell i6400 the bug is in manual change (by keyboard special keys).
If I change brightness, this return at 100% after open gnome-power-manager or Idle or other.
The workaround is set brightness in gnome-power-manager.

For me the solution of this bug is synchronize 'manual change' with brightness in gnome-power-manager.

Ted Gould (ted) wrote :

While there are other issues discussed in this bug, is the original "showing brightness change indicator after idle" still valid? I'm not seeing this on Hardy, with or without dim if idle set.

Thank you.

Changed in gnome-power-manager:
assignee: ogra → ted-gould
status: Triaged → Incomplete
Charlie Kravetz (charlie-tca) wrote :

This bug report is being closed due to this being fixed with an update. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in gnome-power-manager:
assignee: ted-gould → nobody
status: Incomplete → Fix Released
Changed in gnome-power:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.