Can't change display brightness on Dell Inspiron 1501

Bug #105512 reported by der_vegi on 2007-04-11
58
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power
Fix Released
Medium
gnome-power-manager (Ubuntu)
Undecided
Unassigned
Declined for Hardy by Steve Beattie
Nominated for Intrepid by der_vegi
hal-info (Ubuntu)
Undecided
Unassigned
Declined for Hardy by Steve Beattie
Nominated for Intrepid by der_vegi

Bug Description

Okay, as the hwdb-gui still doesn't work, I'm reporting this here: On my Dell Inspiron 1501 I can't change the display brightness over the hotkey "Fn + up/down".

Feisty daily build from April 9th.

der_vegi (m-may) wrote :

Still doesn't work on Feisty Final.

der_vegi (m-may) wrote :

Still happens on fresh installation of Feisty final.

der_vegi (m-may) wrote :

the brightness can be changed by "echo -n 62 > /proc/acpi/video/VGA/LCD/brightness" though.

JRaspass (jraspass) wrote :

Confirmed on Gutsy up to date as of today. The above command however did work.

der_vegi (m-may) wrote :

Still present in Gutsy with all updates until Oct. 22nd, amd64.

This bug is also upstream: http://bugzilla.gnome.org/show_bug.cgi?id=469748#c17

der_vegi (m-may) wrote :

Heho! It works in Hardy daily-live 20071211!

Changed in gnome-power-manager:
status: Confirmed → Fix Released
der_vegi (m-may) wrote :

Now, in Hardy final, this appears again... When I try to set the display brightness with the Fn-keys, the status is displayed (around 80 %, which could be right) but does not change.
Using Hardy amd64 with all updates applied.

Changed in gnome-power-manager:
status: Fix Released → New
racoon97 (racoon97) wrote :

Yes, for me It's have worked with apha 5 but since beta, doesn"t works anymore.
For me, the status is displayed around 25-30 % and nothing can't change this.

Dovel (dov01) wrote :

There is a fix for this issue, but I do not know how to make a patch (yet) to submit. The fix is found @ http://www.ubuntu1501.com/2008/04/overview-of-ubuntu-804-hardy-heron-on.html . and was blogged by aaronmt (http://www.blogger.com/profile/00032734089773880467).

<quote>
To fix brightness, it's easy as just editing two script files. No bios change whatsoever.

sudo gedit /etc/acpi/video_brightnessup.sh

replace everything in the file with

#!/bin/bash

CURRENT=$(grep "current:" /proc/acpi/video/VGA/LCD/brightness |awk '{print $2}')

case "$CURRENT" in

100)
echo -n 100 > /proc/acpi/video/VGA/LCD/brightness;
;;
87)
echo -n 100 > /proc/acpi/video/VGA/LCD/brightness;
;;
75)
echo -n 87 > /proc/acpi/video/VGA/LCD/brightness;
;;
62)
echo -n 75 > /proc/acpi/video/VGA/LCD/brightness;
;;
50)
echo -n 62 > /proc/acpi/video/VGA/LCD/brightness;
;;
37)
echo -n 50 > /proc/acpi/video/VGA/LCD/brightness;
;;
25)
echo -n 37 > /proc/acpi/video/VGA/LCD/brightness;
;;
12)
echo -n 25 > /proc/acpi/video/VGA/LCD/brightness;
;;
*)
echo -n 100 > /proc/acpi/video/VGA/LCD/brightness ;
;;
esac

sudo gedit /etc/acpi/video_brightnessdown.sh

replace everything in the file with

#!/bin/bash

CURRENT=$(grep "current:" /proc/acpi/video/VGA/LCD/brightness |awk '{print $2}')

case "$CURRENT" in

12)
echo -n 12 > /proc/acpi/video/VGA/LCD/brightness;
;;
25)
echo -n 12 > /proc/acpi/video/VGA/LCD/brightness;
;;
37)
echo -n 25 > /proc/acpi/video/VGA/LCD/brightness;
;;
50)
echo -n 37 > /proc/acpi/video/VGA/LCD/brightness;
;;
62)
echo -n 50 > /proc/acpi/video/VGA/LCD/brightness;
;;
75)
echo -n 62 > /proc/acpi/video/VGA/LCD/brightness;
;;
87)
echo -n 75 > /proc/acpi/video/VGA/LCD/brightness;
;;
100)
echo -n 87 > /proc/acpi/video/VGA/LCD/brightness;
;;
*)
echo -n 50 > /proc/acpi/video/VGA/LCD/brightness ;
;;
esac

</quote>

There are several positive responses to it with different BIOS releases. Worked great on my 1501 running the 32bit distro.

Isn't this a bug with HAL though, not gnome power manager?

Dov

der_vegi (m-may) wrote :

Well, the file to edit is in the package acpi-support. Thanks for the fix, I will try that later...

der_vegi (m-may) wrote :

Thanks very much, this works for me!

Hi all.

In my Compaq Presario C708LA the display brightness not change. Is a problem of Hardy?

Thanks,

Marlon.

Changed in gnome-power:
status: Unknown → Fix Released
Augusto Santos (mkhaos7) wrote :

Hello,
Just to let you guys know. The workaround proposed by Dov-El worked like a charm with my Dell Vostro 1000 with Kde3.
Before i was having some issues with multiple key presses but these got fixed with the latest guidance updates.

der_vegi (m-may) wrote :

Works in Intrepid Alpha 6 for me, although the applet showing the brightness status while changing it, behaves a little bit strange: The brightness bar jumps forward and backward until it reaches the maximum.

Daniel T Chen (crimsun) on 2008-10-05
Changed in gnome-power-manager:
status: New → Invalid
Changed in acpi-support:
status: New → Fix Released
der_vegi (m-may) wrote :

So this is not going to be fixed in Hardy? In 8.04.1, this bug is still present.

Dovel (dov01) wrote :

Not sure if it will be fixed in Hardy, I used the fix posted above and haven't had any problems since. Brightness works fine in Intrepid, with the power manager resetting the brightness for battery conservation as well.

dov

Changed in gnome-power:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.