Login screen doesn't always appear

Bug #1001908 reported by amcnea
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)

Bug Description

After upgrading to 12.04 upon closing my laptop lid it locks the system and prompts for login/password upon reopening the lid. Even if the option is set not to do so, however, this is detailed in bug #995840. In addition to this the login screen doesn't always appear. Sometimes it is just a blank screen of my desktop with no way to input or do anything through the GUI. This never happens during the initial login from a fresh boot, and I haven't tested it comming back from suspend or hibernate.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
florin (florin-arjocu) wrote :

I think it is needed some logs, kernel versions, etc.

florin@florin-Satellite-C650:~$ uname -a
Linux florin-Satellite-C650 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
amcnea (amcnea) wrote :

uname -a
Linux sam 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1001908/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → gnome-power-manager (Ubuntu)
Revision history for this message
amcnea (amcnea) wrote :

Update: After disabling all locking in "Brightness and Lock" control panel (switch lock to off, and unselecting the "Require my password when waking from suspend"), the problem still persists. Though less frequently.

So, far I can go into another terminal Ctrl+Alt+F1 and run:

ps ax | grep lightdm

4485 ? Ssl 0:00 lightdm
 6230 tty7 Ss+ 0:06 /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
 6345 ? Sl 0:00 lightdm --session-child 12 23

By killing "lightdm --session-child 12 23" I can get my system to unlock. However, this kills my current session and a new session is automatically generated. I am then brought to the login screen and can login as normal. It's not to good, but better then a hard reboot.
Furthermore, I tried going into gconf-editor and taking a look at what the actual stored values for gnome-power-manager are since that was named by Professor Jeggletitten. However, there are no entries for gnome-power-manager. The entire /apps/gnome-power-manager folder/entry is missing. Has this info been moved somewhere else?

Revision history for this message
amcnea (amcnea) wrote :

I found the settings have been moved to dconf (Install dconf-tools from the repo and you can run dconf-editor).

I have been playing with the options in org.gnome.desktop.lockdown, options in org.gnome.desktop.screensaver, and org.gnome.settings-daemon.plugins.power.

Particulary "sleep-inactive-ac-type", "sleep-inactive-battery-type", and "disable-lockscreen".

Anyways, I'll let you know if anything seems to work.

Revision history for this message
jeff elkins (jeffelkins) wrote :

This bug affects my Asus laptop. Close lid, hard freeze except for mouse.

Revision history for this message
Dave Vree (hdave) wrote :

Brand new system76 laptop here running 12.04 64bit and seeing this exact same behavior.

Revision history for this message
Tikken Grey (tikken) wrote :

I have experienced what this bug report describes since installing 12.04 with default settings.
when I close the lid, and re-open the lid, I find I've been dropped from the network, and reconnects.
I changed Power Setings to:
  suspend when inactive for: don't suspend // don't suspend
  when the lid is closed: do nothing // do nothing
If I keep the lid closed for more than a second, it usualy results in a black screen, though some times a partial screen. Lid closed for a second or less will often return to the visual state.
I've since tried entring my password at this "screen state" ... pretending its at the "unlock" screen but to no effect.

Just tested again -- closing lid momentarily, for less than one second... went to the "lock" screen upon opening screen, and when it returned me to main screen, vpnc was still connected to remote router, Remmina was still running (my primary application), but Compiz crashed (crashes once a week - I assume unrelated)

There are other oddities I experience wth 12.04, so I'll reinstall to help ensure it wasn't me trying to make this do something the Unity devs don't want done - though it started as a fresh install.

primary applications are vpnc and remmina - everything else is secondary

Revision history for this message
Tikken Grey (tikken) wrote :

I took the time to write the above blurb because was tired of having the graphics system unresponsive/unavailable after opening the lid.

However, as part of writing the above, I unchecked & rechecked all related settings in Power Options, and now when I test again for multiple seconds at a time, laptop network remains connected to remote sessions ... asks for a password to unlock. Previuously it would drop the network and/or blacken the GUI (could shift to alt terminal sessions), and that was relatively unacceptable (relatively, for it's taken me months to add to a bug report).

I can only guess now that the issue is hopefully since been patched, but the old settings/configs were still a problem, so when unconfiguring & reconfiguring, the bad bits are reset. --shrug--

tested a few times now, and each time, after lifting the lid, the screen is still black, and wifi is working, so I move the mouse, nothing happens, and after about 6-10 seconds, I move the mouse again and get the unlock screen prompt.

Revision history for this message
Tikken Grey (tikken) wrote :

Sorry for the bad tidings...
Made use of the new-to-me feature: Lid was closed about 10 minutes, opened the lid, moved the mouse, and the mouse was immediately visible - the screen never returned from 'black.'
Logging into a new tty shell showed nothing notable (diffing a before & after ps aux)

Revision history for this message
Dave Vree (hdave) wrote :

I suspect this may be a duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/966744

But perhaps it is just related....

Revision history for this message
Jasper Floor (jasperfloor) wrote :

FWIW, I have noticed this behavior as well. Confronted with a black screen I ctrl-alt-f1 to a console and then back (actually, I tend to walk back along f2, f3... but that isn't necessary, I'm just weird). This brings back the screen so I think there is just an screen update missing somewhere.

Revision history for this message
Alik (kilaka) wrote :

Happened to me 2 times on a fresh install (12.04) upgraded to to (12.04.1).
ctrl+alt+F1 and back to UI (ctrl+alt+F7) doesn't help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers