gpilotd Crash

Bug #9513 reported by Mike McCabe on 2004-10-27
8
Affects Status Importance Assigned to Milestone
gnome-pilot (Ubuntu)
Medium
Sebastien Bacher

Bug Description

gpilotd crashed when I was syncing the ToDo list with evolution. Below is the
test of the Backtrace without debugging symbols. I have succesfully synced this
palm with this laptop using other applications.

__kernel_vsyscall ()
#0 0xffffe410 in __kernel_vsyscall ()
#1 0x40a6b42b in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0x400a23dd in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3 <signal handler called>
#4 0x40c2159c in memcpy () from /lib/tls/i686/cmov/libc.so.6
#5 0x40af85cf in dlp_response_read () from /usr/lib/libpisock.so.8
#6 0x40af88fe in dlp_exec () from /usr/lib/libpisock.so.8
#7 0x40afa5d3 in dlp_OpenConduit () from /usr/lib/libpisock.so.8
#8 0x08053f9b in main ()

Thread 2 (Thread 1101736880 (LWP 10388)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0x40c76b93 in poll () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2 0x40a9581d in g_main_loop_get_context () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3 0x40a94d4a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4 0x40a953a3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#5 0x409f9050 in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#6 0x40aea398 in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#7 0x41ab2ad8 in ?? ()
No symbol table info available.
#8 0x40aacabf in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#0 0xffffe410 in __kernel_vsyscall ()

Sebastien Bacher (seb128) wrote :

apparently not corresponding upstream bug about this and I've no palm to test.
Anybody else with a palm to work on this ?

Sebastien Bacher (seb128) wrote :

do you know how to rebuild a package with debugging symboles ?
it could be useful to get a full backtrace ...

Sebastien Bacher (seb128) wrote :

no news in one month, bug closed. Feel free to reopen with details if this still
happens.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.