Ubuntu

[FFE] New upstream release 2.0.17

Reported by Martin Pitt on 2009-03-26
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-pilot (Ubuntu)
Wishlist
Martin Pitt

Bug Description

Binary package hint: gnome-pilot

We have a very old gnome-pilot in Jaunty. It should be updated to support more current devices, as well as working with latest hal.

gnome-pilot 2.0.17 'Pippi', 2009-01-07
--------------------------------------
Bug Fixes:
   - #484509: Avoid obsolete HAL info.bus API. Use hal pda.platform
                property instead (keep info.bus for backwards compatibility).
                With thanks to Frederic Crozat.
   - #528701: remove unused applet desktop file
   - #508262: fix long-standing build-order bug by moving libgpilotdcm
                code to gpilotd/ directory.
   - #491921: stray slash breaks rpath for libraries

Updated translations:
     ar (Djihed Afifi)
     ca (Gil Forcada)
     el (Simos Xenitellis)
     en_GB (Philip Withnall)
     fr (Stephane Raimbault)
     it (Luca Ferretti)
     fi (Ilkka Tuohela)
     nb (Kjartan Maraas)
     ne (Pawan Chitrakar)
     oc (Yannig Marchegay)
     pt_BR (Jonh Wendell)
     sv (Daniel Nylander)
     vi (Clytie Siddall)

gnome-pilot 2.0.16 'Quixote', 2008-02-27
----------------------------------------
New Features:
   - Support for Bluetooth sync, via the bluez support in
     pilot-link 0.12
   - Support for specification of the PDA charset via
     the configuration applet (Jerry Yu and Matt Davey)

Bug Fixes:
   - (Ubuntu bug #81396): don't close a database if we got
      an error when opening it.
   - #464385: use LINGUAS file (Gilles Dartiguelongue)
   - #410666: 64 bit compatibility in file_conduit (Devin Carraway)
   - #431145: avoid circular dependency between libgpilotdcm and libgpilotd
   - #400554: Add intltool support to the gnome-pilot applet. (Kjarten
      Maraas)
   - #399039: add HardwareSettings to categories (Denis Washington)
   - #385434: make sysfs/usbfs check linux-specific (Jerry Yu)
   - #385444: [solaris] workaround for lack of sync notification (Jerry Yu)

Related branches

Martin Pitt (pitti) wrote :

Subscribing Sebastien, since he approves GNOME desktop FFEs.

Sebastien Bacher (seb128) wrote :

confirming, the upgrade is not a stability issue for any desktop components and should give better support for some devices let's do that before jaunty

Changed in gnome-pilot (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Martin Pitt (pitti) wrote :

Available in ubuntu-desktop PPA now:

https://launchpad.net/~ubuntu-desktop/+archive/ppa

It still starts and the structure didn't change a lot. Beyond that I can't test it much, I'm afraid.

Changed in gnome-pilot (Ubuntu):
assignee: nobody → pitti
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

I asked for testing feedback in bug 334446, who has some Palm owners subscribed.

Alan Pope ㋛ (popey) wrote :

Whilst I experienced by 349650 in 2.0.17, I also had it with 2.0.15, and the sync itself appeared to work just fine, so not a regression in 2.0.17.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-pilot - 2.0.17-0ubuntu1

---------------
gnome-pilot (2.0.17-0ubuntu1) jaunty; urgency=low

  * New upstream release: (LP: #348940)
    - Support for Bluetooth sync, via the bluez support in pilot-link 0.12
    - Support for specification of the PDA charset via the configuration
      applet.
    - Several bug fixes.
    - Translation updates.
  * Dropped patches which got accepted/fixed upstream:
    - gp-link
    - gp-missingsymbol
    - pointer-size_on_amd64.dpatch
    - work-with-new-hal.dpatch

 -- Martin Pitt <email address hidden> Thu, 26 Mar 2009 13:03:24 +0100

Changed in gnome-pilot:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers