gpilot-applet crashed with SIGSEGV in g_main_context_dispatch()

Bug #189389 reported by nico9julio on 2008-02-05
128
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Gnome-Pilot
Fix Released
Medium
gnome-pilot (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-pilot

When upgrading to 8.04 from 7.10 when the system starts up, it keeps carashing.

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Tue Feb 5 14:11:51 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/gpilot-applet
NonfreeKernelModules: nvidia
Package: gnome-pilot 2.0.15-2ubuntu2
PackageArchitecture: amd64
ProcCmdline: /usr/bin/gpilot-applet --oaf-activate-iid=OAFIID:GNOME_PilotApplet_Factory --oaf-ior-fd=31
ProcCwd: /
ProcEnviron:
 LANG=es_AR.UTF-8
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 SHELL=/bin/bash
Signal: 11
SourcePackage: gnome-pilot
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /usr/lib/libglib-2.0.so.0
 g_main_context_dispatch ()
 ?? () from /usr/lib/libglib-2.0.so.0
Title: gpilot-applet crashed with SIGSEGV in g_main_context_dispatch()
Uname: Linux Conpron-UbuntuGG 2.6.24-5-generic #1 SMP Thu Jan 24 19:29:14 UTC 2008 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev sambashare scanner video
SegvAnalysis:
 Segfault happened at: 0x406837 <g_slist_free@plt+10071>: mov 0x18(%rax),%eax
 PC (0x00406837) ok
 source "0x18(%rax)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA

nico9julio (nico9julio) wrote :

StacktraceTop:pilot_draw ()
timeout ()
g_timeout_dispatch (source=0x6bbd20,
IA__g_main_context_dispatch (context=0x6471f0)
g_main_context_iterate (context=0x6471f0, block=1,

Changed in gnome-pilot:
importance: Undecided → Medium
Connor Imes (ckimes) on 2009-05-24
visibility: private → public
Matt Davey (mcdavey) wrote :

Does this still occur after applying patch in bug #349650? (I don't think that patch has yet been packaged, but you should be able to rebuild following instructions in that bug).

CPKS (c-1) wrote :

Experienced this for the first time in Karmic alpha 3, Linux ... 2.6.31-5-generic #24-Ubuntu SMP Sat Aug 1 12:47:58 UTC 2009 x86_64 GNU/Linux

Matt Davey (mcdavey) wrote :

which gnome-pilot package do you have installed? If it isn't 2.0.17-0ubuntu2, try updating. If it is, please send a full debug trace, etc.

CPKS (c-1) wrote :

Adding to #5 and replying to #6: this occurred when removing a duplicate gpilot-applet icon from the GNOME panel. Specifically, multiple such icons were appearing. On removing one of them, the selected icon disappeared immediately; after about a second, the remainder disappeared at the time of the crash.

This was provoked by a mis-configuration, brought about as follows: under Jaunty, the gpilot-applet does not display on the GNOME panel. Hence, I added the applet, saw no feedback, and thinking (wrongly) that I had done something wrong, I repeated the operation. I then installed Karmic on top of the Jaunty install. When booted, GNOME under Karmic displayed all the duplicate applet icons.

Debug traces were supposedly uploaded using Apport. However, when I had removed all gpilot-applet elements from the GNOME panel, the crashes desisted and I cannot now reproduce the problem. All related Apport data in /var/crash now deleted by the system.

Please let me know if I can help further in tracking this down.

CPKS (c-1) wrote :

Correction to #7: this is easily reproducible. Right-click on panel, select "add to panel" from menu, select Pilot applet, click twice on "Add" dialog button. Two applet icons appear in the panel. Close the dialog. Right-click one of the gpilot-applet icons and select "remove from panel" from menu. Crash occurs. Manually attached debug info from /var/crash/.

Kees Cook (kees) on 2009-09-16
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-pilot - 2.0.17-0ubuntu4

---------------
gnome-pilot (2.0.17-0ubuntu4) lucid; urgency=low

  * debian/patches/fix-timeout-segfault.dpatch: fix segfault caused by
    timeout handler running during shutdown. (LP: #189389)
 -- Marc Deslauriers <email address hidden> Mon, 01 Mar 2010 17:51:26 -0500

Changed in gnome-pilot (Ubuntu):
status: New → Fix Released
Changed in gnome-pilot:
status: Unknown → Fix Released
Changed in gnome-pilot:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.