Ubuntu

sync on feisty with Palm m130, 'visor' kernel module not loaded

Reported by Matthew Helmke on 2007-04-21
16
Affects Status Importance Assigned to Milestone
gnome-pilot (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-pilot

This is on a fresh install of the feisty final release. I'm connecting the palm m130 to my computer via cradle and usb.

In edgy the gnome-pilot device settings used /dev/ttyUSB0 and /dev/ttyUSB1.

In feisty I get no connection when I press the sync button on the cradle (although the info appears in System->Preferences->Hardware Manager just fine). Instead, I receive the following error dialog:

"Failed to connect using device `cradle', on port `/dev/ttyUSB0'.
Check your configuration, as you requested old-style usbserial
`ttyUSB' syncing, but do not have the usbserial `visor' kernel
module loaded. You may need to select a `usb:' device."

I can see in gnome-pilot->Devices->Edit->Device where I can select "usb:", but using this setting fails to make any connection at all.

My gut feeling is that I'm missing something simple, but I just can't see it.

I also tried "/dev/pilot" with no success. Only "/dev/ttyUSB0" or "/dev/tty/USB1" get any recognition from gnome-pilot that a connection is even being attempted.

Lynoure Braakman (lynoure) wrote :

I think this is caused by the kernel and not by gnome-pilot. At the earlier kernel on feisty and the same kpilot I have now I could get synching to happen fine, and lsmod would show the visor module. Now the device gets detected, but visor module does not get loaded, and so nothing happens with kpilot.

Matthew Helmke (matthelmke) wrote :

Lynoure: thanks for the input, that was the nudge I needed to get my thoughts together.

I found the "something simple" that I was missing. The solution was quite simple. I'm still using /dev/ttyUSB0 and 1.

Before starting gnome-pilot, open a terminal and type:

sudo modprobe visor

to load the visor module. Then start gnome-pilot and initiate sync from the cradle, as usual, and everything should work (it did for me).

I'll blame my failure to notice this earlier on being sick this week. :)

Matthew Helmke (matthelmke) wrote :

I should add, for those who might be looking for help and don't know this is possible, you can make the module load automatically.

sudo gkedit /etc/modules

add visor to the end of the list, save. You're done..

The thing is that before, visor module would load automatically.
Something is still wrong, but it is nice there is a workaround.

Changed in gnome-pilot:
assignee: nobody → ubuntu-pda
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Matthew Helmke (matthelmke) wrote :

Lynoure: agreed. I've used this Palm with Hoary, Breezy, and Edgy (it had problems with Dapper, though).

Lynoure Braakman (lynoure) wrote :

Hmm, I wonder what has changed. Late last month I could still sync if I loaded the visor module manually. Now doing that does not seem to help any at all. Is this workaround still working for the rest of you?

Matthew Helmke (matthelmke) wrote :

I haven't made any new changes since April 24th, when I made my last comment. Since then, I can boot up and sync immediately without doing anything else. I did add the visor module to the list in /etc/modules on April 24th, so it has loaded automatically since then.

Happens here too, on a Treo 90. The workaround of adding visor to /etc/modules works for me.

Does anyone have an idea yet why the visor module is no longer loaded?

rickyrockrat (rickyrockrat) wrote :

My guess is that something changed in the udev directory. I suspect a keyword is missing/vid/pid in one of these files:
/etc/udev/rules.d/ 60-libpisock.rules or 60-symlinks.rules

Jacob Godserv (fun2program8) wrote :

I can confirm this also applies to my Palm Zire 71. This is a regression bug, I'd assume, since it did work in Edgy?

Aaron Peromsik (aperomsik) wrote :

I think the use of the visor module with gnome-pilot may be deprecated. I don't remember where I saw it, but try changing the device to "usb:" instead of /dev/anything ... that worked for me on a Tungsten C. (I don't know if it will still work if you've already done "modprobe visor".)

Adrianus (adrianus-kurnadi) wrote :

This is one of the several things that already worked in Edgy but didn't work in Feisty.
I also think this is a regression bug.

gsauthof (g-sauthoff) wrote :

Hi,

it looks like it is not a bug, it is a feature ... ;)

The visor module is not loaded anymore after plug-in because it is blacklisted in /etc/modprobe.d/libpisock9. Well, and libpisock9 is some userspace palm communication library, which could be used by pilot-xfer, kpilot etc.

For example:
Instead of:
pilot-xfer -i Aus_meinem_Leben_Erster_Teil.pdb -p /dev/ttyUSB1
Use now:
pilot-xfer -i Aus_meinem_Leben_Erster_Teil.pdb -p usb:

I am bit suprised, that this works for normal users out of the box. Previously, with the device you had to care about right permissions. Thus, does someone know, how to restrict access to the Palm Pilot from userspace. I mean, if I am at a multi user computer, I don't want, that every user is able to communicate with my palm after I attach it to a usb port.

Hm, now I have to find out, how to get the pilot-link people to change their linux readme: http://www.pilot-link.org/README.usb

It's not a wiki :(

Best regards
Georg Sauthoff

gsauthof (g-sauthoff) wrote :

reagarding permissions: you have to be in the group dialout.
see /etc/udev/rules.d/60-libpisock.rules

gsauthof (g-sauthoff) wrote :

btw, does the ubuntu pda team have some email address? I want to forward a mail from a pilot-link.org guy.

He thinks, that using libusb for palm sync by default is not such a good idea (yet). Mail includes some details.

regards

cmnorton (octopusgrabbus) wrote :

Thank you. These instructions solved the same problem on my laptop, which has a fresh feisty installation.

Xamusk (ronanpaixao) wrote :

I can confirm this bug is also present in Gutsy.
One way to fix it is to edit /etc/modprobe.d/libpisock9 and comment the line "blacklist visor".
The other way is to configure gnome-pilot to use "usb:" instead of "/dev/pilot" as device.

lgc (lgcota) wrote :

Manually loading the visor module works for me, but using "usb:" instead of "dev/pilot" just doesn't seem to work with my Z22.

Kai Sandoval (ms.kai) wrote :

I mentioned in Bug #71837 I am also experiencing this issue with a Sony Clie and Ubuntu 8.04 Hardy Heron.

Ms.Kai
May 25, 2008

Thomas Hotz (thotz) wrote :

Does this happen in supported Ubuntu versions? Thank you for telling us!

Changed in gnome-pilot (Ubuntu):
status: Confirmed → Incomplete
Matthew Helmke (matthelmke) wrote :

I haven't even used the Palm in question for at least 4 years. I think it is safe to close this one.

Thomas Hotz (thotz) on 2012-10-04
Changed in gnome-pilot (Ubuntu):
status: Incomplete → Invalid
assignee: Ubuntu PDA team (ubuntu-pda) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers