[feisty] etodo conduit times out when syncing with a palm device

Bug #81170 reported by mangar
110
Affects Status Importance Assigned to Milestone
gnome-pilot-conduits
Fix Released
Critical
gnome-pilot-conduits (Ubuntu)
Fix Released
High
Ubuntu PDA team

Bug Description

Binary package hint: gnome-pilot-conduits

using palm m505, feisty fawn. evolution 2.9.6
when synchronizing evolution and palm, the synchronization times out
when synchronizing the todo list. when disabling the etodo plugin, the synchronization works without a problem.

Revision history for this message
RobotII (pete-arthur) wrote :

I am experiencing this problem in feisty using same evolution and palm tx.

etodo plugin is part of the evolution package so perhaps this should be changed.

I get the following message when trying to sync tasks to pc with no due date.

*** stack smashing detected ***: gpilotd terminated

If I add a due date to the task on the palm, then the sync appears to work in the majority of cases, suggesting this is related to the due date, although perhaps not exclusively.

Revision history for this message
rubinstein (rubinstein) wrote :

I can confirm the exact error message from above. I use Feisty Fawn beta, Palm IIIx. The synchronization hangs at EToDo.

Revision history for this message
Floris Kruisselbrink (vloris) (vloris) wrote :

I can confirm this too. Also using Feisty Fawn, and a Sony Clie T675C.
I can also confirm that the problem goes away when there are no todo items on my clie without a due date, it seems to be a problem related to undated todo items.

The last messages gpilotd shows before the error:

  etodoconduit-Message: add_record: adding [0 1177279200 1 0 'Censored' '[14-99:99 s000.... ]' 3] to desktop
  etodoconduit-Message: add_record: adding [0 1179698400 1 0 'Censored' '[14-99:99 s000.... ]' 3] to desktop
  etodoconduit-Message: add_record: adding [1 -1 1 0 'Censored' '' 2] to desktop
  *** stack smashing detected ***: /usr/bin/gpilotd terminated
  Aborted (core dumped)

The Cencored texts where different, but are not relevant I hope. They all contain only normal alphabetical characters, I had an @ sign in the last one but replaced that by 'at' for the last one, just to be sure that wasn't the problem. I do have the coredump if that is of any use, but there is no gpilot ubuntu package with debugging symbols as far as I could see.

Revision history for this message
thinapps (pierre-vannier) wrote :

Confirmed also on palm treo 680. Sync hangs when etodo's synchronisation is choosen.

Revision history for this message
Byeong-Taek Lee (btlee) wrote :

I confirm this bug.
Interestingly, it seems to happen when the due date is empty.
is there anyone to confirm this?

Revision history for this message
Floris Kruisselbrink (vloris) (vloris) wrote :

> Interestingly, it seems to happen when the due date is empty.
> is there anyone to confirm this?
Yes, that's what I said in my reply, and also what RobotII said in the first reply

Revision history for this message
Charl P. Botha (cpbotha) wrote :

I can confirm this bug with a Palm Tungsten C and the Ubuntu Feisty beta (up to date as of 2007-03-10). EToDo continues forever, the palm pilot times out eventually. Disabling the EToDo conduit allows the sync to complete successfully.

Revision history for this message
Brett Johnson (linuxturtle) wrote :

I'll also confirm this same bug with a Tungsten T5. Adding a due date to all todos sucks, but seems to work around the problem.

Sadly, I'm guessing this won't get fixed in time for the feisty release :o(

Revision history for this message
Luke Orland (orluke) wrote :

The behavior i have noticed is that syncing hangs when the EToDo conduit is set to 'Synchronize' or 'Copy from PDA'. It does not hang (I think) when the conduit is set to 'Copy to PDA'.

Also, when the the syncing is continuing indefinitely, the pilot applet is stuck - Restarting it does nothing. It is necessary to remove the applet from the gnome panel and add it again.

I am using Feisty and a Treo 600.

Revision history for this message
spiderwort (ironweed) wrote :

It also happens with the newest feisty Evolution (as of 4/14/2007...2.10.1) and a Palm as old as a Handspring Platinum. So, it has nothing to do with the newer structure of the Palm databases in the Tungstens and Treos. All I did was add a due date to my undated ToDos, and it worked fine.

By the way, killing the gnome-pilot process from a terminal works as well, and it nicely asks if you want to reload it, so it will put it back on the panel for you.

Revision history for this message
vasilis (vtsolis) wrote :

Same here
Feisty updated
Palm E2
Evolution 2.10

Backup+ Etodo in default does not work.
I havent tried the above suggestions but

Revision history for this message
vasilis (vtsolis) wrote :

Apologies.. for the double message.

But if you configure Etodo : send to pda, then it seems to work flawlessly.

Revision history for this message
erm67 (erm67) wrote :

The problem remains in FeistyFawn release synchronizing with a Tungsten T

Revision history for this message
Oliver Richards (richaoj) wrote :

Broken with a TX as well. Does anyone have a workaround? perhaps loading the old Etodo conduit which worked fine for me for a long time in dapper and edgy?

Revision history for this message
rodrigouroz (rodrigouroz) wrote :

I have a Palm TX and Feisty and I have the same problem.

Changed in gnome-pilot-conduits:
status: Unconfirmed → Confirmed
Revision history for this message
naked (luke-enterlife) wrote :

Same problem with Treo 680 and Feisty.

Is there going to be any work done on this?

Changed in gnome-pilot-conduits:
assignee: nobody → ubuntu-pda
importance: Undecided → High
Revision history for this message
DWHagar (david-hagar) wrote :

I have a T3 and ToDo works perfectly for me, but other things don't work.

Who do I report my other issues to?

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) wrote :

Yup, hsppening here with Palm TX syncing over wireless with todo items with no date.

Revision history for this message
Thomas_a55 (thomas-a55) wrote : RE: [Bug 81170] Re: [feisty] etodo conduit times out when syncing with apalm dev

I can agree to todo- items without a date but the sync was made via
USB.........

Regards
Thomas

_________________________________________________________________
Need a break? Find your escape route with Live Search Maps.
http://maps.live.com/default.aspx?ss=Restaurants~Hotels~Amusement%20Park&cp=33.832922~-117.915659&style=r&lvl=13&tilt=-90&dir=0&alt=-1000&scene=1118863&encType=1&FORM=MGAC01

Revision history for this message
Kip Warner (kip) wrote :

Confirmed. Treo 650 via USB. Hangs on "EToDo: Started". If I disable that conduit, it completes just fine.

Kip

Revision history for this message
MoLE (moleonthehill) wrote :

I can confirm also - Palm Tungsten T via USB. Disabling the todo conduit allows the sync to complete successfully.

Revision history for this message
Paul Flint (flint) wrote : Re: [Bug 81170] Re: [feisty] etodo conduit times out when syncing with a palm device

Dear Kip,

Thanks! I will try this immediately!

Regards,

Flint

On Mon, 7 May 2007, Kip Warner wrote:

> Date: Mon, 07 May 2007 21:30:41 -0000
> From: Kip Warner <email address hidden>
> Reply-To: Bug 81170 <email address hidden>
> To: <email address hidden>
> Subject: [Bug 81170] Re: [feisty] etodo conduit times out when syncing with a
> palm device
>
> Confirmed. Treo 650 via USB. Hangs on "EToDo: Started". If I disable
> that conduit, it completes just fine.
>
> Kip
>
> --
> [feisty] etodo conduit times out when syncing with a palm device
> https://bugs.launchpad.net/bugs/81170
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

/************************************

Paul Flint
17 Averill Street
Barre, VT
05641

http://www.flint.com/home
skype: flintinfotech
Work: (202) 537-0480
  Fax: (703) 852-7089

Free advice .~.
is worth /V\
exactly what /( )\
you pay for it. ^^-^^

Revision history for this message
Sebastian Schauenburg (sschauenburg) wrote :

I also confirm this bug for the Palm Zire connected via USB on a Feisty machine. The bug is clearly in the EToDo synching process (disabling it or setting a due date to each todo item, seems to solve problem). I have not tested it extensively.

Revision history for this message
Mischko (scott-mischko) wrote :

I have seen the same bug with the Handspring Treo 700. Same symptoms, etc.

Revision history for this message
Rudd-O (rudd-o) wrote :

I can confirm this bug on a T|X, latest Evo, same bug. When I set a due date on a ToDo item that was entered on the palm, the sync completed flawlessly.

Revision history for this message
Brad Langhorst (brad-langhorst) wrote :

This also happens with my treo 600
I can confirm that choosing copy to pda instead of sync for the todo applet makes the sync work okay.

Revision history for this message
Sean (defulmere) wrote :

Same thing for me, with a Clie SJ-20.

I've noticed that if I create a todo on my PDA, then everything works as has been noted here. Then, if I remove the due date from the item (either on the PDA or in Evo) and sync again, there are no problems.

Changed in gnome-pilot-conduits:
status: Unknown → Needs Info
Revision history for this message
Brad Langhorst (brad-langhorst) wrote :

what info is needed?

Revision history for this message
Daniel Holbach (dholbach) wrote :

Can we get another backtrace of the problem? Does this happen with feisty or gutsy? If so, please attach the full crash report file to the bug.

Changed in gnome-pilot-conduits:
status: Confirmed → Needs Info
Revision history for this message
Kip Warner (kip) wrote :

I think the bug may be in /usr/share/gnome-pilot/conduits/e-todo-2.10.conduit which is a part of the evolution-common package, not gnome-pilot-conduits.

Revision history for this message
Kip Warner (kip) wrote :

Correction, that is just meta information on the actual binary library /usr/lib/evolution/2.10/conduits/libetodo_conduit.so

Revision history for this message
Sean (defulmere) wrote :

See attached for gpilotd crash output on Feisty. No actual crash dialog is raised.

Revision history for this message
Philipp (philipp30) wrote :

I use Feisty with newest patches (as of today) and a Palm m505. I deactivated all conduits but etodo.
gpilotd output is attached. I can confirm that no crash dialog is raised.

Revision history for this message
Kip Warner (kip) wrote :

Sorry, but what patch? Was a newer build of Evolution released in the repository? I just checked on aptitude and I don't see anything.

Revision history for this message
Philipp (philipp30) wrote : Re: [Bug 81170] Re: [feisty] etodo conduit times out when syncing with a palm device

Sorry I misrepresent that. I just meant that I applied all updates
ubuntu suggested via the automatic update function. I didn't apply any
specific evolution updates.

Revision history for this message
ptillemans (pti) wrote :

I concur with the findings of Philipp.

I use a Palm TX. I experienced the crash consistently till today. I applied the reommended upgrades.

I reenabled the ETodo plugin and it now works flawlessly.

Whatever the problem was, it is fixed.

I am a very happy camper now :).

Revision history for this message
Philipp (philipp30) wrote :

What upgrades exactly did you apply, ptilleman? The ones that ubuntu is
automatically recommending?

As far as I can tell it is still not working. No crash dialog is raised,
but the sync times out (see gpilotd.log which I attached in my earlier
comment).

Revision history for this message
Kip Warner (kip) wrote :

Yes, what upgrade are you being prompted for? I see nothing on aptitude in the updates after I update the listing.

Kip

Revision history for this message
Galen Thurber (godfree2) wrote :

oh it's just another user problem ;^)

pi_bind error: /dev/pilot No such file or directory
Check your serial port and settings
Exiting with status SYNC_ERROR_BIND
Finished

I just 'upgraded' to fiesty,

Revision history for this message
Galen Thurber (godfree2) wrote :

oh it's just another user problem ;^)

pi_bind error: /dev/pilot No such file or directory
Check your serial port and settings
Exiting with status SYNC_ERROR_BIND
Finished

I just 'upgraded' to feisty,

Revision history for this message
coachmike (mehling) wrote :

Unlike other lucky souls, my eToDo conduit continues to hang despite updates. model: T|3, on feisty.

Mike

Revision history for this message
le_jawa (le-jawa-gmail) wrote :

PDA Team,

I just observed this bug today (June 11, 2007) with my Tungsten T2, and have been trying to find a workaround/fix for it. I found this bug report and see that its status is "Needs Info". What info do you need? I will be happy to provide any information I can.

Jason

Revision history for this message
MeneM (maas-mark) wrote :

Hi,

Also available for whatever info you need on this. Please do help me with telling me how to get such info though...

Revision history for this message
Chris Dzombak (chris.dzombak) wrote :

I can confirm this bug with a Tungsten E.

Revision history for this message
Matt Mossholder (matt-mossholder) wrote :

Confirmed on Treo 600

Revision history for this message
Tom Eisenmenger (teisenmenger) wrote :

Also want to confirm bug using Feisty release 7.04 with all updates, Evolution 2.10.1, brand new Palm Tungsten E2 using USB connection.

Revision history for this message
Michael B. Trausch (mtrausch) wrote :

+1 User Affected

Using Feisty (7.04), fully updated, and a Palm V device using a serial connection as well as USB connection on the main PC.

EToDo goes from the PC -> Palm, but not the other way, it seems, at least in my case. I failed to save the crash, however... is another one needed? If so, I believe that I can trigger the bug again by backing up my Palm and doing a reset on it, because when I attempted the first sync, it was with all of the default things on the Palm.

Revision history for this message
tdionne (tim-ruffrecordings) wrote :

+1

Using Feisty (7.04) and a Palm Z22.

So it's clear that this is a real bug. What are the chances of getting this resolved in the next month?

Revision history for this message
Kip Warner (kip) wrote :

It depends how long it takes you to fix it =)

Revision history for this message
Kevin McAllister (mclazarus) wrote :

I am trying to track it down, but am having a hard time. Every time I try and get a back trace no matter how many different dbgsym packages I install there always seems to be parts for which I don't have symbols, and they all appear to be in the thread that is being accused of the stack smash.

The first thing I did is do an ldd on the gpilotd binary and got dbgsym packages for all of the resulting files (well their packages.)

Can anyone suggest a better way of trying to track this down. I'm happy to do the legwork, because I want it fixed. I am just having a hard time getting started. I am going to keep plugging away, but if someone can give me some guidance I would gladly accept it.

Revision history for this message
Mick (freeipod-dos) wrote :

Put this in the FWIW category.

New Linux install. (Ubuntu Studio)

New Evolution install, with importing all my email.

etc...Hotsync would stop at EToDo sync.

Also the Palm had sat for a while, and the onboard memory had been wiped back to original..so no stored anything...EXCEPT for a demo item in the TO DO list...

...that item on the palm to do list ALSO didn't have a due date...

I made sure I had a due date in the Evolution task I made...and I put one in the Palm's To Do list.

I hit the button, and now it syncs both ways. so to speak.

SO the bug has to do with the due date...the work around seems to be put a due date on whatever new task you create.

Revision history for this message
Matt Davey (mcdavey) wrote :

Note that a patch has now been produced for the todo conduit, that is reported to fix the 'no due date' bug.

See http://bugzilla.gnome.org/show_bug.cgi?id=442329
and https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249640
for details.

Any success reports would be very gratefully received as it will speed the adoption of the patch into Evo.
Matt

Changed in gnome-pilot-conduits:
status: Incomplete → Confirmed
Revision history for this message
Heather Van Wilde (heatheriac) wrote :

Same problem as before, but with a different twist:

Using Handspring Visor

All current updates to Feisty, Evo and gnome-pilot

With the eToDo conduit enabled to synchronize, it locks up just like everyone else's does. However, I have no items in either the Evo database or the Visor's, so it should just be seeing an empty database and ignoring. On a side note, any idea why the eMemo conduit doesn't show anything in evo?

Revision history for this message
PFar73159 (pfar73159) wrote :

Matt Davey you asked for success reports.

Thank you Fabrice Bellet!

I just started using evolution on Ubuntu. I have an old hand-me-down Handspring Visor that I have been playing with and I ran in to the same bug with the undated todo item that the firmware puts in there when the Visor is reset. That brought me to this thread.

I am just finding my way through evolution. I have not gone through the todo-conduit.c code completely, but I applied the patch described in bugzilla. That makes sense to me as a fix. I don't think it is a pilot-link bug. I think the problem is that the date value in the visor is not initialized and has garbage in it. I think probably, the code for the pilot todo application should be fixed to iniitiaiize correctly. I could be wrong about that. I have not run a debugger on the conduit to see that there really is garbage in the date value.

To fix it:

I did a "make" and "make install" in /usr/src/evolution/2.10/calendar/conduits

I replaced libetodo_conduit.so

I also did a full "./configure" and "make all" and "make install" for evolution, which took a long time and I don't think I really needed to do that.

Now the Visor successfully syncs with evolution including the undated todo item.

Revision history for this message
Chris Dzombak (chris.dzombak) wrote :

When might we see an update to resolve this problem in Ubuntu?

Revision history for this message
Richard Perry (perryrt) wrote :

I can confirm the bug with one exception. In my case (Treo 700, Ubuntu feisty, Evolution 2.10) I got this bug initially, went into my Treo and fixed my ToDo's, and then the sync worked perfectly....one time. After that, nothing. Same problem. Both sides have all tasks with due-dates.

The only thing I haven't tried is to copy my tasks by hand from my Treo to Evolution, and then "Copy to PDA", to see if that clears it up. Unfortunately, I currently have 71 open to-do's , so haven't had the time to do that.

Ok, so now I have 72 to-do's. :^(

Let me know if I can contribute anything more.

Revision history for this message
Paul Flint (flint) wrote : Re: [Bug 81170] Re: [feisty] etodo conduit times out when syncing with a palm device

Dear Richard,

Interesting and funny!
Will I see you in Boston at the end of October?

Regards,

Flint

On Mon, 3 Sep 2007, Richard Perry wrote:

> I can confirm the bug with one exception. In my case (Treo 700, Ubuntu
> feisty, Evolution 2.10) I got this bug initially, went into my Treo and
> fixed my ToDo's, and then the sync worked perfectly....one time. After
> that, nothing. Same problem. Both sides have all tasks with due-dates.
>
> The only thing I haven't tried is to copy my tasks by hand from my Treo
> to Evolution, and then "Copy to PDA", to see if that clears it up.
> Unfortunately, I currently have 71 open to-do's , so haven't had the
> time to do that.
>
> Ok, so now I have 72 to-do's. :^(
>
> Let me know if I can contribute anything more.
>
> --

/************************************

Paul Flint
17 Averill Street
Barre, VT
05641

http://www.flint.com/home
skype: flintinfotech
Work: (202) 537-0480
  Fax: (703) 852-7089

Free advice .~.
is worth /V\
exactly what /( )\
you pay for it. ^^-^^

Revision history for this message
Richard Perry (perryrt) wrote : Re: [Bug 81170] Re: [feisty] etodo conduit times out when syncing with a palm device

On Mon, 2007-09-03 at 20:17 +0000, Paul Flint wrote:
> Dear Richard,
>
> Interesting and funny!
> Will I see you in Boston at the end of October?
>
> Regards,
>
> Flint

Flint -

This is when I scratch my navel and admit I don't think I know you, but
if I do...I really apologize for forgetting you (I am horrible on
names.) There are also quite a few Richard Perrys in the world. I'm the
one in Orlando, FL who works in aviation...

However, that having been said, sure, I'll be there :^) Where are we
meeting? (actually, my old roommate lives in Boston and I've been
meaning to go see him anyway, so what the heck.)

Regards,

The Other Richard Perry (I think I'll be hereafter known as "TORP".)

Revision history for this message
Steven Webb (webbsd) wrote :

Success!

After manually applying this patch I successfully synchronized my todo list.

Note, the original patch didn't apply automatically for me:

Hunk #1 FAILED at 992.
1 out of 1 hunk FAILED -- saving rejects to file evolution-2.10.1/calendar/conduits/todo/todo-conduit.c.rej

(sorry, I don't know what that means). However, I applied it manually and everything worked correctly. I've generated a patch (attached).

Steve.

Revision history for this message
Kip Warner (kip) wrote :

On Sat, 2007-29-09 at 01:43 +0000, Steven Webb wrote:
> Success!
>
> After manually applying this patch I successfully synchronized my todo
> list.
>
> Note, the original patch didn't apply automatically for me:
>
> Hunk #1 FAILED at 992.
> 1 out of 1 hunk FAILED -- saving rejects to file evolution-2.10.1/calendar/conduits/todo/todo-conduit.c.rej
>
> (sorry, I don't know what that means). However, I applied it manually
> and everything worked correctly. I've generated a patch (attached).
>
> Steve.
>
> ** Attachment added: "Fixes todo synchronization error (Bug #81170)"
> http://launchpadlibrarian.net/9575359/todo.patch

I haven't tried it yet, but nicely done!

--
Kip Warner
Software Engineer
http://www.thevertigo.com

Revision history for this message
Chris Dzombak (chris.dzombak) wrote :

I no longer have this problem with the version of Evolution (2.12.0) shipped with Ubuntu Gutsy.

Revision history for this message
James Clemence (jvc26) wrote :

Problem confirmed in Gutsy with evolution 2.12.0 and gnome-pilot-applet 2.0.15
Il

Revision history for this message
Kip Warner (kip) wrote :

That's terrible news. As I understand it, it was already patched above. =( Perhaps it didn't make it into Gutsy in time.

Revision history for this message
Steven Webb (webbsd) wrote : Re: [Bug 81170] Re: [feisty] etodo conduit times out when syncing with a palm device

I upgraded to Gutsy over the weekend and it works fine for me. I'm
using evo 2.12.0 and gnome-pilot applet 2.0.15. I was able to sync
both calendar and todo list items across.

I did get a few fatal exceptions on my m515 and had to reset; however,
I suspect that may be caused by hardware. Will continue to
investigate.

Steve.

On 25/10/2007, Kip Warner <email address hidden> wrote:
> That's terrible news. As I understand it, it was already patched above.
> =( Perhaps it didn't make it into Gutsy in time.
>
> --
> [feisty] etodo conduit times out when syncing with a palm device
> https://bugs.launchpad.net/bugs/81170
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Chris Dzombak (chris.dzombak) wrote :

I am using Gutsy, and I have Evolution 2.12.1. I no longer experience this issue, and I did when using Feisty (and an older Evolution). Might differences in repos enabled be an issue?
I have main, universe, restricted, and multiverse enabled.

Revision history for this message
Seiti Yamashiro (seiti-yamashiro) wrote :

Im using Gutsy too, and the bug no longer occurs like it did in Feisty. Using Palm Z22, Evolution 2.12.0

Revision history for this message
mangar (mycrapaccount-deactivatedaccount) wrote :

The problem was solved in 7.10 final, I think this bug can be closed..
Congrats!

Revision history for this message
mangar (mycrapaccount-deactivatedaccount) wrote :

correction - the problem was no solved.
just happend again.

Revision history for this message
Floris Kruisselbrink (vloris) (vloris) wrote :

The bug is exactly the same in a clean Ubuntu gutsy install as it was with feisty:
gpilotd crashes on todo-conduit if the palm has any todo entries without a due date.

Same workaround still works: always set a due-date on your todo's and the todo-conduit will work fine.

Revision history for this message
Gary (gary-anglersonline) wrote :

I had the same problem in 7.10 Gutsy until I did the following:

Changed the Device Settings Speed to 115200.

Now it no longer freezes on the todo's.

Revision history for this message
William McKee (william-knowmad) wrote :

I am still having this problem in Gutsy despite the upstream link saying that it was fixed in 2.12.x. Increasing Device Settings Speed only made the problem happen faster. I should be able to test a clean install in a couple weeks.

Revision history for this message
William McKee (william-knowmad) wrote :

I've done some more research on this issue and have come to the following discovery. The eToDo conduit wasn't actually freezing. It was the time sync conduit that was causing my PDA to freeze. Try disabling this conduit and see if you can successfully synch your Palm. Read on for more info.

Along the way, what I thought was the etodo conduit freezing was actually the conduit deleting and adding every todo task each time it ran. It was doing this because I had the conduit set to Copy from PDA. To figure this out, I ran gpilotd from the command-line of my user account (not root). You'll need to kill the process if it's already running. The output messages were extremely helpful in tracking down what gpilotd was up to. Interestingly, the process of deleting each task is much more time intensive than adding them all back.

Along the way, what I did find was that the time synchronization conduit was causing a crash while the Palm was displaying the message "Synchronizing To Do List". Try turning off your time sync conduit to see if that helps.

If others get the same result as I am, it looks like we can finally close this ticket and open a new ticket for the time conduit. If you want to keep digging, I suggest reading the info at http://wiki.ubuntu.com/DebuggingProgramCrash to setup debugging. It was very helpful.

Revision history for this message
William McKee (william-knowmad) wrote :

Well, I thought that was the fix, but I'm still getting freezes in Gutsy as well as in Hardy. The exception handling mechanisms in Hardy are better than in the past so I'm sending up a new bug report (see https://bugs.launchpad.net/ubuntu/+source/gnome-pilot/+bug/210221) with trace info from the exception handler that will hopefully help the developer track down and kill this bug before Hardy goes live.

Revision history for this message
fadyek (fadyek) wrote :

Thanks so much for the help. The output messages after running the gpilotd command were really helpful.
Because I couldn't figure out when the bug is going to be solved I could live quite happily with it. I would set due dates to all my todos, and for those that don't have any due date I would set it to the next year. But My real problem came after deleting some unnecessary records that happened not to have due dates. I deleted them while checking the archive option. From the output messages I noticed that the conduit is trying to sync the archived todos and because they don't have any due date it freezes. Problem is I don't see them on the palm to set them a date. They are only in the gpilotd files. Does anyone know how do I totally get rid of these archived todos so that I am able to sync the rest of them that have due dates set?

Revision history for this message
William McKee (william-knowmad) wrote :

Well here's another piece of the puzzle. My comment on 3/26 that all was well was due to me running gpilotd from the command-line. My follow-up reply on 4/1 occurred when I used the gpilot-applet to manage gpilotd. That method is always resulting in a crash. Synching by running gpilotd at a command-prompt as a regular user is always successfully synching. I have loads of ToDo's that have no dates and am not wanting to change my system to get around a bug, esp since there's another workaround. Leaves me wondering what the difference is between running gpilotd manually versus having gpilot-applet manage it.

Revision history for this message
fadyek (fadyek) wrote :

I am still using Ubuntu 7.4 Faisty Fawn. Waiting for 8.4 Hardy to upgrade. So my Evolution is 2.10.1, and hence the bug still exist in my system. According to your comment the bug is not "fully" solved in 7.10: when running the gpilotd as a daemon you still get the crash. So for now I am left with one option which is to set due dates for all my items, but after upgrading to Hardy I can just run gpilotd from the command line.
As for the side issue of the records archived without due date, I managed to delete them by deleting the whole ToDoDB on my palm using filez manager. Of course after copying them in a memo. According to Palm website it is the responsibilty of the desktop (pilot-link in this case) to delete the records marked to be archived from the palm after syncing. Only after the record is saved on the desktop it should be deleted from the palm. Since pilot-link crashed it couldn't delete the records in the pda, thus leaving them hidden in the pda. The next time it syncs the pda doesn't send them to the desktop because for the pda they are already deleted. Therefore they stay always on the pda. Now I can sync fine as long as I have due dates in my records, hoping the problem is solved in Hardy.

Revision history for this message
Matt Davey (mcdavey) wrote :

William: it is very strange that your problems go away when using gpilotd from the command line. This makes me wonder whether you could actually have two copies of gpilotd installed, and two copies of the etodo conduit. Can you check that? (maybe, 'locate gpilotd', and 'locate e-todo.conduit')

Revision history for this message
William McKee (william-knowmad) wrote :

Hi Matt,

Actually I jumped the gun on saying it was always working from command-line. It seems that the first time I sync, it generates a segfault after eToDo. Once it gets through once, it seems to be able to successfully complete the process. Once it completes successfully from command-line, it also completes successfully from the applet. So, I don't think that I have 2 different copies; I just think that my testing had not revealed this behavior (it's hard to tell when the applet's version of gpilotd crashes as I don't know whether there is an output log). Would a backtrace help the maintenance team?

Between the gpilotd crashing and now my calendar items not synching between Evolution and Palm, I'm planning to go back to the good, old reliable JPilot. Hopefully these issues will be resolved in the future.

Revision history for this message
David Futcher (bobbo) wrote :

A patch that supposedly fixes this has been accepted by GNOME Upstream. Could a Maverick tester please check if this has been fixed in Maverick? The bug was closed in November 2009, so it will hopefully have filtered down into Maverick by now.

tags: added: patch-accepted-upstream
Changed in gnome-pilot-conduits:
importance: Unknown → Critical
status: Confirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

closing the bug it should be resolved in the current version

Changed in gnome-pilot-conduits (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.