Gnome-phone-manager doesn't discover any device

Bug #97243 reported by Lionel Dricot on 2007-03-28
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-phone-manager (Ubuntu)
Medium
Bluetooth

Bug Description

Binary package hint: gnome-phone-manager

I have a Nokia 6021 which works fine with nautilus-sendto to send file or gnome-obex-server.

But gnome-phone-manager doesn't show any bluetooth device. Nokia 6021 is well supported since 0.7 according to the changelog.

I suspect that g-p-m doesn't even scan for anything because I also have another bluetooth device (a nokia 770) and both my phone and my 770 are well seen by nautilus-sendto or by hcitool

PS : I'm running the latest feisty here.

Daniel Holbach (dholbach) wrote :

Thanks for your bug report.

Changed in gnome-phone-manager:
assignee: nobody → bluetooth
importance: Undecided → Medium
Sapan (sapan-ganguly-gmail) wrote :

I have this problem too.

Wade Simmons (wadesimmons) wrote :

Having the same problem with Feisty and a RAZR. I can see the phone with hcitool. Here are the messages I see in the console:

** Message: New connection device is empty
** Message: No device!
** Message: Exiting connect thread
** Message: inquiry complete

the last message appears about 1 minute after clicking refresh in the scan devices window.

abulyomon (abulyomon) wrote :

Same problem here .. Ubuntu 7.04

** Message: New connection device is empty
** Message: No device!
** Message: Exiting connect thread
** Message: inquiry complete
conn_complete: status 0x00

Aanjhan Ranganathan (aanjhan) wrote :

Yes. I can report the same with my K750i too.

Changed in gnome-phone-manager:
status: New → Confirmed
Bhavani Shankar (bhavi) wrote :

Yes the same here with my k750i..

James Brost (jbrost) wrote :

It works for me (sending only) with RAZR V3i

Install "bluez-gnome" package and bond Ubuntu with your phone. It will then show up.

Trond Husoe (tr-huso) wrote :

The same goes here.
gnome-phone-manager --gtk-debug=9
** Message: New connection device is empty
** Message: No device!
** Message: Exiting connect thread

When running hcitool scan I get my phone (+ other bluetooth-devices in the area.) It seems as if GPM doesn't use the bluetooth libraries that are on the computer. I have a Dell D420 with onboard BlueTooth.

best
TH

Fredrik Blom (fhm-blom) wrote :

Not much luck here either. I do manage to discover all available devices (phones) though, but I cannot connect to a single one of them.

joris (joris-dobbelaer-gmail) wrote :

This problem is really weird. On my labtop (acer aspire 5610) with a bluetooth usb-stick i can perfectly use gnome-phone-manager for my nokia 6021. I can connect and send and receive sms. On my girl-friends labtop (medion-sim 2070) with a internal bluetooth-connector the gnome-phone-manager is not working. BTW: The bluetooth applet can perfectly connect to the phone and i can browse the phone with nautilus.

On feisty the gnome-phone-manager wasn't working on my own acer labtop. After i did fresh install with gutsy it suddenly worked fine. My girlfriend upgraded from feisty to Gutsy, but i don't know if the phone was working in feisty, because i didn't try. I like to do some debugging, but i do not know how. I don't think my girlfriend really likes it when i make a fresh install only to get gnome-phone-manager working ;)

bluez-gnome and gnome -vfs-obexftp are installed on both computers...

Trond Husoe (tr-huso) wrote :

GPM does not discover my HTC mobile either. Same errormessage as with my old Sony. Not found.

Ketil Malde (ketil-ii) wrote :

I get the same thing:

  ** Message: bdaddr
  ** Message: New connection device is empty (not changed)
  ** Message: New connection device is empty (not changed)
  ** Message: No device!
  ** Message: Exiting connect thread

hcitool and obexfs works, and gnokii --identify seems to indicate things are in order:

  GNOKII Version 0.6.22
  IMEI : 357850008016682
  Manufacturer : Sony Ericsson
  Model : AAB-1022011-BV
  Product name : AAB-1022011-BV
  Revision : R1DB001 R1DB001

Installing bluez-gnome didn't make a difference. (I am not running Gnome, in case it matters)

-k

rbertran (rbertran) wrote :

I have this problem on a Nokia 2730 device. Running Natty. gnokii works like a charm, but gnome-phone-manager do not work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers