SonyEricsson phones can't send SMS

Bug #181909 reported by Stéphane Maniaci on 2008-01-11
6
Affects Status Importance Assigned to Milestone
gnome-phone-manager
Fix Released
Medium
gnome-phone-manager (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Baptiste Mille-Mathias

Bug Description

Binary package hint: gnome-phone-manager

Hi, I'm running Hardy Heron Alpha 2 up-to-date, and I recently installed GPM in its 0.40-3 version, I successfuly connect my v630i SE Phone with Bluetooth, but sending SMS fails (nothing happens, no reception and no tax).

Launching in terminal prints :

steph@steph-desktop:~/gnome-phone-manager-0.8$ gnome-phone-manager
** Message: bdaddr 00:1B:59:AD:6F:0C
** Message: New connection device is 00:1B:59:AD:6F:0C (changed)
** Message: New connection device is 00:1B:59:AD:6F:0C (not changed)
** Message: Connecting...
** Message: Status 1
** Message: Making serial port connection
conn_complete: status 0x00
** Message: Model AAD-3022042-BV not supported natively
** Message: Using driver 'AT'
** Message: Status 2
** Message: Serial port connected
** Message: Connecté au périphérique sur 00:1B:59:AD:6F:0C
** Message: Exiting connect thread
** Message: Couldn't get our own phone number
** Message: driver and phone support sms notifications
** Message: emitting battery

Carl van Tonder (carlvantonder) wrote :

Similar behaviour --- with a k750i, there is additionally no notification on received messages. This functionality with this phone has worked in the past but was broken early in Hardy.

Carl van Tonder (carlvantonder) wrote :

What extra information is needed on this bug to confirm or triage it?

I see the same behariour with my Sony Ericsson W800i; the connection works fine (the below debug output is produced during connection), but SMS messages never reach their recipient.

** Message: bdaddr 00:16:20:33:90:EC
** Message: New connection device is 00:16:20:33:90:EC (changed)
** Message: New connection device is 00:16:20:33:90:EC (not changed)
** Message: Connecting...
** Message: Status 1
** Message: Making serial port connection
conn_complete: status 0x00
** Message: Model AAB-1022013-BV not supported natively
** Message: Using driver 'AT'
** Message: Status 2
** Message: Serial port connected
** Message: Connected to device on 00:16:20:33:90:EC
** Message: Exiting connect thread
** Message: Couldn't get our own phone number
** Message: driver and phone support sms notifications
** Message: emitting battery

I've reported the bug and it is fixed upstream in the version 0.50; so it worth request a Freeze Exception; someone can request that here ?
please notice in the request gnokii as also to be updated to the latest version.

thanks

Changed in gnome-phone-manager:
status: Unknown → Fix Released
Mariusz Cielecki (xodeus) wrote :

it is still not working. v 0.51

mariusz@R4v3R ~/Desktop $ gnome-phone-manager
** Message: bdaddr 00:1E:DC:71:A8:18
** Message: New connection device is 00:1E:DC:71:A8:18 (changed)
** Message: New connection device is 00:1E:DC:71:A8:18 (not changed)
** Message: Connecting...
** Message: Status 1
** Message: Making serial port connection
conn_complete: status 0x00
** Message: starting search
** Message: Using serial channel 3 for device 00:1E:DC:71:A8:18
** Message: Model AAD-3022061-BV using default driver
** Message: Using driver 'AT'
** Message: Status 2
** Message: Serial port connected
** Message: Connected to device on 00:1E:DC:71:A8:18
** Message: Exiting connect thread
** Message: Couldn't get our own phone number
** Message: driver and phone support sms notifications
** Message: emitting battery

Mariusz Cielecki (xodeus) wrote :

Baptiste. I was using gnome-phone-manager 0.51 and gnokii from interpid, but I still getting these errors as above. Is there any workaround?

Daniel T Chen (crimsun) on 2008-11-23
Changed in gnome-phone-manager:
status: New → Confirmed
Stéphane Maniaci (stephh) wrote :

There's patch upstream (see http://bugzilla.gnome.org/show_bug.cgi?id=513491), which has already been commited in Gnokii CVS. So you may need to get the latest Gnokii trunk, and compile GPM trunk with it. Then it should work.

Someone can confirmed the bug is fixed?

Thanks

Changed in gnome-phone-manager:
importance: Unknown → Medium
Xiang (hsiang-liu) wrote :

I can confirm that it was fixed since I have successfully sent SMS out on ubuntu 10.04.
But I can also confirm that it fails again on ubuntu 10.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.