gnome-phone-manager unable to connect to any newer sony ericsson mobile

Bug #134709 reported by psernetz
10
Affects Status Importance Assigned to Milestone
gnome-phone-manager
Fix Released
Medium
gnome-phone-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-phone-manager

When trying to connect gnome-phone-manager to my K550i/W610i it says that everything went fine at the prompt. But the tray icon keeps displaying the working symbol.

This is the output

gnpatrick@patrick-laptop:~$ gnome-phone-manager
** Message: bdaddr 00:1A:75:91:9E:85
** Message: New connection device is 00:1A:75:91:9E:85 (changed)
** Message: New connection device is 00:1A:75:91:9E:85 (not changed)
** Message: Connecting...
** Message: Status 1
** Message: Making serial port connection
conn_complete: status 0x00

The conn_complete seems to be the problem.

This BUG is related to Version 0.10 from gutsy.

Revision history for this message
psernetz (patrick-sernetz-com) wrote :

patrick@patrick-laptop:~$ gnome-phone-manager
** Message: bdaddr 00:1A:75:91:9E:85
** Message: New connection device is 00:1A:75:91:9E:85 (changed)
** Message: New connection device is 00:1A:75:91:9E:85 (not changed)
** Message: Connecting...
** Message: Status 1
** Message: Making serial port connection
conn_complete: status 0x00

** (gnome-phone-manager:24802): WARNING **: gn_gsm_initialise: Command timed out.
** Message: Failed connection to device on 00:1A:75:91:9E:85
** Message: Exiting connect thread

complete output with error message.

Bluetooth runs just fine with other applications and the Mobile asks for permission to allow gpm to connect.

Revision history for this message
Áron Sisak (asisak) wrote :

Thanks for reporting this issue. I cannot confirm this as I have no Ericsson phone around.

Changed in gnome-phone-manager:
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
psernetz (patrick-sernetz-com) wrote :

Can I do anything to support you with this ?

Revision history for this message
psernetz (patrick-sernetz-com) wrote :

When connecting through the cable... this is the output

patrick@patrick-laptop:~$ gnome-phone-manager
** Message: bdaddr 00:1A:75:91:9E:85
** Message: New connection device is /dev/ttyACM0 (changed)
** Message: New connection device is /dev/ttyACM0 (not changed)
** Message: Connecting...
** Message: Status 1
** Message: Making serial port connection

** (gnome-phone-manager:2358): WARNING **: Model AAC-1052021-BV not supported natively
** Message: Using driver 'AT'
** Message: Status 2
** Message: Serial port connected
** Message: Connected to device on /dev/ttyACM0
** Message: Exiting connect thread
** Message: driver supports sms notifications
** Message: emitting battery

So it seems its bluetooth specific

Revision history for this message
Jose Herran (jherran) wrote :

Same with my SE Z610i. If I can do anything, just say it.

Revision history for this message
psernetz (patrick-sernetz-com) wrote :

My phone has although the problem that the standard hid function wont work. You need to add this,

 HIDD_OPTIONS="--master --server -D -Z"

to the option files of bluez.
When this option is not set the communication between the bluetooth remote and my desktop starts and stops immediately.

Changed in gnome-phone-manager:
status: Incomplete → Confirmed
Revision history for this message
Trond Husoe (tr-huso) wrote :

The bug is still present with Ubuntu 7.10 and with a Sony Ericsson W810i

$ gnome-phone-manager
** Message: bdaddr 00:16:B8:20:47:8C
** Message: New connection device is 00:16:B8:20:47:8C (changed)
** Message: New connection device is 00:16:B8:20:47:8C (not changed)
** Message: Connecting...
** Message: Status 1
** Message: Making serial port connection
conn_complete: status 0x00

** (gnome-phone-manager:7489): WARNING **: gn_gsm_initialise: Command timed out.
** Message: Failed connection to device on 00:16:B8:20:47:8C
** Message: Exiting connect thread
** Message: Auto-retrying the connection
** Message: New connection device is 00:16:B8:20:47:8C (not changed)
** Message: New connection device is 00:16:B8:20:47:8C (not changed)
** Message: Connecting...
** Message: Status 1
** Message: Making serial port connection
conn_complete: status 0x00

Revision history for this message
Stéphane Maniaci (stephh) wrote :

Same problem here with a Bluetooth connection and a SE V630i. Both works fine cause I can synchronize them in Wammu.

Revision history for this message
Krešo Kunjas (deresh) wrote :

same here with w880i and k510i

i have reported this error upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=513491

Changed in gnome-phone-manager:
status: Confirmed → Triaged
Changed in gnome-phone-manager:
status: Unknown → Fix Released
Changed in gnome-phone-manager:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.