Missing default Show Desktop icon

Bug #846378 reported by Fred
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Wishlist
Unassigned

Bug Description

In gnome-panel on 11.10 Oneiric, the Show Desktop and Trash icons are missing missing from the bottom panel.

Also the Firefox and Help icon are missing from the top panel.

tags: added: icon icons trash
Revision history for this message
kurt belgrave (trinikrono) wrote :

Fred
 How did you get gnome panel in oneiric since we use unity now?

Revision history for this message
Fred (eldmannen+launchpad) wrote :

kurt,
  I installed gnome-session-fallback (which installs gnome-panel).
Then I switch session when I login to "GNOME Classic".

Unity sucks. I like GNOME 2.32 more.

Revision history for this message
kurt belgrave (trinikrono) wrote : Re: [Bug 846378] Re: Missing Trash and Show Desktop icon

Fred

Can you please take a screenshot for me, also can you run for me
apport-collect 846378
in a terminal
This would attach all the needed log files.
If you can do these two for me while i work on reproducing the issue.
Cheers

Revision history for this message
Fred (eldmannen+launchpad) wrote : Re: Missing Trash and Show Desktop icon
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Changed in gnome-session (Ubuntu):
status: New → Confirmed
Revision history for this message
Andreas (andreas-kotowicz) wrote :

attaching screenshot

tags: added: apport-collected oneiric
Revision history for this message
Andreas (andreas-kotowicz) wrote : apport information

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
NonfreeKernelModules: wl nvidia
Package: gnome-session 3.1.92-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Tags: oneiric oneiric
Uname: Linux 3.0.0-11-generic x86_64
UpgradeStatus: Upgraded to oneiric on 2011-09-23 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
Andreas (andreas-kotowicz) wrote : Dependencies.txt

apport information

Revision history for this message
Jeremy Bicha (jbicha) wrote : Re: Missing Firefox, Trash and Show Desktop icon

This was an intentional decision of the Ubuntu Desktop Team to package gnome-panel without all of the Ubuntu-specific patches. What you see is basically what GNOME ships (although GNOME uses a different theme).

summary: - Missing Trash and Show Desktop icon
+ Missing Firefox, Trash and Show Desktop icon
Changed in gnome-session (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
kurt belgrave (trinikrono) wrote :

Jeremy can this bug be closed in gnome-panel aswell by the same reasoning?

Changed in gnome-panel (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Kurt, I don't plan to bring back the Firefox, Trash, and Show Desktop icons by default.

On the other hand, someone could add these shortcuts to gnome-panel upstream if GNOME wouldn't mind, so I think we should go ahead and keep this bug open.

Changed in gnome-panel (Ubuntu):
importance: Undecided → Wishlist
no longer affects: gnome-session (Ubuntu)
Changed in gnome-panel (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Jeremy Bicha (jbicha) wrote :

I think I'll add the Show Desktop button by default since it's rather useful (of course, it does the same as Ctrl+Alt+D). I don't think the Trash icon is useful for most people by default. Adding a Help button isn't very useful since Help would either describe Unity or GNOME Shell which are dramatically different than GNOME panel. A single Firefox button wouldn't be useful to Chrome/Chromium users and there's almost as many of those as there are Firefox users.

Bryce Harrington (bryce)
tags: added: precise
summary: - Missing Firefox, Trash and Show Desktop icon
+ Missing default Show Desktop icon
Jeremy Bicha (jbicha)
Changed in gnome-panel (Ubuntu):
assignee: nobody → Jeremy Bicha (jbicha)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:3.3.5-0ubuntu2

---------------
gnome-panel (1:3.3.5-0ubuntu2) precise; urgency=low

  * debian/patches/41_classic_layout.patch:
    - Change the defaults to be more "classic Ubuntu": Show indicators
      & show desktop, drop GNOME clock & notification area (LP: #846378)
 -- Jeremy Bicha <email address hidden> Fri, 10 Feb 2012 14:48:34 -0500

Changed in gnome-panel (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Fred (eldmannen+launchpad) wrote :

Jeremy Bicha (jbicha),
> A single Firefox button wouldn't be useful to Chrome/Chromium users and there's almost as many of those as there are Firefox users.
Chrome/Chromium isn't installed by default on Ubuntu, however Firefox is.
So adding a Firefox icon would give a better out-of-the-box experience for most people.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Fred, I disagree. What makes Firefox so special as to be the only app to receive such a prominent shortcut?

Leaving out the Firefox shortcut makes for a cleaner default look, and it's not too difficult for those that want it to add it.

Revision history for this message
Benjamin Drung (bdrung) wrote :

The trash icon is missing from the bottom panel. I am going to upload a fix to precise-proposed.

Changed in gnome-panel (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
Benjamin Drung (bdrung) wrote :
tags: added: patch
Revision history for this message
Fred (eldmannen+launchpad) wrote :

Jeremy Bicha (jbicha),
What makes Firefox special enough to warrant an own shortcut is that;
A) it is a web browser
B) it is pre-installed by default

The web is the computer! Using the computer equals getting online and using the web!
99% of computer usage is done in a web browser these days.
First thing people will look after when they login is the icon to launch the web browser.

Revision history for this message
Fred (eldmannen+launchpad) wrote :

Also, this is not about Firefox vs Chromium or something like that. I take no side.
You can use the default GNOME web browser icon and make it call;
* gnome-open http://google.com/
* xdg-open http://google.com/
* sensible-browser
or something, and just make it launch the default browser whatever that happens to be.

Jeremy Bicha (jbicha)
Changed in gnome-panel (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody
Changed in gnome-panel (Ubuntu):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers