light-themes don't display well in gnome-panel 3+

Bug #828392 reported by Jeremy Bicha on 2011-08-17
102
This bug affects 18 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Medium
light-themes
Fix Released
Undecided
Unassigned
gnome-panel (Ubuntu)
Low
Unassigned

Bug Description

Please see the attached screenshots. Adwaita looks lovely in Gnome Fallback (aka Gnome Classic or gnome-panel) but Ambiance & Radiance do not blend right. It's probably worth looking at Adwaita's code to see what they do exactly to support Gnome Shell & Fallback. Perhaps light-themes uses too many hacks that don't all work well with the Gnome 3 switch.

This is a high priority as a decent amount of upgraders who will try to keep using Gnome Fallback even though little developer time is spent to keep it working. And since there is not an obvious way to change the theme in Gnome 3, they may not know that switching to Adwaita will improve the appearance, or know how to do that either.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: light-themes 0.1.8.21
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
Date: Wed Aug 17 18:21:31 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
SourcePackage: light-themes
UpgradeStatus: Upgraded to oneiric on 2011-06-17 (61 days ago)

Related branches

lp:~mitya57/light-themes/panel-fixes-part-1
Andrea Cimitan: Approve on 2012-03-06
Ubuntu Artwork Packagers: Pending requested 2012-03-04
Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :
Changed in light-themes (Ubuntu):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

In the beginning of /usr/share/themes/Ambiance/gtk-3.0/apps/gnome-panel.css:

PanelWidget, PanelApplet, PanelToplevel {
    background-image: -gtk-gradient (linear, left top, left bottom,
                                     from (shade (@dark_bg_color, 1.5)),
                                     to (shade (@dark_bg_color, 1.05)));
    <...>
}

I don't see any errors here, so maybe it's Gnome Panel issue? I don't know any other theme that works and uses gradients.

BTW, an easy workaround is to go to panel properties -> "Background" -> set to "Image" -> select "/usr/share/themes/Ambiance/gtk-2.0/apps/img/panel.png" file.

Pedro Abranches (abranches) wrote :

Yes, it's a gnome panel error because it happens with other themes also. There isn't anything wrong with Ambiance.

I pretty sure that the themes that aren't affected by the bug aren't the ones that doesn't use gradients in the panel (I will check when I get some time)

affects: light-themes (Ubuntu) → gnome-panel (Ubuntu)
Changed in gnome-panel (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in gnome-panel:
importance: Unknown → Medium
status: Unknown → New
Dmitry Shachnev (mitya57) wrote :

@Lucazade: You seem to be the original author of gnome-panel theming (http://bazaar.launchpad.net/~lucazade/+junk/light-themes_new-widgets/revision/100). Has the gradient for PanelToplevel ever worked properly for you? (If so, that's probably a regression in gtk or panel itself).

Lucazade (lucazade) wrote :

@Dmitry: unfortunately never worked but I've added it into the code hoping that upstream patches for gnome-panel would have solved the issue.

Dmitry Shachnev (mitya57) wrote :

Thanks for replying! So we can temporarily add a workaround to light-themes like described in comment #3, and wait until that will be fixed upstream.

Paul Sladen (sladen) wrote :

nb, this bug is referenced from:

  "Ubuntu Classic, Now With Indicators"
  http://jeremy.bicha.net/2012/02/11/ubuntu-classic-now-with-indicators/

Dmitry Shachnev (mitya57) wrote :

@Paul or @Andrea:

Can you please look at this bug? Things became even worse in Precise, for example the window labels are unreadable (they have a correct color, but it seems they are darkened for some reason).

Peter Hurley (phurley) wrote :

It seems that this bug is becoming sort of a meta-bug for several issues in different packages.

Bug 885691 (which was marked a duplicate of this) specifically addressed the themed background gradient not drawn correctly. A patch to gnome-panel was submitted for that bug and the upstream bug, gnome-bugs 663397, on remote watch here.

The original reporter of this bug seems to refer primarily to the gradient background issue as being the impetus for this report. There are certainly other bugs that impact the visual quality of light-themes with gnome-panel 3. I would be happy to cross-ref those here if that's helpful.

Andrea Cimitan (cimi) wrote :

Merge proposals welcome :)

Changed in gtk3-engines-unico (Ubuntu):
status: New → Invalid
Changed in unico:
status: New → Invalid
Dmitry Shachnev (mitya57) wrote :

@Andrea, patches are awaiting in these bug reports:
- Unico: bug 920832;
- Light-themes: bug 945644, bug 926487, bug 923788, bug 920843.

There is still an issue with low-contrast text in Ambiance, which I think is not listed here...

Dmitry Shachnev (mitya57) wrote :

Since Peter made patches only for Radiance, I created my own branch that includes also Ambiance changes β€” lp:~mitya57/light-themes/panel-fixes-part-1. I'll now also upload a patched gnome-panel to ppa:mitya57/gnome-test.

@Peter: what about fixing low contrast labels? It would be excellent to get all things fixed altogether.

no longer affects: unico
no longer affects: gtk3-engines-unico (Ubuntu)
Andrea Cimitan (cimi) wrote :

Nice work. Keen on testing and merging if it won't affect unity. Did you test it with unity? It could be that you need to add some exceptions for unity

Dmitry Shachnev (mitya57) wrote :

Tested, no visible regressions under Unity.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:3.3.91-0ubuntu1

---------------
gnome-panel (1:3.3.91-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Several theme fixes, thanks Peter Hurley! (LP: #828392)
 -- Jeremy Bicha <email address hidden> Mon, 05 Mar 2012 20:34:01 -0500

Changed in gnome-panel (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-panel:
status: New → Fix Released
Changed in light-themes:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.