Shutdown from menu does not shutdown computer, goes to GDM login screen

Bug #8238 reported by Petri Pennanen on 2004-09-19
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Medium
Sebastien Bacher

Bug Description

Clicking Log Out on the computer sometimes doesn't bring up the log-out window.

1. Click the "Computer" meny
2. Click "Log Out"
3. Select "Shut Down"

The computer should shut down. Instead the GDM login screen is loaded. This
happens every time. sudo halt works though.

Build: Warty Warhog 4.10, updated 2004-09-19.

Sebastien Bacher (seb128) wrote :

Could you paste the result of "/usr/bin/gdmflexiserver -a -c QUERY_LOGOUT_ACTION" ?

Matt Zimmerman (mdz) wrote :

Works for me here. Is there any pattern to the "sometimes"?

Petri Pennanen (suvarin) wrote :

$ /usr/bin/gdmflexiserver -a -c QUERY_LOGOUT_ACTION
OK HALT;REBOOT;SUSPEND

I can no longer reproduce this bug. I think it might have been caused by my
setting a nonfunctional LANG in /etc/enviroment (bad habit from another linux
distro). After I reset locale with "sudo dpkg-reconfigure locales" this bug has
dissapeared. Feel free to close it, and thank you for your time.

Matvei Fisenko (2matvei) wrote :

After upgrading to Ubuntu 9.04 from Ubuntu 8.10 I got the same issue.
System is up-to-date.

When I press "Shutdown" button the screen goes blank than it shows me login screen.
Expected result - computer shutdown.

If I try "sudo halt" command - it works fine, computer shuts off.

uname -a = "Linux mot-b 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux"

Changed in gnome-panel (Ubuntu):
status: Fix Released → In Progress
Raffles10 (stuartclampit) wrote :

I also have the same problem with ubuntu 9.04, shutdown results in login screen.

uname -a = 'Linux ubuntu 2.6.28-13-generic #45-Ubuntu SMP Tue Jun 30 22:12:12 UTC 2009 x86_64 GNU/Linux'

Przemek K. (azrael) on 2010-01-04
summary: - Shutdown from meny does not shutdown computer, goes to GDM login screen
+ Shutdown from menu does not shutdown computer, goes to GDM login screen
Sebastien Bacher (seb128) wrote :

not sure why this bug had been reopened but if you have a similar issue in recent versions open a new bug rather, the code changed in those years and the issue is a different one now

Changed in gnome-panel (Ubuntu):
status: In Progress → Fix Released
retro89 (bradpearson08) wrote :

Im running 10.04 I experience same issue and 9.10 did not do this. I go to shutdown my pc and it goes to login screen.

Kanapat Tepalagul (talsadus) wrote :

I'm running 10.04 and have this problem after setting resolution to higher one with nvidia X server settings
I can get it to work again if I do "sudo /etc/init.d/gdm stop" then "sudo shutdown -h now" then turn on the machine again
The problem is the resolution goes back to what it originally was :-(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.