The panel encountered a problem while loading... on a live session

Bug #727660 reported by Paolo Sammicheli
144
This bug affects 34 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Medium
gnome-panel (Debian)
Fix Released
Unknown
gnome-panel (Ubuntu)
Medium
Unassigned
Precise
Low
Unassigned

Bug Description

Impact: some applets fail to load sometimes on login

Test Case:
log into gnome classic and make sure your applets are correctly loading

Regression potential: the applets could not load as they should

---

ISO Testing Natty Alpha3, booting in a live session I get errors about Applet Loading. While reporting I'm having «The panel encountered a problem while loading "TrashAppletFactory::TrashApplet" » but in a previous boot I got error on notification area applet.

Testcase performed: Live Session: http://testcases.qa.ubuntu.com/Install/DesktopLiveSession

Attaching a screenshot

Revision history for this message
Paolo Sammicheli (xdatap1) wrote :
description: updated
tags: added: iso-testing
Changed in gnome-panel (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Pedro Villavicencio (pedro) wrote :

is this still reproducible? would be nice to get a debug log of that crash (looks like a crash in the applet) folowing the instructions at: https://wiki.ubuntu.com/DebuggingGNOMEApplets ; thanks.

Changed in gnome-panel (Ubuntu):
status: New → Incomplete
Revision history for this message
Paolo Sammicheli (xdatap1) wrote :

Hello Pedro,

this issue was not systematic. Every boot the behavior changed, it looks like a race condition.

Anyway I did't noticed It this week during Beta2 ISO testing. I'll keep trying during the weekend I'll keep this report updated.

Greetings

affects: gnome-panel (Ubuntu) → gnome-applets (Ubuntu)
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Could you switch to a tty and run gdb as: DISPLAY=:0 gdb /usr/lib/gnome-applets/trashapplet ; after that you need to logout of your session enter the run command on gdb and login again, if DISPLAY=:0 doesn't work try with 1; if you manage to reproduce the applet crash, you need to enter on gdb:

set logging on trash-crash.txt
back
thread apply all bt full

after that you can quit gdb and attach the resulting file to the report (trash-crash.txt), thanks.

Revision history for this message
Paolo Sammicheli (xdatap1) wrote :

Clearly now that I have dbg waiting for it in the other tty it's not coming anymore :(

I'll keep trying.

Btw, I forgot to say that I reproduced it with an installed Natty Beta2 updated today, so it's not related to live session itself.

Revision history for this message
Shane H (shane.h) wrote :

I get this error after loading 11.04 Stable Classic desktop.

The panel encountered a problem while loading "TrashAppletFactory::TrashApplet".
Do you want to delete the applet from your configuration?

Revision history for this message
CedSha (lineaire) wrote :

Same problem (on French version )

At first computer start, trash applet will crash then on reboot applet will load correctly.
It will reproduce almost each morning.
I am not so clearly how to run the gdb because this is at startup of computer I cannot enter anything before

Linux 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
László Monda (mondalaci) wrote :

I've just marked #715706 and #780982 as a duplicate of this.

Revision history for this message
László Monda (mondalaci) wrote :

Sorry for stating marking the duplicates before - I've just noticed that it's automatically taken care by Launchpad.

I read https://wiki.ubuntu.com/DebuggingGNOMEApplets but I don't have a clue how to debug this one because it clearly seems a race condition as others have suggested.

By the way, in my situation this has happened with the User Switch Applet, with the Multiload Applet, and with the Window List applet. It's not deterministic and happens once in a while, about every fourth time upon session startup. This clearly doesn't seem to be applet-specific but rather more general purpose, related to the GNOME panel applet framework / architecture.

Revision history for this message
László Monda (mondalaci) wrote :
Revision history for this message
MyTh (stiffmaster88) wrote :

Same problem here on x86_64
Here the clock applet crashes!

Revision history for this message
Jan Schoubo (jan-schoubo) wrote :

As of today, I am experiencing the same problem:

     The panel encountered a problem while loading "TrashAppletFactory::TrashApplet".

I run 11.04, fully updated, on 64-bit.

Revision history for this message
Stephan Wissel (stw-linux) wrote :

Got that problem too on a regular install with encrypted disks

Revision history for this message
Bob (robert-sabocanec) wrote :

I noticed that the bug started appearing after I've set that user doesn't have to enter password on login (login is done automatically, just by clicking the username in the login window)

Revision history for this message
Martin Stjernholm (msub) wrote :

Indeed, that is an interesting observation. I can confirm it: Out of three boxes I have with Natty, only one exhibits this behavior on a regular basis, and that is also the only one with autologin. Furthermore, I have never experienced the problem if I log out and back in again.

Revision history for this message
Unilogic Networks Package Master (unnet-pkg-master) wrote :

I regularly get hit by this issue too, I have a fairly normal install but run GNOME Classic, and have an encrypted homedir (ecryptfs).

Revision history for this message
Pascal de Bruijn (pmjdebruijn) wrote :

Same for me. Natty/AMD64/GNOME Classic/ecrypfs-homedir

Revision history for this message
Fábio Firmo (fabio-a-firmo) wrote :

Same for me. Natty/AMD64/Gnome Classic but I don't have encrypted home and don't use autologin

Revision history for this message
Martin Stjernholm (msub) wrote :

Martin Stjernholm (msub) wrote on 2011-09-19:

> Furthermore, I have never experienced the problem if I log out
> and back in again.

I have to correct myself on this. I have now seen it after a logout/login cycle as well.

Revision history for this message
physe (graverini-elena) wrote :

It also affects me. Ubuntu 11.04 64bit, no /home encryption, GNOME Classic session.

Revision history for this message
PoxyPig (poxypig) wrote :

I too have this problem. I am using the Classic desktop and have auto-login set. My file system is not encrypted.
About 50% of startups result in one of my applets failing with the described error. Which applet fails appears to be entirely random; if the system is re-started it is unlikely that the same applet will fail the second time.
I agree with the theory that this is being caused by some sort of race situation, particularly as I have only experienced one applet failing per startup. Is there perhaps a way of delaying the applet loading process?

Revision history for this message
Joachim Breitner (nomeata) wrote :

There is a patch for this at https://bugzilla.gnome.org/attachment.cgi?id=201328 since half a year, but unfortunately, upstream has become slow to appl y patches to GNOME fallback stuff.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

A fix has been committed in trunk.

affects: gnome-applets → gnome-panel
affects: gnome-applets (Ubuntu) → gnome-panel (Ubuntu)
Changed in gnome-panel (Ubuntu):
status: Incomplete → Fix Committed
Changed in gnome-panel:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in gnome-panel (Debian):
status: Unknown → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue is fixed in quantal

Changed in gnome-panel (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-panel (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
Revision history for this message
Sebastien Bacher (seb128) wrote :

I've uploaded a SRU candidate for proposed as well

description: updated
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Paolo, or anyone else affected,

Accepted gnome-panel into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-panel/1:3.4.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-panel (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Paolo Sammicheli (xdatap1) wrote :

Sorry for the late answer, I was away.

It's difficult to test it again since I reported it from a LIVE session during natty dev cycle, and now we have unity in the live session. I should create a new ISO with gnome classic as default DE. Any other affected from the desktop session? Any idea how to test it?

Revision history for this message
Sebastien Bacher (seb128) wrote :

If it's difficult to test we can at least test that there is no regression in normal use...

Revision history for this message
Sebastien Bacher (seb128) wrote :

no issue there, setting it verification-done

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:3.4.1-0ubuntu1.1

---------------
gnome-panel (1:3.4.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/15_avoid_applet_loading_failures.patch:
    - Use on_bus_acquired instead of on_name_acquired.
      This helps prevent race conditions at session starts which can lead
      to panel applets failing to load. (lp: #727660)
 -- Sebastien Bacher <email address hidden> Tue, 26 Jun 2012 12:05:46 +0200

Changed in gnome-panel (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
haru (haru-a8n) wrote :

New here... not sure if I should comment or file another bug report. But anyway, I am seeing the same problem on Ubuntu 15.04 and this is reproducible.

How the system was setup.
1. Install a CLI version.
2. Use tasksel, install Ubuntu MATE minimal installation
3. Reboot and login.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

@haru: This bug was about gnome-panel, not mate-panel (which is a fork of some ancient gnome-panel version).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.