Indicator menus won't open when a VirtualBox seamless VM has focus

Bug #706416 reported by Jonas Alves on 2011-01-22
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
gnome-panel (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: indicator-applet

Ubuntu 10.10
indicator-applet (0.4.6-0ubuntu1)
virtualbox-4.0 (4.0.2-69518~Ubuntu~maverick) from VirtualBox's official repository

3) What you expected to happen
When:
1. I'm running a "seamless" VirtualBox window
2. this seamless VirtualBox window has focus
3. I click any indicator

The indicator menu should open

4) What happened instead

The indicator icon background changes, as if it had been opened, but the menu isn't shown.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: indicator-applet-complete 0.4.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Uname: Linux 2.6.35-24-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Jan 22 19:19:47 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: indicator-applet

Jonas Alves (jonasfa) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, does it happen only with virtualbox? which indicator do you click on? the menu export one? or does it do it with other indicators like the session one as well?

Jonas Alves (jonasfa) wrote :

VirtualBox in Seamless mode is the only app I use that makes this happens.
Any indicator, including the Sound, messaging and session ones.

Jonas Alves (jonasfa) wrote :

I've just realized it happens with other applets too: "Main menu" and "Menu bar" included.

Jonas Alves (jonasfa) wrote :

And I've just realized that right clicks in empty spaces in the gnome panel doesn't open the context menu.
So it seems it's something related to gnome-panel, not indicator-applet.

affects: indicator-applet (Ubuntu) → gnome-panel (Ubuntu)
Lukáš Machyán (phobulos) wrote :

I have same problem in Ubuntu 11.04 with indicators in Unity when Gnome Panel isn't launched.

Filip Oščádal (filip-mxd-cz) wrote :

bug confirmed in Ubuntu 10.04 (Gnome) with latest Virtualbox 4.0.8 (and this bug is present since v3)

Alex Launi (alexlauni) on 2011-05-19
Changed in unity:
status: New → Invalid
Matteo (mr-91) on 2011-05-21
Changed in unity:
status: Invalid → New
status: New → Invalid
Lukáš Machyán (phobulos) wrote :

Why has it been marked as Invalid? This problem is still present on my system with Unity.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Andy Clayton (q3aiml) on 2012-12-04
Changed in unity:
status: Invalid → Confirmed
Andy Clayton (q3aiml) wrote :

I am still seeing this in 12.10. I have only seen this happen with virtualbox in seamless mode, and it does affect all indicators. The indicator menu will not display even on a separate monitor from the one where seamless mode is active, yet it does reliably draw the decoration on the panel as if the menu was displayed (see attachment).

Once VirtualBox has focus the indicator menus can be displayed in two ways: 1) giving focus to another non-seamless window, or 2) hitting the VirtualBox hostkey, which defaults to Right Ctrl for me, and reselecting a different indicator.

Andy Clayton (q3aiml) wrote :

It also appears that this is not some stacking issue where the menu is created but not displayed properly. While virtualbox seamless has focus, xwininfo will show no changes for unity-panel-service windows when selecting an indicator and moving the mouse to select others, compared to normal where there are changes.

tags: added: quantal
tags: added: lucid

Priority set to 'low' because the bug is a usability issue that does not limit the functionality of a core application.

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low

Status changed to 'Triaged' because the bug is:

- Valid.
- Well described.
- Reported in the upstream bug tracker (Launchpad).
- Ready to be worked on by a developer.

Changed in gnome-panel (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers