Ubuntu

Drag and drop of Bookmarks from Places menu copies entire directory instead of creating a link

Reported by Mark Florian on 2006-09-26
36
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Panel
New
Medium
One Hundred Papercuts
Undecided
Marcel Stimberg
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

To reproduce: drag and drop an entry from the Places menu (NOT the Home Folder) into some other folder (say Desktop) and you'll see a Copy Progress dialog appear. It seems the entire directory structure is copied to the new location.

What should happen: a launcher (.desktop file) is created, linking to the bookmark. Note that this is what happens when the Home Folder is DND'd from the Places menu, but no other item does this.

Eric Butler (codebutler) wrote :

Reassigning to gnome-panel & confirming.

Sebastien Bacher (seb128) wrote :
Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Unknown
Changed in gnome-panel:
status: Unknown → Unconfirmed
Changed in gnome-panel:
status: Confirmed → Triaged
Biji (biji) wrote :

(intrepid) dragging Home folder from Places to desktop copies its content which should be create shortcut instead

Confirming the Papercut due to the duplicated bug: #388103

Changed in hundredpapercuts:
status: New → Confirmed
summary: Drag and drop of Bookmarks from Places menu copies entire directory
+ instead of creating a link
Changed in hundredpapercuts:
milestone: none → round-10
Changed in hundredpapercuts:
milestone: round-10 → round-7
Andrew (and471) wrote :

happens with home folder with me as well

Andrew (and471) wrote :

the data that is being sent with the DND is a string containing:

'FOLDERPATH'

I am wondering whether this is therefore a bug in nautilus

Andrew (and471) wrote :

The reason a folder is being copied is because the DND action is set to copy. Normal launchers work find because the .desktop file is copied. However the Places menu items don't work as they are not .desktop files. Therefore a string containing the folder path is sent, and nautilus therefore copies this.

Andrew (and471) on 2009-08-23
Changed in gnome-panel:
status: New → Confirmed

I posted a patch upstream that changes the d&d action from copy to link for entries in the places menu.

Changed in hundredpapercuts:
status: Confirmed → In Progress
assignee: nobody → Marcel Stimberg (marcelstimberg)
Changed in hundredpapercuts:
milestone: round-7 → r1
Changed in hundredpapercuts:
assignee: Marcel Stimberg (marcelstimberg) → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2009-12-01
Changed in hundredpapercuts:
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
assignee: Martin Pitt (pitti) → Marcel Stimberg (marcelstimberg)
Mathias Gug (mathiaz) wrote :

Thanks for posting a patch. Since the package is maintained in a bzr branch I'd suggest to turn the patch into a merge proposal by branching from the URL:

  bzr branch https://code.launchpad.net/~ubuntu-desktop/gnome-panel/ubuntu

and then submit a Merge proposal as outlined in https://help.launchpad.net/BranchMergeProposals

I'd also recommend to include a proper changelog entry.

Martin Pitt (pitti) wrote :

Thanks! Committed to packaging bzr. Will test and upload soon.

Changed in gnome-panel (Ubuntu):
status: Triaged → Fix Committed
Vish (vish) on 2010-01-20
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.29.5.1-0ubuntu2

---------------
gnome-panel (1:2.29.5.1-0ubuntu2) lucid; urgency=low

  * debian/patches/05_no_session_delay.patch:
    - don't set X-GNOME-Autostart-Phase=Panel to avoid delaying other softwares
      start on login

  [ Martin Pitt ]
  * Add 02_sunrise_sunset_time_format.patch: Fix sunrise and sunset times in
    tooltip to respect 12/24 hour format setting. Thanks to Ted M Lin!
    (LP: #197657)
  * Add 03_dnd_places_link.patch: When using Drag'n'Drop from Places menu,
    install a link launcher (.desktop file) instead of copying the entire
    directory. Thanks Marcel Stimberg! (LP: #62529)
 -- Sebastien Bacher <email address hidden> Wed, 20 Jan 2010 19:13:17 +0100

Changed in gnome-panel (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2010-01-20
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in gnome-panel:
importance: Unknown → Medium
status: Confirmed → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.