Clock Applet crashes for no reason

Bug #580735 reported by gdonwallace on 2010-05-14
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Undecided
Unassigned

Bug Description

At random times of the day, the clock-applet will stop working. I won't know until I check the time and notice that it is incorrect based on another time source (i.e. phone, laptop, etc..) Running TOP I find a zombie process. I kill the zombie process and an error will pop up with the message "CLOCK" has quit unexpectedly and give me two options, close or reload the applet. I can reload, and the applet will start up again, but at a random time, will stop and create the zombie process again. I I choose to close the error, the clock-applet no longer displays on my panel. I can through the "ADD TO PANEL" dialog add the clock back to the panel and it will start, but within a random amount of time will stop again.

Ubuntu Version: 10.04 LTS

What is expected to happen: Clock applet should run without a problem.

What happens instead: Clock applet stops working after a random period of time and a reload is required.

affects: ubuntu → gnome-panel (Ubuntu)
Peter M. Clausen (pclausen) wrote :

Happend to me after rebooting gdm a couple of times. Please give me a hint which logs to upload ?

Chris Coulson (chrisccoulson) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.
If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in gnome-panel (Ubuntu):
status: New → Invalid
Peter M. Clausen (pclausen) wrote :

Changing to confirmed. There is no crash report because gdm did not crash only the Clock-applet.

So please; tell me where I can find the crash info from the applets and I will upload the infos.

Changed in gnome-panel (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

This happens to me also. I have to log out and in again to make it work. It just crashes without reason, sometimes even just after boot.

Keeps happening. Also i found out you do not have to log off and on again. Going to preferences and toggling 12-hour format and back to 24-hour format also seems to "refresh" the clock and then it is functional again.

Pedro Villavicencio (pedro) wrote :

we need a backtrace of the crash, please read the previous comments to know how to get it, if you have questions please drop it here in the report, thanks.

Changed in gnome-panel (Ubuntu):
importance: Low → Medium
gdonwallace (gregoryw-minokc) wrote :

Unfortunately I will not be able to do the backtrace. A few weeks ago I was having some issues with the Ubuntu and video that was a real show stopper. Could not do any work, or get anything done. So I had to re-install Ubuntu. This is no longer an issue for me.

Its still an issue for me and i also get the right most button (the one with shut down in it) crashing from time to time! O_O.
I will provide a backtrace next time it occurs.

I have another crash currently and the clock shows another part of the gnome panel instead of the time.
Specifically it shows the date "Sun Jun 13," but truncated because the clock is smaller so it only shows "Jun 13, " and a couple of dots on each side. (see attachment)

I installed debug symbols and tried to do a backtrace, but as i understand it, i have to start gnome-panel with gdb. Since the crash occurs randomly and usually when i am logging in to the system, i don't understand how i am supposed to do that. Also, because the crash occurs randomly i can't "Perform any actions necessary to reproduce the crash."

Do i have to always start gnome-panel with gdb on start-up and keep logging off and on until the crash happens?

Another thing i noticed: The above behaviour occurs only on my box which was upgraded from 9.10 to 10.04. All other installations i made (5-6) don't have this problem.

Pedro Villavicencio (pedro) wrote :

you can enable apport as Chris described in his previous comment and report the crash with it.

I enabled apport and the bug did occur, however a crash report is not generated. I know its working because i got some other bug reports and the exclamation mark appeared when this happened.

Maybe its not a "crash" per se?

Joelp (joelp) wrote :

I am having the same problem.

Adding multiple locations and disconnecting from the internet seems to produce this error reliably.
I have made a backtrace, which hopefully contains some useful info.

Hi,

I have the same problem when I click on the clock to display the calendar. Here's the crash report.

Thanks

Pedro Villavicencio (pedro) wrote :

the report is no use, please enable apport and submit the crash trough it, the backtraces attached are empty and people already started to comment because of the title, please enable apport as Chris said and submit a new report, thanks.

Changed in gnome-panel (Ubuntu):
status: Incomplete → Invalid
V. Chungath (vimaljc) wrote :

I am not able to send it through apport as it says it failed to retrieve message related to assertion failure. I am attaching the crash file.

This bug is 100% reproducible. I am using Lucid Lynx.

I have attached my crash file. I enabled apport, but it refuses to upload the crash:

"The problem cannot be reported: The program crashed on an assertion failure, but the message could not be retrieved. Apport does not support reporting these crashes."

Why are assertions enabled in production code? And if you choose to enable them, the apport bug reporter should be able to handle them like any other crash.

Changed in gnome-panel (Ubuntu):
status: Invalid → Confirmed
racitup (racitup) wrote :

Yes, this bug is now affecting me too. 10.04 fully up-to-date on 18th July 2013, kernel ver 2.6.32-49.

The problem is not really a crash, but a hang that sometimes recovers.

I managed to grab a gdb trace when it hung, but don't have debug symbols for most things.

Hope this helps!

gdonwallace, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/580735/comments/8 regarding this being fixed with a reinstall. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in gnome-panel (Ubuntu):
importance: Medium → Undecided
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers