Ubuntu

gnome-panel consuming 100% of CPU and driving up memory

Reported by O. Emmerson on 2009-11-10
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-panel

After rebooting today gnome-panel is consuming 100% of my CPU and slowly driving memory up to 100% also.

I had installed the latest updates just before rebooting.

I have tried tried killing the process but it just starts again immediately at 100% CPU.
I have tried restarting again but just to the same results.

ProblemType: Bug
Architecture: i386
Date: Tue Nov 10 07:28:02 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gnome-panel
Package: gnome-panel 1:2.28.0-0ubuntu6
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: gnome-panel
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:5199): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:5199): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:5460): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:5409): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:5348): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -21 and height 24

O. Emmerson (oemmerson) wrote :
O. Emmerson (oemmerson) wrote :

The lower panel with the application tabs and the virtual desktop selector also becomes unresponsive, taking several seconds at least to change to a different application/virtual desktop when clicked.
I can change immediately with alt-tab however.

Erik Kronberg (eakron) on 2009-11-10
Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Confirmed → Incomplete
O. Emmerson (oemmerson) wrote :

I installed gnome-panel-dbg and ran the backtrace, find it attached.
I noticed that it said no debugging symbols found when I started gdb though. Let me know if I need to install something else and run again.

When I finished the backtrace and quit the process I noticed that nautilus was comsuming 70%CPU also. I killed it and started it again but it goes right back up to 70%
Now when I tried to attach the backtrace to this page firefox hanging when the file selector window pops up.
Maybe this is a problem attached to nautilus and/or gvfs?

I installed Konqueror to attach the backtrace.

O. Emmerson (oemmerson) wrote :

I was running a Karmic system that had been running for 4-6 weeks before official release, being updated every day.
I need to use this system. I thought the problem may have been from a conflict from something left over from the development stage of Karmic. I decided to reinstall from the final release CD. Happily I can say this has fixed the problem.

There are still problems with devicekit/gvfs and CPU usage.
I have filed a separate bug at https://bugs.launchpad.net/ubuntu/+source/devicekit-disks/+bug/481626 about that.

O. Emmerson (oemmerson) wrote :

I posted too soon, the bug is still there.
I have more info though.

After editing the fstab file to include lines for external hard drive and mp3 player the bug reoccurred.

After some testing it seems to be the external hard drive line which causes the problem.
'UUID=65f23d3e-760c-4349-9bce-3bb952b14924 /media/freeagent1500 ext3 relatime,user,data=writeback'
If I add the line to fstab and save the file, gnome-panel immediate starts to consume massive amounts of CPU. If I comment it out and re-save the file it immediately stops.

This appears to be connected to the other bug I linked to above. In my research about that I discovered forum posts about entries in fstab causing an increase in CPU.

matthew72 (matthew72) wrote :

It happened to me after adding a new panel:
- right clicked top panel, "New panel"
- panel appeared at the right edge of the screen
- right clicked new panel, "Properties"
- set orientation to "Top"
- the panel stacked below the existing one
- checked auto-hide
- all panels turned empty at once, the system froze with 100% cpu used by process gnome-panel, also using an increasing amount of memory
then I had a hard time gaining control of my box, the system was nearly unresponsive, the process would immediately restart when killed, rebooting didn't solve it. In case it happens to somebody else, here's how I got out of trouble: I didn't exactly know what to do but it had to be something with gnome-panel settings in my home folder, so i switched to a text-mode console (ctrl-alt-f1), logged in, "find -iname *panel*|less" showed lots of results, among which i found:
~/.gconf/apps/panel/general/%gconf.xml -- at the bottom i found two entries for the default top and bottom panels as well as a third one called "panel_4", which i removed
~/.gconf/apps/panel/toplevels/panel_4 -- i removed the whole folder
then i rebooted and finally resumed breathing...

Benjamin Humphrey (humphreybc) wrote :

I had the exact same thing happen to me today, I can confirm this. I reported it as bug 545521. Completely took down the system like I have never seen before, might have something to do with hot-plugging dual monitors. (I'm running Lucid beta1 by the way).

Changed in gnome-panel (Ubuntu):
status: Incomplete → Confirmed
Bartosz Kosiorek (gang65) wrote :

I have the same problem.
When I kill the "notification-ar" process, the warning "Firefox-3.0 need to be restarted" every time.

How can I help resolve this problem?

Bartosz Kosiorek (gang65) wrote :

This bug is still open so I assume it's here to post:
Today I had a 100% (out of 400%) CPU consumption by a process called gnome-panel. Apart from the laptop turning loud I did not notice any issues and killing it resulted in it going quiet again.

So for now the issue is not reproducible for me but annoying especially when on battery.

Mats Karrman (mats-karrman) wrote :

Happened to me too yesterday.
Turning on the computer (it was fine before, no updates installed) I got some messages about widgets that failed to load (happened before so I ignored it) andthen the desktop was unusable. Gnome panel was sucking 100% and the panels were totally unresponsive. Tried logging into a console and killing gnome-pannel (respawning) and then killing it's parents but it didn't help. Then I apt-get removed the gnome-panel package and reinstalled -- didn't help. I then apt-get purged gnome-panel and reinstalled, still didn't help. So far no resolution...

Mats Karrman (mats-karrman) wrote :

Forgot, I'm running 10.10 on x86_64 quad core.
I followed the suggestion in bug 545521 and removed everything under ~/.gconf/apps/panel/general and ~/.gconf/apps/panel/toplevels, rebooted and then everything worked (but all customization was lost of course).
Attaching the removed files in case they are of any interest.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers