Ubuntu Clock Won't Show Year

Bug #465689 reported by Lonnie Lee Best on 2009-10-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Panel
In Progress
Wishlist
Indicator Date and Time
Fix Released
Wishlist
Charles Kerr
gnome-panel (Ubuntu)
Wishlist
Unassigned
indicator-datetime (Ubuntu)
Low
Unassigned

Bug Description

indicator-datetime, Ubuntu 12.10

The Ubuntu menu bar clock offers no setting to "show year".

Yes, I know what year it is, but I have very good reason for wanting it shown. For years, I've been collecting screen-shots, when I'm doing something I think is pretty cool. When I use to use windows, these screen shots (over the years) have always showed the current year.

However, since April of 2007 (The date I started using Ubuntu exclusively), my screen shots have not included the year, because the Gnome clock doesn't provide this capability.

<https://wiki.ubuntu.com/TimeAndDate#settings>: "'Year' should be both insensitive and unchecked whenever 'Date and month' is unchecked..."

Related branches

For example, this page clear shows, that I made the top Google result for "crazy songs" on 02-12 2005 (See attachment)

However, in 2007, when I submitted the number one Digg article for the day, see the ubuntu screen shot (attached).

No year shown!

At bare minimum, I'd expect to see "show clock" in the gconf-editor, but more importantly, most user's expectations would be to see this as a check box option, after right-clicking on the Clock and selecting "Properties".

Here's another screen shot, compare and contract Ubuntu Clock to Windows 7 Clock (See attachment).

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

affects: gconf-editor (Ubuntu) → gnome-panel (Ubuntu)
Changed in gnome-panel (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Wishlist
Kamus (kamus) wrote :

This issue is already reported in Gnome BugTracker so for now I have mark this report as triaged. You can track and follow status of this requirement at: https://bugzilla.gnome.org/show_bug.cgi?id=317891 , Thanks in advance.

Changed in gnome-panel (Ubuntu):
status: New → Triaged
Changed in gnome-panel:
status: Unknown → Confirmed
Changed in gnome-panel:
importance: Unknown → Wishlist
description: updated

Here we are in 2012, and "show year" is still not an option on the clock in Ubuntu!

description: updated
Charles Kerr (charlesk) wrote :

Years aren't shown in the datetime indicator because it's not in the design <https://wiki.ubuntu.com/TimeAndDate>.

I don't have any opinion on this one way or the other... adding Design to the ticket for feedback.

Changed in indicator-datetime:
status: New → Confirmed
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Changed in indicator-datetime:
importance: Undecided → Wishlist
Changed in indicator-datetime (Ubuntu):
importance: Undecided → Wishlist

Call it what you want, but it is a option that is NOT there in Ubuntu, that IS there in Windows and Mac (see screen-shots I've provided).

If it is by design, it is an over-presumptuous design to assume that no one wants the year to be displayed; I've given very practical reasons for why I dearly prefer it.

John Lea (johnlea) wrote :

Hi MPT, could you talk a look at this bug. Thx!

Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)

After 3 years with no fix, I decided to use LXDE desktop, where I can easily configure the clock applet to any format I wish:
http://forum.lxde.org/viewtopic.php?f=8&t=88&p=39493#p39493

Now, in LXDE, I have my clock display set to:
%m/%d/%Y %l:%M %p

Which displays:
07/12/2012 1:49 PM

Perfect for me!

apport information

tags: added: apport-collected quantal running-unity
description: updated

My clock looks like this:
Thursday | 10-11-2012 | 1:40PM

Using this command:
gsettings set com.canonical.indicator.datetime time-format "'custom'" ; gsettings set com.canonical.indicator.datetime custom-time-format "'%A | %m-%d-%Y | %l:%M%p'"

Omer Akram (om26er) wrote :

Marked incomplete as we await design.

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Incomplete
Changed in indicator-datetime:
status: Confirmed → Incomplete
importance: Wishlist → Undecided
Changed in indicator-datetime (Ubuntu):
importance: Wishlist → Undecided
Changed in gnome-panel (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in ayatana-design:
assignee: Matthew Paul Thomas (mpt) → nobody
Changed in indicator-datetime (Ubuntu):
status: Incomplete → Confirmed
assignee: nobody → Matthew Paul Thomas (mpt)
Matthew Paul Thomas (mpt) wrote :

This seems like a reasonable request. Thanks for the report, Lonnie.

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
status: Confirmed → In Progress
Matthew Paul Thomas (mpt) wrote :
Changed in indicator-datetime (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
status: In Progress → Triaged
description: updated
no longer affects: ayatana-design
tags: added: saucy
Charles Kerr (charlesk) wrote :

We're waaaay past the UI/feature freeze for this cycle, but I'll try to pick this up post-13.10.

Changed in indicator-datetime:
status: Incomplete → Triaged
importance: Undecided → Wishlist
assignee: nobody → Charles Kerr (charlesk)
Changed in gnome-panel:
status: Confirmed → In Progress
Charles Kerr (charlesk) on 2013-10-30
Changed in indicator-datetime:
status: Triaged → In Progress
Changed in indicator-datetime (Ubuntu):
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-datetime at revision 282, scheduled for release in indicator-datetime, milestone Unknown

Changed in indicator-datetime:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+14.04.20131125-0ubuntu1

---------------
indicator-datetime (13.10.0+14.04.20131125-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * Switch the build system to cmake. (LP: #1237509)
  * As per the spec, let users show the year in indicator-datetime. (LP:
    #465689)
  * Don't generate g_critical() messages in the log when the timezone
    object is clearing its value. . (LP: #1246532)
  * When in the desktop-greeter mode, don't allow clicking on calendar
    dates to launch evolution. (LP: #1246812)
  * Use g_icon_serialize() output when setting menuitems' "icon"
    property.
  * In src/clock-live.c, pass the right pointer to
    on_detect_location_changed(). (LP: #1251460)

  [ Ted Gould ]
  * Adding a phone_greeter profile.
  * Upstart Job. (LP: #1185565)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 289
 -- Ubuntu daily release <email address hidden> Mon, 25 Nov 2013 03:55:52 +0000

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
Charles Kerr (charlesk) on 2014-03-05
Changed in indicator-datetime:
status: Fix Committed → Fix Released

Will I ever be able to convenience people that "show year" is actually a useful feature when taking screenshots over time?

Now, that I've upgraded to Ubuntu 18.04 and GNOME 3.28, it looks like I'll have to start this 2009 battle all over again. It will not allow me to format the clock the way I want it to display.

In Unity, I could at least achieved my desired clock format with a command:

gsettings set com.canonical.indicator.datetime time-format "'custom'" ; gsettings set com.canonical.indicator.datetime custom-time-format "'%A | %m-%d-%Y | %l:%M%p'"

In GNOME 3.28 on Ubuntu 18.04, I've yet to figure out a way to achieved my desired format. The GUI doesn't offer "show year" and I've yet to discover a command (like the one above) that achieves the exact custom format I desire.

tags: added: bionic
Jeremy Bicha (jbicha) wrote :

Lonnie, please use a separate gnome-shell bug for that issue.

I was ultimately able to achieve my exactly desired format using a GNOME extension made by Daniel Khodabakhsh. Thank you Daniel!

I found that here:
https://github.com/Daniel-Khodabakhsh/datetime-format

Screenshot:
http://neartalk.com/ss/2018-04-06_003_1919x1079.png

Format:
%A | %m-%d-%G | %I:%M %p

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.