Clock applet ignores locale settings

Bug #459939 reported by Gioele Barabucci on 2009-10-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Expired
Medium
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-panel

The clock applet shows Sunday as the first day of the week while it should be showing Monday as LC_TIME is set to it_IT.UTF8.

My locale is set so that the messages are displayed in US English while the rest of the environment adheres to the Italian standards (Celsius degrees, units and cents separated by comma, etc). It seems that the clock applet is ignoring these settings.

Maybe the problem is related to the fact that I once used gnome-language-selector.

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 24 20:11:02 2009
DistroRelease: Ubuntu 9.10
Package: gnome-panel 1:2.28.0-0ubuntu6
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: gnome-panel
Uname: Linux 2.6.31-14-generic x86_64

Gioele Barabucci (gioele) wrote :
Gioele Barabucci (gioele) wrote :

The output of the locale command (partially found in ProcEnviron.txt):

  $ locale
  LANG=en_US.UTF-8
  LANGUAGE=en_US.UTF-8
  LC_CTYPE=it_IT.UTF8
  LC_NUMERIC=it_IT.UTF8
  LC_TIME=it_IT.UTF8
  LC_COLLATE=it_IT.UTF8
  LC_MONETARY=it_IT.UTF8
  LC_MESSAGES="en_US.UTF-8"
  LC_PAPER=it_IT.UTF8
  LC_NAME=it_IT.UTF8
  LC_ADDRESS=it_IT.UTF8
  LC_TELEPHONE=it_IT.UTF8
  LC_MEASUREMENT=it_IT.UTF8
  LC_IDENTIFICATION=it_IT.UTF8
  LC_ALL=

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gnome-panel (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Gioele Barabucci (gioele) wrote :

This bug as already been reported upstream: https://bugzilla.gnome.org/show_bug.cgi?id=587752

Changed in gnome-panel (Ubuntu):
status: New → Triaged
Changed in gnome-panel:
status: Unknown → Invalid
Changed in gnome-panel:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.