Clock applet no longer shows weather in panel

Bug #447570 reported by Jim Louvau on 2009-10-09
48
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Low
Unassigned
Nominated for Maverick by Metin Amiroff

Bug Description

Binary package hint: gnome-panel

I'm not sure which recent update killed it, but weather no longer displays next to the time in the panel (Clock 2.28.0).

Location is and was configured correctly. In fact, if I enable expand_weather in gconf, I do get the correct weather info in the calendar window. But nothing ever displays in the panel.

I have tried re-installing the applet, deleting and re-entering the location, etc. No fix/work-around so far. Happening on 3 different machines that were fine recently (sorry I can't be more accurate, not something I always pay attention to).

ProblemType: Bug
Architecture: amd64
Date: Fri Oct 9 15:56:29 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: gnome-panel 1:2.28.0-0ubuntu4
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.42-generic
SourcePackage: gnome-panel
Uname: Linux 2.6.31-13-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:4489): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:4552): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:4519): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -4 and height 24
 (nautilus:4521): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Jim Louvau (jlouvau) wrote :
Jim Louvau (jlouvau) wrote :

Okay, I may have lost it when I changed the system to keep time with Internet servers from the default manual mode. Setting it back to manual fixed the issue. I then went in and set it back to using ntp and the fix seems to have held.

I seem to recall a clock bug re things not working right if TZ was different/incorrect/something like that. Perhaps this is related.

Sebastien Bacher (seb128) wrote :

was your internet and name servers working when you did the change?

Yes, one of the first things I checked.

Sebastien Bacher wrote:
> was your internet and name servers working when you did the change?
>
>

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
thatdude (thatdude) wrote :

I had the same issue where the weather was not showing. Resolved by going to System > Administration > Time and Date and select the correct time zone.

Architecture: amd64
DistroRelease: Ubuntu 9.10

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
assignee: nobody → thatdude (thatdude)
assignee: thatdude (thatdude) → nobody
laferter (laferte) wrote :

When you lick on the clock in the panel, under "Locations", do you have a little "home" displayed to the right of your location? If not, click on the "Set" button to set your home location, and the weather should be working after that. It fixed the problem for me a few minutes ago!

I also have this problem. It only gets fixed when I re-enter my Location Name (that is, Manila, Philippines).
My internet connection is working and I have no problems with my CMOS battery.

tags: added: likely-dup

likely duplicate with bug #397267

Jeremy Cantrell (jmcantrell) wrote :

I'm on Lucid, and this was only fixed for me after going to the time and date settings and re-entering my time zone which had been previously set.

Adam Hallgat (hallgat) wrote :

I noticed that problem. Actually it happened to me every day at 00:00. When I entered killall gnome-panel in the console, it restarted and worked fine. So I think the problem is the mindight time.

JohnnyRep (steffen894) wrote :

The "solution" posted in #9 works fine. (But just until the information gets lost again! ;))
You also have to do it for every location, which is kind of annoying when you have a couple of entries.

Metin Amiroff (amiroff) wrote :

I have the same problem on Maverick RC. My location in time zone settings was Asia/Istanbul. Changing to Europe/Istanbul fixed the problem. Why was it set to Asia in the first place? Installation was done the usual way with correct location selection being made.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers