[karmic] No icons in System menu

Bug #442973 reported by Gergely Fábián on 2009-10-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: xorg

There are no icons in the System menu in Karmic Beta (and also in Eclipse File Explorer's local menu I have experienced this).

Architecture: amd64
DistroRelease: Ubuntu 9.10
MachineType: LENOVO 27466FG
Package: xorg 1:7.4+3ubuntu5
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=9861fad7-8ece-4733-bfc9-a0f2d1f3389e ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=hu_HU.UTF-8
 LANGUAGE=hu_HU.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu6
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
Uname: Linux 2.6.31-11-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 04/01/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6AET57WW
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: 27466FG
dmi.board.vendor: LENOVO
dmi.board.version: LENOVO 6AET57WW
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: LENOVO 6AET57WW
dmi.modalias: dmi:bvnLENOVO:bvr6AET57WW:bd04/01/2009:svnLENOVO:pn27466FG:pvrThinkPadSL:rvnLENOVO:rn27466FG:rvrLENOVO6AET57WW:cvnLENOVO:ct10:cvrLENOVO6AET57WW:
dmi.product.name: 27466FG
dmi.product.version: ThinkPad SL
dmi.sys.vendor: LENOVO
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-11-generic

tags: added: apport-collected

There are no icons also for Firefox's Search Plugin select menu (where is Google, Ubuntu Package Search, etc.). Interestingly icons are shown for the selected element.

Bryce Harrington (bryce) on 2009-10-05
Changed in xorg (Ubuntu):
status: New → Confirmed
Robert Hooker (sarvatt) wrote :

This is a new intended change in gnome 2.28, you can enable it again by running gconf-editor and changing these two keys to true.

/desktop/gnome/interface/buttons_have_icons
/desktop/gnome/interface/menus_have_icons

More info on the change:

" * GNOME menus and buttons have been standardised across all applications to not display icons by default. Menu items with dynamic objects, including applications, files or bookmarks, and devices are the exception and can display an icon. This change will standardise the look and feel of menus and present a cleaner interface to users."

http://library.gnome.org/misc/release-notes/2.28/

Changed in xorg (Ubuntu):
status: Confirmed → Invalid

I have set those keys to true, restarted system and there are still no icons in those places (checked the settings after restart, and they say true).
On the other hand did Ubuntu intend to remove icons from System menu and from Firefox's Search plugin's drop-down?

komputes (komputes) on 2009-10-06
Changed in xorg (Ubuntu):
status: Invalid → Confirmed
komputes (komputes) wrote :

I can confirm this bug as well. (see attached)

Even with the gconf values on /desktop/gnome/interface/buttons_have_icons and /desktop/gnome/interface/menus_have_icons set to false, you will see that editing menus and turning on the hidden "Control Center" icon. This is an inconsistency.

As well, shouldn't these gconf values control the ENTIRE menu (Applicatipns, Places and System). As it says in the GNOME changelog "GNOME menus and buttons have been standardised across all applications to not display icons by default" - ALL APPLICATIONS, not just the system menu.

In karmic it only seems to affect the System Menu. Even though this may be a default, and an intended change in GNOME 2.28, I would like to say that IMO we (in Ubuntu) should keep icons in the system menu.

komputes (komputes) wrote :
affects: xorg (Ubuntu) → gnome-panel (Ubuntu)
komputes (komputes) wrote :

In fact, why was this even chosen as a GNOME default and why does it not seem to affect anything but the System Menu?

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in gnome-panel (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Igor Guerrero (igorgue) wrote :

The fact that you can fix it with the gconf-editor doesn't make this bug invalid... and as komputes said why does it only affect the system menu?

Igor Guerrero (igorgue) wrote :

Upps sorry about that, this is a duplicate bug :)

hazard (hazard-pad) wrote :

Ok. I had the same problem. Affected only Preferences / Administration / Help and Support / About Gnome / About Ubuntu and just setting true /desktop/gnome/interface/menus_have_icons resolved the problem. But it is weird that when it was set on false not all the menu was affected.

I have same problem in 9.10 and in 10.04 after upgrade - please help with this

Changed in gnome-panel (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers