circle -> places -> bookmark doesn't work

Bug #43905 reported by Tom Vaughan
10
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

i have bookmarks in nautlius that worked just fine under breezy, but not under dapper. if i select circle -> places -> bookmark, then i am told by nautilus that there is no default action associated with this location (see error.png). but if i have a nautilus window open, e.g. Home Folder, and select the bookmark from the the Places column, then the bookmark works. these bookmarks are a link to a smb share (buffalo linkstation), ftp, and davs. all of which exhibit the same behaviour.

Revision history for this message
Tom Vaughan (tvaughan) wrote : nautilus error message

this is the nautilus error message described in this problem report.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for your bug. What do you call "circle"?

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Revision history for this message
Tom Vaughan (tvaughan) wrote :

"circle" is the ubuntu circle of friends logo on the panel, the main menu button.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Confirmed, note that you can click on the labels on the panel directly, no need to click on the logo :)

Changed in nautilus:
status: Needs Info → Confirmed
Revision history for this message
Tom Vaughan (tvaughan) wrote :

i've customized my panels, and only have one panel at the bottom with just a all-in-one main menu button, aka "circle". it's a dell inspiron x1 and i don't have much vertical space to spare. thanks.

Revision history for this message
Sebastien Bacher (seb128) wrote :

In fact that was an another issue on my box due to the ftp server I was trying with. Could you run "gnomevfs-info smb://badonkadonk/tvaughan" and copy that to a comment?

Changed in gnome-panel:
status: Confirmed → Needs Info
Revision history for this message
Tom Vaughan (tvaughan) wrote :

$ gnomevfs-info smb://badonkadonk/tvaughan
Name : tvaughan
Type : Directory
MIME type : x-directory/smb-share

Revision history for this message
Sebastien Bacher (seb128) wrote :

Do you still have that issue with dapper or edgy?

Revision history for this message
Tom Vaughan (tvaughan) wrote : Re: [Bug 43905] Re: circle -> places -> bookmark doesn't work

On Tue, 2006-09-26 at 09:56 +0000, Sebastien Bacher wrote:
> Do you still have that issue with dapper or edgy?
>

kinda. i can create bookmarks, but what i don't like is that ftp links
now open in firefox, not nautilus.

-tom

Revision history for this message
Sebastien Bacher (seb128) wrote :

do you have the same behaviour with "gnome-open ftp:URI"? Did you set some /desktop/gnome/url-handlers/ftp gconf keys for it?

Revision history for this message
Tom Vaughan (tvaughan) wrote :

i am now running edgy, and this problem has disappeared. ftp url's work
as i would expect them to, they open in nautilus. thanks.

-tom

On Sun, 2006-12-17 at 11:58 +0000, Sebastien Bacher wrote:
> do you have the same behaviour with "gnome-open ftp:URI"? Did you set
> some /desktop/gnome/url-handlers/ftp gconf keys for it?
>

Revision history for this message
Sebastien Bacher (seb128) wrote :

Marking fixed then, thank you for the update

Changed in gnome-panel:
status: Needs Info → Fix Released
Revision history for this message
Tom Vaughan (tvaughan) wrote :

i've just discovered that if you allow firefox to set itself as the preferred web browser then it sets several of the url-handler gconf keys such as http, https, ftp, gopher, and chrome. this causes ftp bookmarks in nautilus to open in firefox. if you set the preferred web browser back to the default value via gnome preferred applications, the ftp url-handler is left as firefox. i'm not so sure i expect setting my preferred *web browser* to firefox to also set my preferred *ftp client* to firefox... hope this helps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers