Panel in middle of the screen after reboot when not full-sized

Bug #39856 reported by Tobias F. on 2006-04-17
130
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
High
gnome-panel (Kairos Linux)
New
Undecided
Unassigned
gnome-panel (Ubuntu)
High
Ubuntu Desktop Bugs
Hardy
Medium
Ubuntu Desktop Bugs

Bug Description

Happens when the box to fit the panel to screen width in its properties dialog is unchecked:

After restarting X the panel that is supposed to be at the bottom of the screen is right in the middle of it. The panel stays there until I check the box to fit the panel to screen width in its properties dialog.

TESTCASE:
* log in GNOME using a stock user configuration
* right click on the bottom gnome-panel, properties, unselect the expense option there
* close the session and log in again

the gnome-panel is moved at the top of the screen, after installing the upgrade it behaves correctly (you need to try on a new account or reset the gconf configuration to try though)

Tobias F. (captain-tf) on 2006-04-17
description: updated
Sebastien Bacher (seb128) wrote :

Thanks for your bug.

from bug #44333:

"When I unckeck the "expand" button for the default bottom panel. Log out and log in again; The panel which should (still) be appearing at the bottom of the screen, places itself just under the top panel. This behaviour was also found in the 'previous' version (Breezy).

Steps to reproduce:
- Create a new "desktop" user
- Log in to Gnome with newly created account
- Right-click bottom panel "Properties"
- Uncheck the "Expand" button
- Hit "Close" button
- Log out of session
- Log back in to Gnome again with same account (new one)

>> Now the bottom panel places itself just under the top panel

Note: When you try to set the orientation back to "Bottom" for the (previous) Bottom-panel, It refuses that and 'automagically' reverts back to "Top". Except when first checked the "Expand" button, it allows to set the orientation back to "Bottom"."

Vincent, do you think that's a panel or window manager bug?

Changed in gnome-panel:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Kasper Peeters (kasper-peeters) wrote :

Something similar happens when switching the panel to be on the left or right:

  1. Setup panel to be 'top' and unset 'expand'.
  2. Re-open panel properties.
  3. Set location to be 'left' or 'right'.

The panel now appears in the middle of the screen. Then do

  4. Set 'expand',

and the panel goes to the left or right as it should have done rightaway.

Vincent Untz (vuntz) wrote :

I don't think this can be a window manager bug. Most probably a panel bug. Feel free to forward :-)

Sebastien Bacher (seb128) wrote :
Tobias F. (captain-tf) wrote :

Works alright with up-to-date release.

:-D

Snellgrove (snellgrove) wrote :

This just happened to me (its happened before, too) after I changed my graphics driver to "nv" from "nvidia" and restarted X (obviously, my resolution was lowered when using "nv")

After doing what I needed to do, I changed back to "nvidia" and back to lovely high resolution but the panel I normally have at the bottom (which is not expanded, sits in the centre with my icons) was shrunk down to 2 icons wide and I couldn't stretch it back out to its normal size and it was not at the bottom of the screen in the high resolution, it was where it was when I was running low resolution in the "nv" driver - so it was near the centre of the screen in terms of height (Y Axis) it was still in the centre in terms of X axis.

hope this helps..

ColinLaurie (luxcal) wrote :

Ditto for me on Ubuntu 6.06.
Also Panel on Left or Right does not align all the text to horizontal, even when the pixel size is increased.

Changed in gnome-panel:
status: Rejected → Unconfirmed
Morlan Liu (morlanliu) wrote :

I was modifying my xorg.conf file to use my Dell Inspiron 630m S-Video port and got it working but ever since my gnome-panel starts in the center of the screen until I expand then unexpand it.

I am now using my original xorg.conf file but the bug remains. Is there a solution to this?

djanderson (douglasjanderson) wrote :

This is a pretty serious bug because you can't drag the bar back down with your mouse, you have to recheck the expand option. Isn't that really confusing for new users?

I'm using feisty with all updates applied. My panel version is:
$ gnome-panel --version
GNOME gnome-panel 2.17.92

I have the exact same problem as mentioned above. My resolution is set correctly (1400x1050 IBM T43 with Radion M300 running OS driver) in both gnome's resolution application and in xorg.conf, which I haven't modified (except to add middle mouse scroll or something).

I really hope this gets squashed before release time... it's a biggun...

AntonChanning (antonchanning) wrote :

I realise that both problems are identical, so maybe my screenshot is redundant.

It appears to me that both problems are caused by the panel positioning itself
for a 800x600 screen, even though a higher resolution has been selected.

Like the experience of others here, the problem is temporarily fixable by
simply expanding the panel and then unexpanding it again. Unfortunately
it doesn't remember its new position after reboot.

Paul Whittaker (launchpad-pdw) wrote :

I've tried the following workaround, and it works for me across a session logout/login.

Short:
Use gconf-editor to change the value of /apps/panel/toplevels/bottom_panel_screen0/y to the vertical screen resolution.

Notes:
I ran gconf-editor from the terminal. There were other keys for bottom_panel_screen1 and top_panel_screen[0/1] visible, but I tried this one first and it worked for me. When I changed the value to the current vertical resolution it appeared to invoke some magic, because the value automatically adjusted to put the panel at the bottom of the screen: I typed "1024", hit return, and a split second later it said "975" where it used to say "1024". The calculation appears to be ((Y resolution - Panel size) - 1). Panel size is visible in the panel properties dialog. As soon as the new value was entered, the panel moved to the new position, and I quit gconf-editor.

Thanks:
Originally found in dbloom's post at http://ubuntuforums.org/showthread.php?t=117997

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gnome-panel:
status: Confirmed → Fix Committed
Changed in gnome-panel:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

gnome-panel (1:2.19.5-0ubuntu1) gutsy; urgency=low

  * New upstream version:
    Panel
    - Make changing orientation of an expanded panel work better when
      dragging the panel
    - Fix name of launcher created by dropping an URI on the panel
      (LP: #35919)
    - Improve handling of size hints from applets. This is needed for the
      tasklist sizing algorithm to correctly work
    - Use new icon for recent documents
    - Save the panel position relatively to the right/bottom edge of the
      monitor when needed. This fixes a lot of problems, like the panel
      being at the center of the screen when resizing the screen or when
      the size of the panel grows. (LP: #39856)
    - Also do not save the position of the panel in gconf when the position
      is changed because of constraints. This also fixes a lot of problems,
      like the panel suddenly snapping to the center or an edge of the
      screen because its size has changed.
    - Fix crash when a panel is destroyed whil its context menu is opened
    - Make it possible to have bigger panels (up to 1/5 the screen size)
      for people wanting sidebars
    - Fix a crash in the lockdown checking code
    - Don't use nautilus-home.desktop for the places menu, but makes the
      item a real place item
    - Automatically use the right icon for launchers for $HOME or ~/Desktop
    - Migrate to GtkTooltip
    - Code cleanups
    - Add a detail for theming the arrow in the button widget
    - Add new _GNOME_PANEL_ACTION_KILL_DIALOG action to the panel action
      protocol
    - Use program-name instead of name property for GtkAboutDialog
    gnome-desktop-item-edit
    - Use g_option_context_set_translation_domain()
    All applets
    - Use gtk_widget_set_tooltip_text()
    - Use program-name instead of name property for GtkAboutDialog
    - Fix compilation
    Clock Applet
    - Sort completed tasks last, treat unprioritised tasks as normal
      priority, and fall back on sorting by summary
    - Add a first version of timezone support. This needs some UI love.
    Window List Applet
    - Do not call wnck_screen_force_update(). Fix a crash.
    - Code cleanups
    - Fix window list sizing (most of the changes are in libwnck) (LP: #16391)
    - Deprecate minimum/maximum size settings
    Workspace Switcher Applet
    - Code cleanups
    - Show/hide some of the settings in the properties dialog depending on
      the window manager, since some of the settings are not saved or don't
      make sense when metacity is not used.
    Misc
    - Require libwnck 2.19.5
    - Add libbonobo and libbonoboui explicit checks for compilation
  * debian/control.in:
    - updated libwnck requirement
  * debian/patches/01_layout.patch:
    - updated
  * debian/patches/09_lpi.patch:
    - updated
  * debian/patches/12_autoreconf.patch:
    - updated

 -- Sebastien Bacher <email address hidden> Mon, 09 Jul 2007 18:33:05 +0200

Changed in gnome-panel:
status: Fix Committed → Fix Released
Stéphane Marguet (stemp) wrote :

Still have this issue (bottom/top with non expanded panel) with :
gnome-panel Version : 1:2.19.92-0ubuntu1

I still have the bug.

--- Stéphane Marguet <email address hidden> wrote:

> Still have this issue (bottom/top with non expanded
> panel) with :
> gnome-panel Version : 1:2.19.92-0ubuntu1
>
> --
> Panel in middle of the screen after reboot when not
> full-sized
> https://bugs.launchpad.net/bugs/39856
> You received this bug notification because you are a
> direct subscriber
> of a duplicate bug.
>

Regards
  Ferdaus

  Ph:416-449-7593 (LL)
       416-268-3809 (cell)

Changed in gnome-panel:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

could you describe steps to trigger the bug?

Changed in gnome-panel:
status: Confirmed → Incomplete
Stéphane Marguet (stemp) wrote :

On a bottom panel (orientation bottom), click on properties, uncheck the expand option.
Log out.
Log in.
The panel orientation is top and you can't change it unless you change the expand option to true.

Ferdaus (ferdausalamin) wrote :

Hi

If panel prperties is selected to be in the Middle (on
Application, Place, System) and then one switches off.

Next time one starts in Ubuntu, this panel comes in
the middle.

I fix it by going to properties..
-->then selecting EXPAND
--> then again selecting MIDDLE

Thanks
Ferdaus

--- Sebastien Bacher <email address hidden> wrote:

> could you describe steps to trigger the bug?
>
> ** Changed in: gnome-panel (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Panel in middle of the screen after reboot when not
> full-sized
> https://bugs.launchpad.net/bugs/39856
> You received this bug notification because you are a
> direct subscriber
> of a duplicate bug.
>

Regards
  Ferdaus

  Ph:416-449-7593 (LL)
       416-268-3809 (cell)

Changed in gnome-panel:
status: Incomplete → Confirmed
Changed in gnome-panel:
status: Unknown → New
Stéphane Marguet (stemp) wrote :

The panel is not moving up anymore.

gnome-panel Version : 1:2.20.0.1-0ubuntu2

Kelvin Vanderlip (kelvin-zft) wrote :

I just tried 7.10 preview on a Samsung Q45 and I get this behavior still (Oct 14 2007 download). The top panel is at the top OK, but it is 1024 pixels wide though the screen is 1280 wide, and the bottom panel (same width) sits above the bottom of the screen as though the bottom was 786 (or whatever that is normally) while the actual screen is 800 pixels tall. I cannot find a way to change this.

seanvt (spoust) wrote :

Hi,

Just upgraded from Feisty to Gutsy and now I have this unfortuntate problem too. I use the bottom panel as a kind of launcher dock. I make it 50 px tall and all I have in it are the launchers for seven progs that I use a lot. I keep it on the bottom and I have "expand" unchecked, so it's centered.

When I log out and log in it's up on top of the screen, just under the "real" top panel. I can't switch it back to "bottom". If I go into properties and try to click "bottom", my selection just stays as "top".

So I expand it - and then it lets me move it down to the bottom.

Now I've got it on the bottom but there's space where some icons used to be - Firefox, Thunderbird, Gedit, usually.

So I make a new launcher for firefox, for example, and drag it onto the panel - and TWO firefox icons appear. Because the first one didn't really go away, you just couldn't see it after the wonky top-and-bottom behavior happened.

I'm on a Panasonic toughbook W4 with 1 Gig Ram.

This is a bummer because I'm really enjoying gutsy otherwise. :(

--
SeanVT

currtj35 (currtj35) wrote :

I recently upgraded to Gutsy 7.10 and I am experiencing this problem as well. I also use the bottom panel as a launcher for commonly used programs. Upon logout and login the panel aligns itself directly under the fixed top panel. To get it back down to the bottom I must first check the expand button then switch the drop-down menu to bottom, then uncheck the expand button in order to achieve the desired look. I am using a IBM thinkpad R31 with 512MB ram.

Changed in gnome-panel:
milestone: none → ubuntu-8.04
Sebastien Bacher (seb128) wrote :

the bug will not likely be fixed before hardy now, changing the milestone to later

Changed in gnome-panel:
milestone: ubuntu-8.04 → later
status: Confirmed → Triaged
Axel Haustant (noirbizarre) wrote :

I have this issue on both gutsy and hardy beta. This is an import issue as it make gnome panel unusable if not stretched on top.

I'm using hardy (with all updates till my post) and my problem is very similar to the ones mentioned,
the top unexpanded panel now always goes to the bottom when I re-login.
Everytime I login I must
1- Right click on the panel and check "Expand"
2- Change Orientation to "Top"
3- Uncheck "Expand"

I can't change the orientation unless it's expanded, if I choose "Top" and it's not expanded, it overrides my selection with "Bottom" again without doing anything.

M. Nease (mlnease-hctc) wrote :
M. Nease (mlnease-hctc) wrote :

Hello,

I hope it is appropriate to post here that I have the same problem in newly upgraded (and otherwise splendid) Hardy. Thanks.

mike

Shofi Islam (shofi-islam) wrote :

I confirm this is still a bug in Hardy. Judging by the wide variety of graphics cards used this isn't an X or Video problem.

The workaround by "Paul Whittaker 2007-05-29" worked. This suggests a problem with how to handle panels under /aps/panels/toplevels as in gconf-editor. I don't know which file this is updating, but I think it is assuming the first entry to be the top panel and the second entry to be elsewhere.

M. Nease (mlnease-hctc) wrote :

Hi Shofi,

Thanks for this. I thought I had already posted these here; I hope they aren't redundant.

These are screen prints of output from gconf-editor. I hope they may be of use to someone.

mike

M. Nease (mlnease-hctc) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.23.5-0ubuntu1

---------------
gnome-panel (1:2.23.5-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    Panel
    - Use new icon name for shutdown
    - Continue code cleanup
    - Fix crash when editing launcher and setting an empty name
    - Fix compiler warnings
    - Fix some gconf values in the default layout (lp: #39856)
    libpanel-applet
    - Fix compiler warnings
    Clock Applet
    - When opening the "set time" window, also set the day on the calendar
    so that the user doesn't accidently set a time in the past
    - Show groupwise and exchange appointments in the calendar
    - Load calendars asynchronously (lp: #194505)
    - Fix compiler warnings
    - Use the right color for tasks and appointments (lp: #173413)
    - Fix leak and correctly handle ical memory
    Notification Area Applet
    - Fix compiler warnings
    Show Desktop Applet
    - Use "user-desktop" icon name
    Wnck Applets
    - Fix compiler warnings
  * debian/control.in:
    - don't use a version build-depends on scrollkeeper
  * debian/patches/08_clock_applet_event.patch:
    - dropped, the bug should be fixed in the new version
  * debian/patches/10_appointment_colors.patch:
    - dropped, the change is in the new version
  * debian/patches/18_clock_capplet_use_time_admin.patch:
    - comment this change in the series and use the upstream version now

 -- Sebastien Bacher <email address hidden> Wed, 23 Jul 2008 09:23:21 +0200

Changed in gnome-panel:
status: Triaged → Fix Released
Changed in gnome-panel:
status: New → Fix Released
Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Confirmed
description: updated
Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-panel:
status: Confirmed → Fix Committed

Hi Martin,

Thanks for all your efforts. When I followed the instructions at
https://wiki.ubuntu.com/Testing/EnableProposed , I received this
terminal output:

mn@mn-desktop:~$ sh -c 'kill -SEGV $$'
Segmentation fault
mn@mn-desktop:~$

I'm running Ubuntu 9.04--do you need any more info? Have I missed
something obvious?

Thanks Again,

Mike Nease

Martin Pitt wrote:
> Accepted into -proposed, please test and give feedback here. Please see
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you in advance!
>
> ** Changed in: gnome-panel (Ubuntu Hardy)
> Status: Confirmed => Fix Committed
>
> ** Tags added: verification-needed

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gnome-panel:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

M. Nease, with that command you just tested whether apport is working. If your intention was to enable apport, this was ok, but it is not for testing the new gnome-panel in this bug. Also, I take it you run 8.04, not 9.04 (which isn't even planned yet :) ).

M. Nease (mlnease-hctc) wrote :

Thanks for the good work and for the response, Martin--I thought my last
message to you was lost. I was attempting to test and respond to
launchpad--I'll be glad to help test and so on if I can just negotiate
the initial hurdles. Yes, I'm running 8.04--

By the way, I had found a workaround at
http://ubuntuforums.org/showthread.php?t=278954 from Vincentvee:

"yeah i got the same problem, i fixed it, hit alt+f2 type gconf-editor
got to apps on the left menu, then go to panel>toplevels>panel_0 you
should have a value on the right called y_bottom which is set at -1 by
default, what you should do is increse that value to a positive value, i
used 10, that made my panel stick to the bottom when un-expanded.
good luck with it..."

Sorry I didn't share this earlier and

Thanks Again,

mike

Martin Pitt wrote:
> M. Nease, with that command you just tested whether apport is working.
> If your intention was to enable apport, this was ok, but it is not for
> testing the new gnome-panel in this bug. Also, I take it you run 8.04,
> not 9.04 (which isn't even planned yet :) ).
>

austin (mail-axelrosenthal) wrote :

bug still there in ubuntustudio karmic
workaround setting the value y (I set it to 1280) still works!
my panel - that is supposed to appear at bottom without expand - appears at top without expand after relogin

Tory (tory-andrew-law) wrote :

Interesting.... this is effecting me in 10.04 .... but, in only one of the two profiles on the computer. Odd.

Richard85 (rll1509) wrote :

This bug is definitely alive in 10.04.
See
http://ubuntuforums.org/showthread.php?p=9838002#post9838002

Got a buddy of mine to reproduce it.

Changed in gnome-panel:
importance: Unknown → High

Still bugging people in Debian's squeeze.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.