gnome-panel crashed with signal 7 in panel_shell_register()

Bug #366344 reported by DrC on 2009-04-24
6
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-panel

Ubuntu 0904 downloaded yesterday, used as a live CD on Dell Dimension 3100 with USB kbd, mouse, Brother DCP-540CN and a nondescript USB webcam. A mouse-pad-cum-USB hub connects keyboard, mouse and webcam.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Disassembly: 0x8089570 <panel_shell_register>:
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/gnome-panel
MediaBuild: Ubuntu 9.04 "Jaunty Jackalope" - Release i386 (20090420.1)
Package: gnome-panel 1:2.26.0-0ubuntu7
ProcCmdline: gnome-panel
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 7
SourcePackage: gnome-panel
Stacktrace:
 #0 0x08089570 in panel_shell_register ()
 #1 0x08063019 in main ()
StacktraceTop:
 panel_shell_register ()
 main ()
ThreadStacktrace:
 .
 Thread 1 (process 5588):
 #0 0x08089570 in panel_shell_register ()
 #1 0x08063019 in main ()
Title: gnome-panel crashed with signal 7 in panel_shell_register()
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

DrC (drcowsley) wrote :
visibility: private → public
DrC (drcowsley) wrote :

Reboot - I got an X-server error (not visible) with an out-of-vertical synch static black band across the centre of the display. The body of the error message was not visible.

There was a choice (Retry or Continue I think from memory) but the keyboard was not working properly ( I got another retry button and other screen corruptions but neither option was properly selectable, and Return didn't).

Ctrl-Alt-Del got me into a reboot. On the third attempt the live CD booted properly and I got panels and menus on the GUI.

I cannot exclude the possibility of CD reader faults - yet. I will do a check on the CD and report back......

DrC (drcowsley) wrote :

COLD BOOT - disk error message on two out of two occasions, offering to retry which invariably succeeds. The first occasion was when the CD was first loaded. The second preparatory to doing the integrity check.

REBOOT - always (6 times now) reads OK as far as I know, including the disk integrity check.

I have to give this hardware back to my wife for now. If others experience the problem and I need to return to it it will be possible, but for now I'm off to my own hardware to see what that does.

StacktraceTop:panel_shell_register (replace=0) at panel-shell.c:78
main (argc=) at main.c:75

Changed in gnome-panel (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
DrC (drcowsley) wrote :

CD fault confirmed - two CDs written on the same drive using media from the same close source both demonstrated unreliability - one consistently worse than the other. The read process is marginal.

The same two media performed with consistent load times and no errors on other hardware.

It may still be worth looking at the bug detail to see whether misreads have been accepted (checksum checks failing?) or error handling code has misbehaved. But such considerations are way out of my depth.

Changed in gnome-panel (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Pedro Villavicencio (pedro) wrote :

Could you still reproduce this or indeed was the CD that was causing the issue?

Changed in gnome-panel (Ubuntu):
status: New → Incomplete
DrC (drcowsley) wrote :

I strongly suspect the CD reader. I have tried again tonight on the same hardware with CD No 1 used previously. Warm reboot from shutting down Windows came up alright on the live CD with both panels and all expected panel contents.
A shutdown and cold boot also loaded OK. I ran a launchpad hardware test which should appear somewhere with my email account attached. There were two defects:
 - one - the default English keyboard is the US keyboard. I am in the UK. (A colleague who installed from the live CD ended up with a US keyboard and had to be shown how to correct it.)
 - the second - no sound. I don't know whether this is a characteristic of this Dell model. The welcoming chime was loud and clear when I returned the machine to Windows and my wife.
I would recommend putting this bug report in suspense unless/until either:
 - someone else has a similar experience or
 - a bug is found in the read checking logic of the live boot
in either case, with my wife's agreement I will do my best to make the hardware really flakey (ie let it cool right down) and see if there is a detectable difference between this original version and any update.

Chris

Sebastien Bacher (seb128) wrote :

do you still get the issue?

DrC (drcowsley) wrote :

A newly downloaded image (Linux ubuntu 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux) has loaded the live image today without issue.

The original problem was almost certainly a CD read issue, and the only useful input is the observation that the read checks failed, allowing a non-functional system to be loaded.

The unreliability is not apparent on a CD written today, loaded today.

Today is very much warmer than it was in April.

Chris

Victor Vargas (kamus) wrote :

According to last message this issue was solved with a newly and fresh cd image. for now I will close this report but if you encounter that this issue is still affecting you under latest version of Ubuntu please reopened. Thanks in advance

Changed in gnome-panel (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers