Ubuntu

double-clicking a date should start evolution on the right day

Reported by Tollef Fog Heen on 2006-03-16
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Medium
gnome-panel (Ubuntu)
Low
Unassigned

Bug Description

As the summary says, if you double-click a date in the calendar, it should spawn evolution on the specified date.

(Patch forthcoming)

This fixes the bug, it spawns evo for the correct day. For proper operation, evolution should be fixed to not spawn an extra window when it's given URLs on the command line (patch for that has already been submitted)

Sebastien Bacher (seb128) wrote :

Thanks for the patch Tollef, I've forwarded it upstream on http://bugzilla.gnome.org/show_bug.cgi?id=162305 and I'll ship with the package for dapper if it's not done by upstream for it

Changed in gnome-applets:
assignee: nobody → seb128
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for the patch Tollef, this upload fixes the issue:

 gnome-panel (2.14.0-0ubuntu2) dapper; urgency=low
 .
   * debian/patches/07_clock_applet_spawn_evo_right_day.patch:
     - make double clicking on a day from the panel calendar open the
       evolution calendar on the same day, patch by Tollef (Ubuntu :#35167)

Changed in gnome-panel:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

fixed upstream, bugzilla comment:

"I committed a modified version of Tollef's patch.

We still need to do something when clicking on a task or on a particular
appointment."

Sebastien Bacher (seb128) wrote :

fixed to dapper

Changed in gnome-panel:
status: Fix Committed → Fix Released

if you look at the 'impl_handleURI' function in 'calendar-component.c', the standard function 'time_from_isodate' is used to parse 'startdate' and 'enddate' values. the 'time_from_isodate' documentation states the string must be a Date/time value in ISO 8601 UTC format.

in other words, the date string must include the time and be in UTC. the format is also specified in the upstream of this bug:

http://bugzilla.gnome.org/show_bug.cgi?id=162305

Changed in gnome-panel:
status: Fix Released → Confirmed
Changed in gnome-panel:
status: Unconfirmed → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

This sounds similar to Bug #17621

Sebastien Bacher (seb128) wrote :

that bug has been fixed, the wrong day problem is described by bug #66028

Changed in gnome-panel:
assignee: seb128 → desktop-bugs
status: Confirmed → Fix Released
Changed in gnome-panel:
status: Confirmed → Fix Released
Changed in gnome-panel:
importance: Unknown → Medium
loko (arph) wrote :

I reopen the bug because the same thing happens to me in Maverick now.

Changed in gnome-panel (Ubuntu):
status: Fix Released → Confirmed
loko (arph) wrote :

Is somebody working on this problem? It is really annoying and it seems to be a general problem of the latest linux distributions. This bug happens in fedora 14 too.

Musigreg (greg-drouin) wrote :

Same problem here.
I 'd like to add that clicking on the calendar opens an extra window too, in addition to displaying the date D -1.
In Maverick too.

xcape77 (xcape77) wrote :

same problem in ubuntu 10.04. 10.10 and debian 6.0

Changed in gnome-panel (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
importance: Medium → Low
milestone: ubuntu-6.06 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.