Ubuntu

Keyboard focus get lost in Gnome panel

Reported by Vorname Nachname on 2006-03-09
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Gnome panel 2.13.92:

The keyboard focus gets lost when navigating with keyboard in Gnome panel.

How to reproduce:

1. Press Ctrl-Alt-Esc so that you get the focus on the panel.
2. You get a highlighted rectangle which is your keyboard focus.
3. Navigate a little bit with cursor left/right - no problem so far.
4. But if you navigate to the right with cursor right through the application list panel and still press cursor right, the focus of the keyboard gets lost.
5. Now you cannot navigate with the keyboard in the panel any more.
6. Unfocus the panel with i. e. a click with the mouse on the Desktop.
7. Press Ctrl-Alt-Esc again to get the focus on the panel again.
8. Now the problem is you get no keyboard focus any more and you cannot navigate through the panel with cursor left/right.

Press Ctrl-Alt-Esc to get the focus. Now press "cursor right" 20-30 times and the focus gets lost.
You only get it back if you click on an application in the window list applet. But that means you have to use the mouse and cannot navigate completely with the keyboard through the panel.

Manu Cornet (lmanul) wrote :

Huh, I don't really get it. Define "cursor" ? If I try "Ctrl-Alt-Esc" the panel gets highlighted by a black rectangle, then I release the keys, and if I press the right/left arrows (on the keyboard), nothing happens. Is that what should be done to reproduce the bug ? What should happen ?

Anyway, marking as minor severity :)

Changed in gnome-panel:
status: Unconfirmed → Needs Info

Yes, with cursor I mean this black dotted rectangle which is appears around an icon if you have icons on your panel. See my screenshot where I highlighted the black dotted rectangle with a red rectangle.

Right - what I mean is that you CAN navigate with cursor left/right through your panel. But if you press for example 20 times cursor right, this small black rectangle gets lost and you're not able to navigate through the panel any more.

I'm not disabled but sometimes it's faster to navigate with the keyboard than with your mouse. I think it is also important for disabled persons but I haven't talked with one, though.

Sebastien Bacher (seb128) wrote :

Is that specific to an applet? Pressing right on the windows list on my box goes to the next component which is the notify area and it works fine

Changed in gnome-panel:
assignee: nobody → desktop-bugs
Sebastien Bacher (seb128) wrote :

do you still have that issue with dapper?

With newest Dapper updates it works, now. Even with the new Novell Gnome menu and some additional applets.
But sometimes it still doesn't work. Haven't found the reason why it works sometimes and sometimes not. Will add a comment here when I find the reason.

Daniel Holbach (dholbach) wrote :

Any news on aour investigations?

I think I found the problem:

If I start KDE apps like Kontact under Gnome - the keyboard focus gets lost in the systray where I have the KAlarm and KMail icons docked to systray.

If I quit KAlarm and KMail I can navigate through the panel with the keyboard without problems.

Daniel Holbach (dholbach) wrote :

Subscribed the Kubuntu team - hopefully they have some more insight into this.

Changed in gnome-panel:
status: Needs Info → Unconfirmed
Sebastien Bacher (seb128) wrote :

Do you still get the bug?

Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gnome-panel:
status: New → Invalid

Sorry, haven't had recognized your comment.

Yes it still happens with Gutsy Tribe3 + current updates. When I have no KDE apps in systray I can move forward and backward between icons in panel. If I start for example klipper, keyboard focus gets lost at klipper's icon so that I can not move forward and backward any more.

Changed in gnome-panel:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in gnome-panel:
status: New → Incomplete
Sitsofe Wheeler (sitsofe) wrote :

I've just done some testing with a Hardy Alpha from last week and the problem has changed a little. Tab focus no longer stops on the notification area under any circumstances. While this prevents keyboard focus being swallowed, it also prevents you from interacting with any notification area applets from the keyboard. I've tried moving the location of the notification area but the new behaviour persists.

Version information:
Ubuntu Hardy (Alpha)
gnome-panel 1:2.21.90-0ubuntu2

Changed in gnome-panel:
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

Ubunter, you're welcome to submit a patch for it if you can reproduce it, thanks.

Ubunter (quest123456) wrote :

I don't speak C, sorry.

Pedro Villavicencio (pedro) wrote :

May someone experience the bug can forward it upstream? for forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; leaving this as incomplete until it gets forwarded, thanks.

Changed in gnome-panel:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in gnome-panel:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers