Drawer in doesn't work with xinerama

Bug #32285 reported by Walther Zwart
8
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Low
gnome-panel (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

The drawer in gnome-panel doesn't work well with Xinerama.
When I drag my panel to my left monitor and click the drawer, it comes up on my right monitor.

This only happens when the panel is horizontal (and thus the drawer is vertical) and on my left monitor. This is my Xinerama configuration:

Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Screen 1" 0 0
    Screen "Screen 0" LeftOf "Screen1"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    Option "Clone" "off"
    Option "Xinerama" "on"
EndSection

Related branches

Revision history for this message
Daniel Holbach (dholbach) wrote :

Thanks for your bug report. That issue is already known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=300883

Changed in gnome-panel:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
status: Unconfirmed → Confirmed
Changed in gnome-panel:
status: Unconfirmed → Confirmed
Revision history for this message
Daniel Holbach (dholbach) wrote :

Fixed Upstream.

Changed in gnome-panel:
status: Confirmed → Fix Committed
Changed in gnome-panel:
status: Confirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

gnome-panel (1:2.20.0-0ubuntu1) gutsy; urgency=low

  * New upstream version
    Panel
    - Show drawers on same monitor as the panels they're attached to
      (LP: #32285)
    - Use new icon name for logout
    Clock Applet
    - Fix crashers in timezone handling
    - Don't show the UI to have timezones in the clock since it's not ready
    Docs Translators
    Translators
  * debian/patches/12_autoreconf.patch:
    - updated

 -- Sebastien Bacher <email address hidden> Tue, 18 Sep 2007 11:16:26 +0200

Changed in gnome-panel:
status: Fix Committed → Fix Released
Changed in gnome-panel:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.