Ubuntu

Can't disable tooltips

Reported by Trouilliez vincent on 2006-02-10
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Expired
Low
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

In Gconf, I found this key :

/apps/panel/global/tooltips_enabled

the description says : "If true, tooltips are shown for objects in panels. "

I unchecked that option, but it fails to disable all the panel tooltips. It only disables the tooltips for the menu bar, all the applets on the panel still pop-up tooltips.

Daniel Holbach (dholbach) wrote :

Thanks for your report, that's a known upstream issue.

Changed in gnome-panel:
status: Unconfirmed → Confirmed
status: Unconfirmed → Confirmed
towsonu2003 (towsonu2003) wrote :

will this be fixed? these tooltips are annoying at times. or is there a workaround? thanks.

Sebastien Bacher (seb128) wrote :

You can read the upstream bug about that. There is no workaround for the moment and will not be fixed for dapper. Marked it as feature request

Changed in gnome-panel:
assignee: nobody → desktop-bugs
towsonu2003 (towsonu2003) wrote :

sorry, but this is not a feature request. this is a request to fix the feature. thanks.

Sebastien Bacher (seb128) wrote :

the feature is for the panel and works for the panel, your issue is with the applets placed on the panel, read the upstream bug about that, wishlist or minor make no difference on how the bug will be handled but playing against the maintainer on the settings is of no use

towsonu2003 (towsonu2003) wrote :

> wishlist or minor make no difference on how the bug will be handled

yep, I got that...

> playing against the maintainer on the settings is of no use

I'm not "playing against" anyone. If the maintainer can fix the bug, s/he will. If s/he can't, s/he won't. All I'm doing is to give feedback: "this is a bug, and should be labeled as so". I don't see the point of downplaying it just bc no one's gonna fix it.

> your issue is with the applets placed on the panel, read the upstream bug about that

I did. I don't think you want me to file a launchpad bug report on each and every applet we have in the repos.

Sebastien Bacher (seb128) wrote :

No, but you request for a feature not available yet, a feature request is a "wishlist" technicaly. No point to talk about it for hours anyway, that's a detail. Bugging every applet would be wrong, a framework need to discussed for that and the right place is with some upstream maintainers of the panel not to bug every part that could use that framework

Changed in gnome-panel:
status: Unconfirmed → Confirmed
Mike Sola (solar-552) wrote :

Tooltips are the most overrated feature/gimmick ever. I'm sitting here looking at what the tooltips say and what they are obscuring on my desktop, and this is ridiculous. The text inside tooltip boxes is obvious and useless 75% of the time. The firefox tab of this very webpage has a tooltip which is the exact same text as the tab - "Bug #31102 in GNOME Panel: "Can't disable Tooltips"". Gee thanks.

The tooltip box covers area immediately next to where the mouse is, which is always the most relevant part of the screen to what you are currently doing. I am almost always MOST INTERESTED in the window contents UNDERNEATH the tooltip. When editing source code inside an IDE, the tooltips hide the very lines of code you are trying to change. And you can't change the code without seeing what the current line of code is.

Sure, it's up to me to change all my settings. Maybe linux should just not clone Windows braindamage.

Michele (mikelito) wrote :

A workaround for those of you who are using CompizFusion, which I found googling around:
open the advanced compiz settings panel (you might have to
$ apt-get install compizconfig-settings-manager
)

go to General Options > Opacity Settings

click on Add, type Tooltip into the Opacity windows textbox, and set the opacity to zero

volià: the tooltips are still there, but at least they are invisible :-)

Changed in gnome-panel:
status: Confirmed → Triaged
Changed in gnome-panel:
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

upstream bug comment

"tooltips are now (gtk+ 2.14) enabled globally by the gtk-enable-tooltips
setting.

every gtk+ widget (and hence applets) will automatically have tooltips disabled
if that property is set to FALSE inside a gtkrc file. it might require a
XSettings key in case we want to be able to use GConf to toggle it - but that
is for another bug.

I'd close this bug as OBSOLETE."

closing the distribution bug too

Changed in gnome-panel:
status: Triaged → Invalid

Sebastien Bacher,

And where is gtkrc file?

Carthik Sharma (carthik) wrote :

@aoirthoir:

The gtkrc files go with the themes. You will find the themes in either ~/.themes/ or /usr/share/themes in the case of system-wide default themes.

gcb (descartavel1) wrote :

Mike, I agree.

Carthik,
edit ~/.gtkrc-2.0
and add the line

gtk-enable-tooltips = 0

Mr.Mizzen (mr-mizzen) wrote :

The worst offenders at the moment are the pop ups over the workspaces.

At the very least, with Compiz active, the pop up will say “Current Workspace: Desk 1”.
Every workspace has incessant reminders to “Click to start dragging xxx”. I have known that for a few years now.
This situation is magnified when using Compiz.
The attachment shows how the pop up displays the entire title of a web page from Firefox. This pop up covers almost ¼ of the whole desktop every time the mouse passes over the workspaces.
The second screen shot shows what happens when the mouse goes over the Firefox task bar when in the same workspace.

Admittedly, the issues is not as bad if not running Compiz because the pop up is somewhat truncated, but it is still an issue.

@aoirthoir:
The gtkrc files go with the themes. You will find the themes in either ~/.themes/ or /usr/share/themes in the case of system-wide default themes.
There is no ~/.themes/ on my system.
/usr/share/themes contains 118 folders. Controls and boarders and complete themes all have a folder, only icons get their own place /usr/share/icons

edit ~/.gtkrc-2.0
and add the line
gtk-enable-tooltips = 0

Rummaging through 118 folders to permanently change this setting is NOT a valid fix for this problem

Mr.Mizzen (mr-mizzen) wrote :
Changed in gnome-panel:
importance: Unknown → Low
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.