Ubuntu

"Update information" tries replacing non-existent Quit button in brand-new user account

Reported by Matthew Paul Thomas on 2008-10-24
8
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: fast-user-switch-applet

Ubuntu Intrepid, all updates installed

1. In Users and Groups, create a brand new user account.
2. Switch into this newly-created user account.
3. Wait about 70 seconds.
4. When the light bulb icon appears at the top right of the screen, click it.
5. In the window that appears, click the "Update" button.

What happens:
4. A window appears: "There is now a combined status menu for instant messaging status, switching user accounts, and exiting Ubuntu. This menu will replace the current Quit button. If you click on the 'Update' button below your Quit button will be replaced with the new status menu."
5. An error alert appears: "No logout button found" - "The logout button can not be found or it is not in the standard location. Please update the panel configuration manually."

What should happen:
3. The light bulb icon should not appear, since this account already has the new setup and does not have a Quit button.

Related branches

Matthew Paul Thomas (mpt) wrote :
Changed in fast-user-switch-applet:
assignee: nobody → pitti
Martin Pitt (pitti) wrote :

It seems the gnome-panel migration code does the wrong thing. Michael, can you please have a look?

Michael Vogt (mvo) on 2008-10-24
Changed in gnome-panel:
assignee: pitti → mvo
importance: Undecided → Medium
milestone: none → ubuntu-8.10
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.24.1-0ubuntu2

---------------
gnome-panel (1:2.24.1-0ubuntu2) intrepid; urgency=low

  * debian/fusa-applet.note.in:
    - only show the note if there is actually a logout button in
      the panel config (LP: #288696)

 -- Michael Vogt <email address hidden> Fri, 24 Oct 2008 20:39:46 +0200

Changed in gnome-panel:
status: In Progress → Fix Released
Simon Morvan (simon-icilalune) wrote :

I got the same exact behavior here with gnome-panel 1:2.26.0-0ubuntu3

newur (newur) wrote :

Same problem here with jaunty beta.

Reopening the bug due to the last two comments regarding this being not fixed.

Changed in gnome-panel:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

if you have an issue in jaunty open a new bug that one was intrepid specific and fixed now

Changed in gnome-panel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments