[Enhancement] Add a flexible spacer in the panel objects

Bug #275353 reported by Jean-Philippe Fleury on 2008-09-28
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Wishlist
One Hundred Papercuts
Undecided
Unassigned
gnome-panel (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnome-panel

It would be very great to add a flexible spacer in the panel objects (right click to panel -> Add to Panel). I mean by "flexible spacer" the possibility to add a spacer that takes all available space and moves icons to one side or the other of the panel. XFCE's panel has this useful option. Firefox's and Thunderbird's toolbars have it too.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, that's not something the ubuntu team has the ressources or interest to work on and that doesn't need to be a gnome-panel object but could be an applet rather

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Invalid
Changed in gnome-panel:
status: Invalid → Triaged
Changed in gnome-panel:
status: Unknown → New
Ilya Barygin (randomaction) wrote :

Nominating for papercuts because the duplicate was nominated.

Vish (vish) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

A feature request is not a Papercut.

A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Erich E. Hoover (ehoover) wrote :

After talking with a friend the other day, I would disagree that this "not a paper cut." One of the first things that I've noticed that new users do is setup their panels - and the number one problem I see them encounter is positioning the objects in the first place and the number two problem is that everything gets screwed up when the screen is rotated or resized (so this is a HUGE problem with tablet users).

Also, I would say that this issue would be relatively trivial to fix by slightly adjusting the panel mechanics. Since GTK already uses containers for scaling areas you can remove the ability to absolutely position objects by switching to containers and instead expose the "fill" and "expand" attributes. This way the majority of objects will automatically butt up against each other (the default and expected behavior that most users must currently work around using the "lock" mechanism) but for advanced users there would be the ability to fine-tune which objects expand and fill. So, with a flexible spacer on the top panel and the Window List applet on the bottom panel (both set to expand and fill by default) you would get a sane default where new users can easily add and remove elements on the panels without taking tons of time locking and unlocking the panel objects just to get everything to line up properly.

Changed in gnome-panel:
importance: Unknown → Wishlist
Derek Price (derek-ximbiot) wrote :

I have no idea how hard this fix is to implement, but as a long time Ubuntu fan, I can say that this has been annoying me a long time, and usually does happen during initial setup of a new machine during all the monitor resizes in the monitor configuration step. I also currently have Ubuntu setup inside a VMWare virtual machine which basically resizes the monitor to full screen mode every time I log in and the VMWare Tools application starts. This leaves the applets that should be on the right sitting in the middle of my panels with every login. Unlocking and moving them all every login is a serious pain.

Derek Price (derek-ximbiot) wrote :

A gnome panel developer just marked this as fixed in Gnome 3 in the gnome panel bug report (https://bugzilla.gnome.org/show_bug.cgi?id=557925).

Changed in gnome-panel (Ubuntu):
status: Triaged → Fix Committed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in gnome-panel:
status: New → Fix Released

I'm out of the office until 1st August.

On 21 Apr 2011, at 21:01, Bug Watch Updater
<email address hidden> wrote:

> ** Changed in: gnome-panel
>       Status: New => Fix Released
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/275353
>
> Title:
>  [Enhancement] Add a flexible spacer in the panel objects
>
> Status in Desktop panel for GNOME:
>  Fix Released
> Status in One Hundred Paper Cuts:
>  Invalid
> Status in “gnome-panel” package in Ubuntu:
>  Fix Committed
>
> Bug description:
>  Binary package hint: gnome-panel
>
>  It would be very great to add a flexible spacer in the panel objects
>  (right click to panel -> Add to Panel). I mean by "flexible spacer"
>  the possibility to add a spacer that takes all available space and
>  moves icons to one side or the other of the panel. XFCE's panel has
>  this useful option. Firefox's and Thunderbird's toolbars have it too.

Marcus Haslam (marcus-haslam) wrote :

I'm out of the office until 1st August.

On 21 Apr 2011, at 14:50, Derek Price <email address hidden> wrote:

> A gnome panel developer just marked this as fixed in Gnome 3 in the
> gnome panel bug report
> (https://bugzilla.gnome.org/show_bug.cgi?id=557925).
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/275353
>
> Title:
>  [Enhancement] Add a flexible spacer in the panel objects
>
> Status in Desktop panel for GNOME:
>  New
> Status in One Hundred Paper Cuts:
>  Invalid
> Status in “gnome-panel” package in Ubuntu:
>  Triaged
>
> Bug description:
>  Binary package hint: gnome-panel
>
>  It would be very great to add a flexible spacer in the panel objects
>  (right click to panel -> Add to Panel). I mean by "flexible spacer"
>  the possibility to add a spacer that takes all available space and
>  moves icons to one side or the other of the panel. XFCE's panel has
>  this useful option. Firefox's and Thunderbird's toolbars have it too.

Marcus Haslam (marcus-haslam) wrote :

I'm out of the office until 1st August.

On 21 Apr 2011, at 13:41, Derek Price <email address hidden> wrote:

> I have no idea how hard this fix is to implement, but as a long time
> Ubuntu fan, I can say that this has been annoying me a long time, and
> usually does happen during initial setup of a new machine during all
> the
> monitor resizes in the monitor configuration step.  I also currently
> have Ubuntu setup inside a VMWare virtual machine which basically
> resizes the monitor to full screen mode every time I log in and the
> VMWare Tools application starts.  This leaves the applets that
> should be
> on the right sitting in the middle of my panels with every login.
> Unlocking and moving them all every login is a serious pain.
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/275353
>
> Title:
>  [Enhancement] Add a flexible spacer in the panel objects
>
> Status in Desktop panel for GNOME:
>  New
> Status in One Hundred Paper Cuts:
>  Invalid
> Status in “gnome-panel” package in Ubuntu:
>  Triaged
>
> Bug description:
>  Binary package hint: gnome-panel
>
>  It would be very great to add a flexible spacer in the panel objects
>  (right click to panel -> Add to Panel). I mean by "flexible spacer"
>  the possibility to add a spacer that takes all available space and
>  moves icons to one side or the other of the panel. XFCE's panel has
>  this useful option. Firefox's and Thunderbird's toolbars have it too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.