restore remaining minimized windows instead of showing the desktop

Bug #236376 reported by glotz on 2008-05-31
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Unknown
Medium
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Often when I click the button it doesn't display the desktop but instead pulls up some more (minimized?) windows! I don't see any logic to this strange behaviour. It used to work just fine in Dapper. This bugged version is on Hardy.

Michael Nagel (nailor) wrote :

confirming. i noticed something strange about the button, too. i did not find any logic in the behavior, either.

Nick Ellery (nick.ellery) wrote :

This is definitely the case, but I don't think that it is a bug, and that it is intentional. I think this should be marked as wishlist.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you describe easy steps to trigger the bug?

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Incomplete
glotz (glotz) wrote :

I'm sorry, it's not clear to me how to duplicate it. :-/

glotz (glotz) wrote :

Aha! Looks like you need to have compiz enabled to make this happen. Open 2 windows. Hit the button and they'll get minimized. Then click one of them on the panel and that window will maximize (or restore) back. And now, when you hit the button, the minimized window comes crashing down on you. Can you dupe that?

Michael Nagel (nailor) wrote :

yes, i have compiz enabled.

the hide all windows button has 2 state. up/and down.

when it is up, klicking will minimize all windows.
when it is down, klicking it will restore all windows.

when its down, klicking a window will restore this window AND set the button to up state.
since lately the second thing is not the case, and after that strange things happen...

Sebastien Bacher (seb128) wrote :

not sure if that's a bug or a wanted upstream change, somebody should open a bug on bugzilla.gnome.org where the code is written

Pedro Villavicencio (pedro) wrote :

no response, closing the report.

Changed in gnome-panel:
status: Incomplete → Invalid
Michael Nagel (nailor) wrote :

just played around a bit and installed
compizconfig-settings-manager

there drop the "show desktop" plugin and use the "fade to desktop" plugin instead. things seem to work for me now... might be some kind of compiz related thing... can someone confirm?

Changed in gnome-panel:
status: Invalid → Incomplete
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs only to ask compiz questions

Changed in gnome-panel:
status: Incomplete → Invalid
Forest (fdenger-gmail) wrote :

I'm reopening this bug because it IMO is a regression. This is confirmed a bug in the show desktop button. I believe it to be a regression because the proposed fix for this bug: https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/99595 wanted to have the show desktop button to be a toggle to show desktop, and then restore windows if clicked again. However, if you show the desktop, and then go and manually open other windows, clicking the desktop icon again should (and intentionally should) show the desktop, not RESTORE the previously hidden windows from a 30 minute ago hiding of them. Enabling desktop effects (compiz) causes this bug to show up, whereas, if you don't enable compiz, the bug does not show up.

To reporduce: (compiz effects should be enabled to reproduce this, but its not required to have the special "show desktop" effect enabled, just standard default compiz)

step1) have some windows opened up
step2) click the "show desktop" button -> it will hide the windows and show the desktop to you
step3) open some more windows manually, for instance go to places -> home
step4) click the "show desktop" button again -> intentionally it should show the desktop, however it erroneously restores all the windows which were previoiusly minimized in step2.

This is a regression IMO to 8.04 and i believe to be directly related to the fix which was applied to correct this bug (99595, which was only asking to restore the windows back to original mode if the desktop was already showing)

if you feel that inappropriate then re-close it.

Forest (fdenger-gmail) wrote :

is this bug closed because it can't be confirmed, or because it is not a valid ubuntu bug? I'll leave it alone if so but I just am not sure the intentions here. Thanks.

Changed in gnome-panel:
status: Invalid → Confirmed
Forest (fdenger-gmail) wrote :

To clarify, the bug shows up when compiz is enabled (not the compiz "show desktop" option, but just compiz desktop effects in general) and the bug does not show up when compiz is disabled (desktop effects disabled)

Thanks.

Sebastien Bacher (seb128) wrote :

the bug has been closed because it should be sent on bugzilla.gnome.org by somebody having the issue

Changed in gnome-panel:
status: Confirmed → Incomplete
Changed in gnome-panel:
status: Incomplete → Invalid
Changed in gnome-panel:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

it has been sent upstream, marking it as triaged.

Changed in gnome-panel (Ubuntu):
status: Invalid → Triaged
summary: - Show Desktop Button 2.22.1.3 is driving me bonkers
+ restore remaining minimized windows instead of showing the desktop
Changed in compiz:
status: Unknown → Confirmed

Has this bug stalled? I note that it seems to be waiting on compiz-plugins #315, but the link to that (http://bugs.opencompositing.org/show_bug.cgi?id=315) is broken or down (confirmed by http://downforeveryoneorjustme.com/http://bugs.opencompositing.org/show_bug.cgi?id=315).

Still happens (for me on Gnome v2.30.2 on Ubuntu Lucid Lynx aka 10.04). Surprisingly irritating.

Changed in gnome-panel:
importance: Unknown → Medium
biffta (hopkins81) wrote :

I would like to add my support that this thing gets fixed once and for all. I'm glad it's not just me who is being driven bonkers by this bug, I've been trying to get a response about it on the compiz forums for ages:

http://forum.compiz.org/viewtopic.php?f=86&t=13406

cheers.

Changed in gnome-panel:
status: New → Unknown
Ashwin G (ashwin-8740) wrote :

really ...this is one of the most irritating bugs...#5 replicates the problem nicely

dekeyserkarel (dekeyserkarel) wrote :

A fix would really be appreciated!

Nicolas_Raoul (nicolas-raoul) wrote :

Still happening, on default Natty installed from scratch.

Nicolas_Raoul (nicolas-raoul) wrote :

In addition to being useless, bringing back old windows is painfully slow, because those are unused programs already on swap memory.

On Natty's Unity, after pressing SUPER+D twice, when finally the desktop becomes visible, it is partially hidden by the dash overlay that always decides to open at that time. So it requires the user to click somewhere else so that the dash disappear.
All in all, showing the desktop takes a good 6 seconds.

no longer affects: compiz
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.