gnome-panel doesn't hide all the way

Bug #218982 reported by jasonq on 2008-04-18
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Confirmed
Wishlist
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-panel

I've check auto-hide and it works except that there's about 5 pixels of the panel still visible. It's even enough to see the bottom of the mini-icons.

ProblemType: Bug
Architecture: i386
Date: Thu Apr 17 21:04:24 2008
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/gnome-panel
NonfreeKernelModules: nvidia
Package: gnome-panel 1:2.20.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: gnome-panel --sm-client-id default1
ProcCwd: /home/jquinn
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/usr/bin/tcsh
SourcePackage: gnome-panel
Uname: Linux aries 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

jasonq (jason-quinn) wrote :
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid
NoOp (glgxg) wrote :

Is there a reference to the other bug report?

NoOp (glgxg) wrote :

@jasonq: I find the problem irritating as well. FWIW I've found the upstream bug for this problem:

http://bugzilla.gnome.org/show_bug.cgi?id=127973

It does not appear that it will be fixed anytime soon.

A workaround that I use is to "Show hide buttons" and uncheck "Arrows on hide buttons" so that when hidden there is minimal real estate used, and then hide the panel by clicking on the small left or right "hide" square" to hide it, and click on the square (rectangle?) to unhide it.

Changed in gnome-panel:
status: Unknown → Confirmed
Tiede (marcarthur) wrote :

I am not clear if this was tried by the bug reporter. Maybe this can fix your issue.
open gconf-editor
(at+F2 : gconf-editor for example)
browse to apps->panel->toplevel, select your panel and set the autohide size to 3 or lesser, depending on what you want.
I use "0" and have no visual feedback of the location of the panel, but when i hover my cursor there, it pops up.
Hope this helps.

jasonq (jason-quinn) wrote :

Fantastic, Tiede! Your fix works. The size was set to 6 by default. Who would want that? I changed it to "1" because that's the way I liked it most.

jasonq wrote:
> Fantastic, Tiede! Your fix works. The size was set to 6 by default. Who
> would want that? I changed it to "1" because that's the way I liked it
> most.
>

Confirmed here as well. Thanks Tiede!

Now I wonder if the gnome-panel folks can reset to 0 or 1 as default
instead of 6.

Changed in gnome-panel:
status: Invalid → Triaged
soc (simon-ochsenreither) wrote :

This should probably be the default, I do that every time I setup a new system, because otherwise people will complain after a few days, that they can't "maximize their windows" or about the wasted sreen space etc. ...

Changed in gnome-panel:
importance: Unknown → Wishlist
NoOp (glgxg) wrote :

This appears to be fixed/resolved for me in Lucid 10.04. Tested on 32 & 64bit. If anyone else can please test & verify this bug report can be closed (for Lucid); I've not tested yet on 8.04 or 10.10.

soc (simon-ochsenreither) wrote :

@NoOp: I sent a patch some time ago to the gnome developers, adjusting the standard settings regarding autohide size, hide/unhide delay to sane values. This patch was included, so for most people the obvious symptoms are fixed.

But I would suggest leaving this bug open here as a reminder, until the real problem is fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.