Ubuntu

locations list can go over the screen border

Reported by stefanlew on 2008-02-02
194
This bug affects 15 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Confirmed
Medium
One Hundred Papercuts
Low
Unassigned
gnome-panel (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-applets

Preparation:
You need at least two cities added in the "Locations" section of the calendar applet. One should be your current time zone marked with a house icon.

Steps to reproduce:
Open the calendar pop-up by clicking on the date and wait some seconds for date and time to appear under the city names.

Now move your mouse over a city which isn't set as your current time. A "Set..." button appears and makes the pop-up float partly off-screen.

stefanlew (stefan-lew) wrote :

Im using the latest Ubuntu 8.04 Hardy.

Changed in gnome-applets:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

Confirmed, thanks for you report.

Changed in gnome-panel:
status: New → Triaged
Pedro Villavicencio (pedro) wrote :
Changed in gnome-panel:
status: Unknown → New
Daniel James (daniel-netbreeze) wrote :

I think this is related - sometimes If you open the popup and just leave the popup open for a minute or so it will resize by itself.

Anders Pamdal (anders-pamdal) wrote :

I too suffer from what is probably the same bug.

while I open the birthday and anniversary it does a jump to the right. (out-of-screen)

Martin Kossick (hacktick) wrote :

This is still an issue in Intrepid beta.

summary: - date/time applet gets too large
+ locations list can go over the screen border
Peter Cherriman (pjcherriman) wrote :

This is affecting jaunty also.

It occurs more often when one of the locations is on a different day of the week to your location, since it makes the time info for the location wider.

Kevin Cole (kjcole) wrote :

Still present in Karmic (Clock 2.28.0). Peter Cherriman's observation above is the same diagnosis I was about to make. Is it possible to determine where on the panel the applet is located, and then expand in the appropriate direction based on that? (i.e. if it's on the far right, move the left edge further left rather than the right edge further right?)

davidc (daave-daave) wrote :

This appears to be fixed in Lucid

В Втр, 18/05/2010 в 14:20 +0000, davidc пишет:
> This appears to be fixed in Lucid
No, I still experience this. It might have helped that the session
applet is on the right of the clock by default, so there's some space,
but it's still not enough.

Still present in Lucid. Try it with one time zone PST and one in Asia. On Tuesday, the "Wednesday" added after the date is enough to push the edge off the screen border. All that needs to be done is account for the 'set' button for the location with the longest string when the menu is first displayed. Should be a simple fix, but I lack the know-how of the applet internals and build system to fix it myself nor the time to figure it out. A minor annoyance at most, but it still should be fixed.

Vish (vish) wrote :

Could someone post a screenshot of the bug affecting the default configuration in Lucid [with the session menu on the right of the clock applet] ?

Changed in hundredpapercuts:
status: New → Incomplete
Alexey Kotlyarov (koterpillar) wrote :

Here you are.

Sebastien Bacher (seb128) wrote :

> Should be a simple fix, but I lack the know-how of the applet internals and build system to fix it myself nor the time to figure it out.

If somebody wants to send a patch the fix would be welcome, usually when such bugs are open for a while that's because the code changes are not as trivial as you could think

d selby (kbmaniac) wrote :

10.04, same problem 1 x location, Canberra Australia, glide mouse pointer from underneath the locations dropdown upwards, 'set' button appears and graphics glitch shows up, causes the issue every time. calender expands off the screen.

This bug affects me.

10.04, clock applet located in the lower-right corner of the screen. Added Seoul to get the text "5:44 AM (Tuesday) KST + 15".

No hovering for the "Set" button is required -- simply adding the city pushes the applet partially off-screen. Hovering to get the "Set" button then pushes it farther off-screen. Not a big deal, we're talking about only 17px or so.

Kevin Godby (godbyk) on 2010-08-08
Changed in hundredpapercuts:
status: Incomplete → New
Changed in gnome-panel:
status: New → Invalid
Changed in gnome-panel (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Kevin Godby (godbyk) wrote :

It appears that there's a patch assigned to GNOME bug #553929: https://bugzilla.gnome.org/show_bug.cgi?id=553929

I haven't tested this patch, so I don't know if it fixes the bug.

Changed in gnome-panel:
importance: Unknown → Medium
status: Invalid → Confirmed
Sense Egbert Hofstede (sense) wrote :

Accepting this as a paper cut since this is an issue that affects the default installation and seems to be trivial to fix.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
Vish (vish) on 2011-02-08
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Chris Wilson (notgary) wrote :

Closing report since Gnome Panel is not longer shipped with Ubuntu.

Changed in hundredpapercuts:
status: Triaged → Invalid
assignee: Papercuts Ninja (papercuts-ninja) → nobody
Chris Wilson (notgary) wrote :

Sorry, meant to say "Closing papercut report".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.