gnome-panel indirectly installs evolution

Bug #1502570 reported by Alkis Georgopoulos on 2015-10-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Undecided
Unassigned

Bug Description

http://packages.ubuntu.com/wily/gnome-panel
gnome-panel Recommends: evolution-common
...which in turn Recommends: evolution

Is this on purpose?
Could you please lower the "Recommends" to "Suggests"?
Gnome-flashback isn't a flavor with a live CD etc, so it makes more sense to keep the vanilla Ubuntu defaults, i.e. thunderbird as the mailer...

If evolution-common is necessary for gnome-flashback, but evolution isn't, please mention it so that we ask them instead to lower their Recommends to Suggests.

Dmitry Shachnev (mitya57) wrote :

Fixed in Svn revision 46381, will upload to Ubuntu as soon as the archive for Wily+1 opens.

Changed in gnome-panel (Ubuntu):
status: New → Fix Committed
Alkis Georgopoulos (alkisg) wrote :

Would it be at all possible to have this in Wily?
We're thinking of installing 15.10 in some schools here instead of 14.04, and it would make things a bit easier for us.

Thank you very much in any case.

Dmitry Shachnev (mitya57) wrote :

I can fix it in Wily, but why can't you just use apt's --no-install-recommends option?

Alkis Georgopoulos (alkisg) wrote :

Because then we would lose all the other recommended packages:
http://packages.ubuntu.com/wily/gnome-panel

alacarte easy GNOME menu editing tool
evolution-data-server evolution database backend server
gnome-applets Various applets for the GNOME panel - binary files
gnome-session-flashback (>= 3.14.0) GNOME Session Manager - GNOME Flashback session
gvfs userspace virtual filesystem - GIO module
indicator-applet-complete Clone of the GNOME panel indicator applet
unity-control-center utilities to configure the GNOME desktop

Listing those one-by-one in the `apt-get install` line of our installer script is possible but it makes the code too much ubuntu-version specific.

And of course other users installing gnome-panel (notably LTSP users) running the `apt-get install` manually wouldn't be aware of this bug in order to read it and run it with --no-install-recommends.

Dmitry Shachnev (mitya57) wrote :

Uploaded to wily, it is waiting in https://launchpad.net/ubuntu/wily/+queue?queue_state=1.

Alkis Georgopoulos (alkisg) wrote :

Thank you Dmitry. :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:3.16.1-3ubuntu3

---------------
gnome-panel (1:3.16.1-3ubuntu3) wily; urgency=medium

  * Move evolution-common from Recommends to Suggests, to avoid pulling in
    evolution by default (LP: #1502570).

 -- Dmitry Shachnev <email address hidden> Fri, 09 Oct 2015 17:00:39 +0300

Changed in gnome-panel (Ubuntu):
status: Fix Committed → Fix Released
Erick Brunzell (lbsolost) wrote :

This was actually a duplicate of bug #1381232.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers