Utopic version of gnome-panel depends on evolution-common

Bug #1381232 reported by Erick Brunzell on 2014-10-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Medium
Unassigned

Bug Description

Not sure when or why this changed but installing gnome-session-flashback in Ubuntu Utopic now wants to install evolution:

lance@lance-desktop:~$ sudo apt-get install gnome-panel
[sudo] password for lance:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  alacarte evolution evolution-common evolution-plugins gir1.2-gconf-2.0
  gir1.2-panelapplet-4.0 gnome-applets gnome-applets-data gnome-media
  gnome-panel-data gnome-session-flashback gstreamer0.10-gconf
  indicator-applet-complete libcpufreq0 libencode-locale-perl liberror-perl
  libevolution libfile-listing-perl libfont-afm-perl
  libgnome-media-profiles-3.0-0 libgtkhtml-4.0-0 libgtkhtml-4.0-common
  libgtkhtml-editor-4.0-0 libgtkspell3-3-0 libhtml-form-perl
  libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl
  libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl
  libhttp-message-perl libhttp-negotiate-perl libio-html-perl
  liblwp-mediatypes-perl liblwp-protocol-https-perl libmail-spf-perl
  libnet-http-perl libnetaddr-ip-perl libpanel-applet-4-0 libpst4
  libsys-hostname-long-perl libwww-perl libwww-robotrules-perl libytnef0
  metacity notification-daemon re2c sa-compile spamassassin spamc
Suggested packages:
  evolution-ews evolution-plugins-experimental tomboy desktop-base
  libdata-dump-perl libcrypt-ssleay-perl libauthen-ntlm-perl
  gnome-control-center razor libdbi-perl pyzor libmail-dkim-perl
The following NEW packages will be installed:
  alacarte evolution evolution-common evolution-plugins gir1.2-gconf-2.0
  gir1.2-panelapplet-4.0 gnome-applets gnome-applets-data gnome-media
  gnome-panel gnome-panel-data gnome-session-flashback gstreamer0.10-gconf
  indicator-applet-complete libcpufreq0 libencode-locale-perl liberror-perl
  libevolution libfile-listing-perl libfont-afm-perl
  libgnome-media-profiles-3.0-0 libgtkhtml-4.0-0 libgtkhtml-4.0-common
  libgtkhtml-editor-4.0-0 libgtkspell3-3-0 libhtml-form-perl
  libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl
  libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl
  libhttp-message-perl libhttp-negotiate-perl libio-html-perl
  liblwp-mediatypes-perl liblwp-protocol-https-perl libmail-spf-perl
  libnet-http-perl libnetaddr-ip-perl libpanel-applet-4-0 libpst4
  libsys-hostname-long-perl libwww-perl libwww-robotrules-perl libytnef0
  metacity notification-daemon re2c sa-compile spamassassin spamc
0 upgraded, 53 newly installed, 0 to remove and 3 not upgraded.
Need to get 15.3 MB of archives.
After this operation, 79.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

Even without recommends evolution wanted to be installed:

lance@lance-desktop:~$ sudo apt-get install gnome-panel --no-install-recommends -s
[sudo] password for lance:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  evolution-common gnome-panel-data libpanel-applet-4-0
Recommended packages:
  evolution alacarte gnome-applets gnome-session-flashback
  indicator-applet-complete
The following NEW packages will be installed:
  evolution-common gnome-panel gnome-panel-data libpanel-applet-4-0
0 upgraded, 4 newly installed, 0 to remove and 10 not upgraded.
Inst evolution-common (3.12.7-0ubuntu1 Ubuntu:14.10/utopic [all])
Inst gnome-panel-data (1:3.8.1-2ubuntu4 Ubuntu:14.10/utopic [all])
Inst libpanel-applet-4-0 (1:3.8.1-2ubuntu4 Ubuntu:14.10/utopic [i386])
Inst gnome-panel (1:3.8.1-2ubuntu4 Ubuntu:14.10/utopic [i386])
Conf evolution-common (3.12.7-0ubuntu1 Ubuntu:14.10/utopic [all])
Conf gnome-panel-data (1:3.8.1-2ubuntu4 Ubuntu:14.10/utopic [all])
Conf libpanel-applet-4-0 (1:3.8.1-2ubuntu4 Ubuntu:14.10/utopic [i386])
Conf gnome-panel (1:3.8.1-2ubuntu4 Ubuntu:14.10/utopic [i386])

But I see evolution-common is now listed as a depend:

lance@lance-desktop:~$ apt-cache show gnome-panel
Package: gnome-panel
Priority: optional
Section: universe/gnome
Installed-Size: 1494
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Debian GNOME Maintainers <email address hidden>
Architecture: i386
Version: 1:3.8.1-2ubuntu4
Replaces: gnome-panel-data (<< 2.91)
Depends: evolution-common (>= 3.4.3), gnome-icon-theme-symbolic (>= 3.0.0), gnome-menus (>= 3.1.4), gnome-panel-data (= 1:3.8.1-2ubuntu4), gconf-service, libatk1.0-0 (>= 1.12.4), libc6 (>= 2.7), libcairo2 (>= 1.10.0), libdconf1 (>= 0.14.0), libecal-1.2-16 (>= 3.5.91), libedataserver-1.2-18 (>= 3.5.91), libgconf-2-4 (>= 3.2.5), libgdk-pixbuf2.0-0 (>= 2.25.2), libglib2.0-0 (>= 2.41.1), libgnome-desktop-3-10 (>= 3.2.0), libgnome-menu-3-0 (>= 3.2.0.1), libgtk-3-0 (>= 3.3.16), libgweather-3-6 (>= 3.7.91), libical1 (>= 1.0), libice6 (>= 1:1.0.0), libpanel-applet-4-0 (>= 3.4.1), libpango-1.0-0 (>= 1.18.0), libpolkit-gobject-1-0 (>= 0.99), librsvg2-2 (>= 2.32.0), libsm6, libtelepathy-glib0 (>= 0.14.0), libwnck-3-0 (>= 3.4.6), libx11-6, libxrandr2 (>= 2:1.2.99.3)
Recommends: alacarte, evolution-data-server, gnome-applets, gnome-icon-theme (>= 2.24), gnome-session-flashback, gvfs, indicator-applet-complete, unity-control-center
Suggests: gnome-terminal | x-terminal-emulator, gnome-user-guide, nautilus, yelp
Breaks: gnome-applets (<< 2.91), gnome-control-center (<< 1:2.91), gnome-settings-daemon (<< 2.91), libpanel-applet2-0, netspeed (<< 0.16-2)
Filename: pool/universe/g/gnome-panel/gnome-panel_3.8.1-2ubuntu4_i386.deb
Size: 384770
MD5sum: 227362a4b3b8ef4656d98de628fe8e01
SHA1: 259c67b759b6e2615bcf599cd9316d60920aeb14
SHA256: 1876760a32c93fe9a327d404f13c94dbbd2e08b72bbf3d824b3ff1d0f62fb1f8
Description-en: launcher and docking facility for GNOME
 The GNOME Panel is an essential part of the GNOME Desktop, providing
 toolbar-like “panels” which can be attached to the sides of your desktop.
 They are used to launch applications and embed a number of other
 functions, such as quick launch icons, the clock, the notification area,
 volume controls and the battery charge indicator, and utilities ranging
 from weather forecast to system monitoring.
Description-md5: 02085226815ba9e6a5733ab8ea00c173
Homepage: https://wiki.gnome.org/action/show/Projects/GnomeFlashback
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m
Task: edubuntu-desktop-gnome

That can't be right can it?

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: gnome-panel (not installed)
ProcVersionSignature: Ubuntu 3.16.0-22.29-generic 3.16.4
Uname: Linux 3.16.0-22-generic i686
ApportVersion: 2.14.7-0ubuntu6
Architecture: i386
CurrentDesktop: Unity
Date: Tue Oct 14 16:24:53 2014
InstallationDate: Installed on 2014-10-14 (0 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha i386 (20141014)
SourcePackage: gnome-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

Found the relevant bit in the changelog:

gnome-panel (3.8.1-2) unstable; urgency=medium

  [ Dmitry Shachnev ]
  * Depend on evolution-common, the clock applet crashes when it
    cannot find the org.gnome.evolution.calendar gsettings schema.
  * Drop 11_compat_options.patch. We no longer need to restore saved
    sessions from 2011.
  * Drop 14_revert_timedate_change.patch. The old DateTimeMechanism
    interface no longer exists in gnome-settings-daemon ≥ 3.3.5.
  * Bump libwnck-3-dev build-dependency to 3.4.6. This allows us to
    drop one hunk from 03_tasklist_orientation.patch.
  * Add patch headers to 01_gnome-wm.patch.

  [ Alberts Muktupāvels ]
  * Fix crash when in-process applet is removed from panel and then
    added back to panel. (LP: #1076830)

 -- Dmitry Shachnev <email address hidden> Wed, 03 Sep 2014 19:42:41 +0400

But that makes things kind of sloppy for Ubuntu users that prefer using the default Thunderbird mail. Doesn't Edubuntu still use Thunderbird? I'll have to check.

Erick Brunzell (lbsolost) wrote :

Just checked and according to the manifest Edubuntu also uses Thunderbird by default.

Erick Brunzell (lbsolost) wrote :

A closer look at the Edubuntu manifest shows that both evolution and thunderbird are installed by default in Utopic. In comparison the Trusty daily builds show only the following evolution packages installed:

evolution-data-server 3.10.4-0ubuntu1.3
evolution-data-server-common 3.10.4-0ubuntu1.3
evolution-data-server-online-accounts 3.10.4-0ubuntu1.3

tags: added: edubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

From the changelog:

gnome-panel (3.8.1-2) unstable; urgency=medium

* Depend on evolution-common, the clock applet crashes when it cannot find the org.gnome.evolution.calendar gsettings schema.

So I think it is a valid dependency.

Changed in gnome-panel (Ubuntu):
status: Confirmed → Opinion
status: Opinion → Confirmed
Dmitry Shachnev (mitya57) wrote :

Okay, as Ubuntu does not use clock applet by default, I can move that to Recommends or Suggests. Will Recommends be OK for you?

Don't do that!

Then we will get new bugs - clock applet crashing. As this applet is installed by default and it requires that schema then gnome-panel should depend on evolution-common event it is not used by default.

If these extra packages are real problem then I would suggest to move clock applet to separate debian pacakge - gnome-panel-clock and make it depend on evolution-common. Then add gnome-panel-clock as Recommends for gnome-panel so it is installed by default, but will allow to be removed if someone will want that. (If you are going to move clock to separate package then you do it with other applets to gnome-panel-clock, gnome-panel-fish, gnome-panel-wnck, gnome-panel-notification-area)

If applet/applets is not going to be moved to separate debian package then I would say this bug should be closed as invalid.

Erick Brunzell (lbsolost) wrote :

What changed between Trusty and Utopic to cause the clock to crash? I have 'gnome-panel' running in multiple Precise and Trusty machines using 'indicator-applet' and gnome-panel-clock rather than using 'indicator-applet-complete' and I've never had the clock applet crash in Trusty or Precise.

If it must stay this way it's not a huge deal because the work around(s) are fairly simple. I say multiple because the first assumes the user already installed 'gnome-panel' including all of 'evolution*' in which case the user can just purge all the unwanted 'evolution*' packages except 'evolution-common'. The second is simply to install 'evolution-common' using the "--no-install-recommends" option before installing 'gnome-panel'.

I originally suspected that Edubuntu was going to release a Utopic version so they'd have to presumably rebuild in such a manner as to not ship both thunderbird and evolution but I now understand that Edubuntu may be releasing only LTS builds going forward so they'd have time to sort that out before 16.04 lands in the distant future.

If you plan on not fixing this I'd prefer you mark it Won't fix rather than Invalid. Like I said I've never had the clock crash w/o evolution installed, is there a bug report regarding such a crash?

Changed in gnome-panel (Ubuntu):
importance: Undecided → Medium

https://git.gnome.org/browse/gnome-panel/commit/?id=cddd69b1d3d4835f65c0c726853b0c695d17b13b

Patch will allow to move evolution-common to Recommends or Suggests. Clock will not crash if that schema is not found.

Dmitry Shachnev (mitya57) wrote :

Thanks. We are in the final freeze now, so this commit won't be in 15.04, but I will downgrade evolution-common dependency once we get a newer Gtk+/gnome-panel.

Erick Brunzell (lbsolost) wrote :

Still effects Wily so I updated the title and tags.

tags: added: vivid wily
removed: utopic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments