Wine applications appear in "Other" on gnome-flashback

Bug #1304645 reported by KyL416 on 2014-04-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Undecided
Alberts Muktupāvels

Bug Description

On Trusty, after the change to use gnome-flashback-applications.menu for the gnome-flashback session all Wine applications appear in the "Other" menu, which leads to a confusing list of applications if the installed programs have common shortcut names in their Start Menu folder like Uninstall, Help, License and Readme.

I did a custom edit of the gnome-flashback-applications.menu to include the Menus defined in the wine.menu file in the applications-merged folder which makes the default wine applications appear in the Wine menu, but the user installed applications that are found in the ~/.local/share/applications/wine folder still show up in the Other menu.

Currently installed Package Versions:
gnome-menus 3.10.1-0ubuntu2
gnome-panel 1:3.8.0-1ubuntu10

Related branches

Dmitry Shachnev (mitya57) wrote :

Alberts, this was caused by your change, do you have any idea about how to fix this?

It would be nice if bug reported could provide screenshot with how menu
should look.

I am going to install wine now.

On Sat, Apr 12, 2014 at 12:38 PM, Dmitry Shachnev <email address hidden> wrote:

> Alberts, this was caused by your change, do you have any idea about how
> to fix this?
>
> --
> You received this bug notification because you are subscribed to gnome-
> panel in Ubuntu.
> https://bugs.launchpad.net/bugs/1304645
>
> Title:
> Wine applications appear in "Other" on gnome-flashback
>
> Status in “gnome-menus” package in Ubuntu:
> New
> Status in “gnome-panel” package in Ubuntu:
> New
>
> Bug description:
> On Trusty, after the change to use gnome-flashback-applications.menu
> for the gnome-flashback session all Wine applications appear in the
> "Other" menu, which leads to a confusing list of applications if the
> installed programs have common shortcut names in their Start Menu
> folder like Uninstall, Help, License and Readme.
>
> I did a custom edit of the gnome-flashback-applications.menu to
> include the Menus defined in the wine.menu file in the applications-
> merged folder which makes the default wine applications appear in the
> Wine menu, but the user installed applications that are found in the
> ~/.local/share/applications/wine folder still show up in the Other
> menu.
>
>
> Currently installed Package Versions:
> gnome-menus 3.10.1-0ubuntu2
> gnome-panel 1:3.8.0-1ubuntu10
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-menus/+bug/1304645/+subscriptions
>

--
Alberts Muktupāvels

Changed in gnome-menus (Ubuntu):
status: New → Invalid
Changed in gnome-panel (Ubuntu):
assignee: nobody → Alberts Muktupāvels (albertsmuktupavels)
status: New → In Progress
no longer affects: gnome-menus (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:3.8.0-1ubuntu11

---------------
gnome-panel (1:3.8.0-1ubuntu11) trusty; urgency=medium

  * Set XDG_MENU_PREFIX to "gnome-flashback-" in the desktop file
    (lp: #1305348, #1304645).
 -- Alberts Muktupavels <email address hidden> Sun, 13 Apr 2014 12:27:07 +0300

Changed in gnome-panel (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers