Menus in gnome-session-flashback are bloated in Trusty

Bug #1267787 reported by Erick Brunzell on 2014-01-10
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Low
gnome-panel (Ubuntu)
Low
Unassigned

Bug Description

Beginning with Saucy I assume that gnome-session-flashback tried to follow the new GNOME Classic Applications Menu extension but it really only resulted in bloat within the flashback menu. I fail to see any benefit to this change.

To explain in greater detail, the sub-menu "Other" was added beginning with Quantal to display shopping lenses and later to also display web-apps which is arguably fine. I personally have no problem with that.

But in Saucy it appears an effort was made to copy the appearance of the GNOME Classic "Applications Menu" extension. In so doing the following sub-menus were added to 'gnome-panel':

(1) System Settings tree view added, but certainly not needed since System Settings also appears in System Tools as well as under the username.

(2) Sundry added, but sparsely populated. Orca Screen Reader moved to Sundry from Universal Access, but Onboard is still in Universal Access (being legally blind myself I refer to such changes as rearranging the furniture while I'm not home). Main Menu was also moved from System Tools > Preferences to Sundry which makes it a bit more difficult to eliminate Sundry if one so wishes.

(3) Utilities added, but also not really needed as all it accomplishes is relocating a large number of apps from Accessories and System Tools to a new location. Again just rearranging furniture.

In summary I'd add that 'gnome-session-flashback' need not mimic the new GNOME Classic session nor vice versa.

Two potential fixes, one upstream and the other at the Ubuntu level, have already been proposed here:

https://mail.gnome.org/archives/gnome-flashback-list/2014-January/msg00011.html

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnome-session-flashback 1:3.8.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-1.16-generic 3.13.0-rc7
Uname: Linux 3.13.0-1-generic i686
ApportVersion: 2.12.7-0ubuntu6
Architecture: i386
CurrentDesktop: GNOME
Date: Fri Jan 10 04:29:21 2014
GsettingsChanges:

InstallationDate: Installed on 2013-10-29 (72 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1)
PackageArchitecture: all
SourcePackage: gnome-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Erick Brunzell (lbsolost) wrote :
Revision history for this message
Erick Brunzell (lbsolost) wrote :

Wow, I couldn't have worded that much worse :^(

At the end instead of saying, "it really resulted in a bloated within the flashback menu", I should have said, "it really resulted in a bloated menu within the flashback session" :^)

tags: added: edubuntu
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Revision history for this message
Adolfo Jayme (fitojb) wrote :

I don't understand what you mean by "bloated"? In any case, this should be reported upstream as indicated in https://wiki.ubuntu.com/Bugs/Upstream/GNOME.

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Revision history for this message
Erick Brunzell (lbsolost) wrote :

I'll take care of filing this upstream ASAP. I first want to take the time to print out the most egregious of the changes.

description: updated
description: updated
description: updated
Revision history for this message
Erick Brunzell (lbsolost) wrote :

Now reported upstream:

https://bugzilla.gnome.org/show_bug.cgi?id=722056

Hope I did OK ;^)

Revision history for this message
Adolfo Jayme (fitojb) wrote :

Thank you for elaborating on the issue AND for reporting upstream :-)

Changed in gnome-panel (Ubuntu):
status: Incomplete → Triaged
Changed in gnome-panel:
importance: Unknown → Low
status: Unknown → New
Revision history for this message
Tim Lunn (darkxst) wrote :

Utilities and Sundry come from gnome-shell. gnome-shell uses gnome-menu, which is shared with gnome-panel. The reason they are sparsely populated is because many of the applications in these two categories are not installed by default.

Reverting the gnome-applications.menu is not a solution since it will break the current gnome-shell behaviour (of having utilities and Sundry folders).

gnome-shell 3.12 no longer uses gnome-menus, but presumably gnome-classic would.

Revision history for this message
Alberts Muktupāvels (muktupavels) wrote :

Why revert? Take last working gnome-applications.menu, rename it to gnome-applications-flashback.menu, add it to gnome-panel package, patch gnome-panel to use this file.

Revision history for this message
Tim Lunn (darkxst) wrote :

Well sure that would almost work, except you are going to have to patch gnome-menus rather than gnome-panel.

I don't really have time to work on gnome-flashback stuff, but would be happy to review/sponsor patches.

Revision history for this message
Alberts Muktupāvels (muktupavels) wrote :

Ok, can you look at proposed merge requests?

Martin Pitt (pitti) on 2014-03-17
Changed in gnome-panel (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:3.8.0-1ubuntu10

---------------
gnome-panel (1:3.8.0-1ubuntu10) trusty; urgency=medium

  * Update 01_menus_rename.patch to use separate menus file for
    gnome-flashback session (lp: #1267787).
 -- Alberts Muktupavels <email address hidden> Mon, 17 Mar 2014 09:00:22 +0200

Changed in gnome-panel (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Cecil Carpenter (cscj01) wrote :

This bug seems to be back in gnome-panel 1:3.8.0-1ubuntu12.1. Everything is the same with Ubuntu 14.04.1 in terms of ability to add, move, or effect chane using Main Menu. I n addition, the .desktop files in `/.local/share/applications are not being used.

Revision history for this message
Erick Brunzell (lbsolost) wrote :

I'm replying here only because Alberts may be able to give some guidance. Obviously new bug reports need to be filed along with the appropriate info/logs.

I've personally seen three different complaints regarding flashback/gnome-panel problems after release upgrades to Trusty on the forums. I can only find two of those now:

http://ubuntuforums.org/showthread.php?t=2220264&page=4&p=13087936#post13087936

http://ubuntuforums.org/showthread.php?t=2239208

They all had in common that gnome-panel no longer automatically launched after boot following the upgrade, I think that should be the primary focus in trying to narrow this down. I realize that the ability to edit the menus is also effected but we have to start somewhere.

Cecil's comment above is in relation to the latter of those two forum links.

I tried a Precise -> Trusty upgrade earlier today and was unable to reproduce the problem so I really don't know what else to do.

@ Cecil,

Possibly file a new bug report from the effected system using "ubuntu-bug gnome-panel" titled something like "gnome-panel fails to launch after Precise -> Trusty upgrade", and also attach the logs in /var/log/dist-upgrade.

Revision history for this message
Cecil Carpenter (cscj01) wrote :

Okay, I'll file a bug report. How do I get to a screen in Launchpad that says "File a bug report"? Also, I am not sure how to use ubuntu-bug-gnome-panel.

Revision history for this message
Cecil Carpenter (cscj01) wrote :

Nevermind the last comment. I found out about Alt-F2.

Changed in gnome-panel:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.