new glib (2.39.1) causes some indicators & nautilus to not load promptly

Bug #1256961 reported by Doug McMahon on 2013-12-02
106
This bug affects 16 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
High
Unassigned
gnome-panel (Ubuntu)
High
Unassigned

Bug Description

Test case:
updated 14.04 install with glib (2.39.1) & default installed indicator-applet-complete
Log into either flashback session
indicators session, datetime & sound will not be present
additionally nautilus will have not been started (handling the Desktop), can be seen by absence of r. click on Desktop

Wait 1-2 min, then the indicators will load & nautilus will have started
(nautilus can be started prior to from places

With previous glib (2.38+) none of this occurs

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnome-session-flashback (not installed)
ProcVersionSignature: Ubuntu 3.12.0-4.12-generic 3.12.1
Uname: Linux 3.12.0-4-generic x86_64
ApportVersion: 2.12.7-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Dec 2 10:29:31 2013
SourcePackage: gnome-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) wrote :

Thank you, Doug! I use i686 Trusty, so I removed amd64 tag.

tags: removed: amd64
Cavsfan (cavsfan) wrote :

I just logged out and back in then timed it to see when the panel date/time etc. appeared and it took 1 minute 30 seconds for it to come up all the way. Once I clicked on Cairo Dock from the menu on the top panel in flashback as it is immediately available. Then when it did finish starting up I had 2 instances of Cairo Dock running.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1256961

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glib2.0 (Ubuntu):
status: New → Confirmed
Eugene San (eugenesan) on 2013-12-19
affects: glib (Ubuntu) → glib2.0 (Ubuntu)
Changed in glib2.0 (Ubuntu):
status: New → Confirmed
Alkis Georgopoulos (alkisg) wrote :

I think this works around the problem:

sudo -i
echo '#!/bin/sh
/usr/bin/gnome-panel &' > /usr/local/bin/gnome-panel
chmod +x /usr/local/bin/gnome-panel

Logout or reboot, the panel should load quickly now.

In other words, it seems like something is waiting for gnome-panel to finish loading, and if it's put in the background, then everything goes fast again and the panel itself loads quickly...

Erick Brunzell (lbsolost) wrote :

Thanks Alkis, that does work :^)

Another workaround is to change X-GNOME-Autostart-Phase from Panel to Applications:
1) sudo gedit /usr/share/applications/gnome-panel.desktop
2) Locate line - X-GNOME-Autostart-Phase=Panel
3) Comment it out by adding # in front of that line or change Panel to Applications

Dmitry Shachnev (mitya57) wrote :

Alberts: thanks for the workaround, do you think it makes sense to apply it directly to the package? Does it have any side-effects?

Yes, it makes sense. Of course this is not proper fix, but at least session starts without delay.

I think there can be side-effects...
1) If nautilus is autostarted in Desktop phase (/usr/share/applications/nautilus-classic.desktop). With workaround gnome-panel will start after nautilus not before. This means that nautilus will think that all screen is available for desktop icons. When panel will start nautilus will redraw desktop icons in new place because now nautilus will know that not all screen is available. I hope you understand what i tried to tell...

My pc is fast enough, i don't see this redraw (icon reposition), but it might be because nautilus-classic is not used in my session.

2) For example, if skype is autostarted in not minimised state could result in case when window is opened in top/left corner and panel is drawn over window. But I think that window manager should reposition window when panel is started.

You should check if this is or is not problem.

I am using metacity gtk3 version and heavily modified gnome-panel version so I think my tests may not be true for standard installation.

On Sat, Jan 18, 2014 at 01:17:47PM -0000, Alberts Muktupāvels wrote:
> Yes, it makes sense. Of course this is not proper fix, but at least
> session starts without delay.

Please, no. It'd be a workaround which might not even completely fix the
problem.

To fix the bug we need to find out why gnome-session isn't moving
through the phases. In my investigations so far I've found out that
neither upstart (turned it off; still happens), the indicators (removed
as much of them as I could find, exported INDICATOR_ALLOW_NO_WATCHERS;
still happens) are to blame, gnome panel or gnome-session (reverted to
the 13.10 version; still happens). Something holds up gnome-session
until it hits a timeout, at which point the session continues to load.

Run gnome-session as gnome-session --debug and look at the log and
you'll see that.

I'd appreciate it if someone else could spend a bit of time on this too.

Cheers,

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Norbert (nrbrtx) wrote :

Installed all updates on Ubuntu 14.04, bug exists.

Norbert (nrbrtx) wrote :

May dbus-monitor can help to trace/debug the issue?

Changed in gnome-panel (Ubuntu):
importance: Undecided → High
Changed in glib2.0 (Ubuntu):
importance: Undecided → High
tags: added: edubuntu

Maybe I found better fix. :) Removing "StartupNotify=true" line from gnome-panel.desktop file fix this bug.

Maybe someone knows why this line was added to gnome-panel.desktop file and why it is needed? Tried to look to other desktop files that uses autostart phases - gnome-shell, mutter, metacity. Did not found such line in any of them.

Doug McMahon (mc3man) wrote :

It's basically supposed to give cursor indication (spin) while app is loading & has been there forever.
(possibly that line was almost always added to many .desktops as a matter of course, needed or not..

Seemed to have created issues in the past, ie. Bug 930768 (though nautilus.desktop still has the line & this may not still be an issue

Dmitry Shachnev (mitya57) wrote :

Thanks guys, if you tested that and didn't notice any regressions, I will include that workaround in the next upload.

Yes, I tested it - installed daily image in virtualbox, installed flashback session, removed that line and logged in flashback session. Seems to work in both sessions - with metacity and compiz.

Only network indicator /applet again is missing. There was patch - http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/trusty/network-manager-applet/trusty/view/head:/debian/patches/git_dont_autostart_under_GNOME.patch, bet it is not enabled.

Dmitry Shachnev (mitya57) wrote :

As it is your patch, can you maybe commit it upstream as well (as the .desktop file is not Ubuntu specific)?

I will take care of nm-applet, actually it was my patch IIRC, don't know why it was disabled.

Dmitry Shachnev (mitya57) wrote :

The nm-applet issue is tracked in bug 1267100. The reporter had a fix already, asked him to submit it to the sponsoring queue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:3.8.0-1ubuntu7

---------------
gnome-panel (1:3.8.0-1ubuntu7) trusty; urgency=medium

  * Update 51_show_in_unity.patch to also remove StartupNotify header
    to work around LP: #1256961. Thanks (again) Alberts Muktupāvels.
 -- Dmitry Shachnev <email address hidden> Sat, 22 Feb 2014 11:33:07 +0400

Changed in gnome-panel (Ubuntu):
status: Confirmed → Fix Released
Norbert (nrbrtx) wrote :

Thank you for the fix!
Tested 3.8.0-1ubuntu7 from proposed on Unity and GNOME FlashBack sessions (Compiz and Metacity) - bug is fixed.

Changed in glib2.0 (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments