Duplicated entries in Places Menu

Bug #122602 reported by Joaquín Fernández on 2007-06-27
182
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Medium
Ubuntu Desktop Bugs
xdg-user-dirs-gtk (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gnome-panel

Desktop and the new folder, Documents, appear duplicated in the Places Menu; in english in my native language.

Sorry, * in english and in my native language.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu and nautilus do you use?

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Joaquín Fernández (nodanero) wrote :

Ubuntu Gutsy: 2.6.22-6-generic #1 SMP
Nautilus: 2.19.4

Thanks.

Sebastien Bacher (seb128) wrote :

Does it happen with an another user? Do you have GTK bookmarks to those locations?

Joaquín Fernández (nodanero) wrote :

No, I haven't created bookmarks and this happens too with a new user created.

Justin Payne (neolithium82) wrote :

I can confirm this bug as well, fully updated Gutsy, Nautilus v 2.19.4; the documents folder is represented twice in the places menu on the Menu Bar. No bookmarks have been created and it does reproduce itself with a new user being created as well.

Regards,
Justin

Changed in gnome-panel:
status: Incomplete → Confirmed
Máté Őry (orymate) wrote :

The same for Hungarian.
`ls ~` gives Desktop Documents Examples (symlink) Music Pictures Public Templates Videos.
The same for a newly created user.

sno (sno-squee) wrote :

Confirmed running 20070716 daily-live for Gutsy from livecd shows the same behaviour as Justin, fully updated and still it appears.

Edward Amsden (amsden-linux) wrote :

fully updated netboot install of gutsy, same behaviour, screenshot attached

mAineAc (robhall-midmaine) wrote :

Happens here fully updated. i have a duplicate Documents folder and a duplicate Desktop folder. Up to date gutsy here also

Stefan Glasenhardt (glasen) wrote :

This bug seems to be related to the package "xdg-user-dirs". The bug first occured when i've installed this package. When you deinstall the package and recreate another user, the bug does not occur.
For your normal user, you have to logout, delete all gnome-related directories (i know this is a brutal method, but i haven't found another working solution) and than login again.
Now all the duplicate entries should have gone away.

Changed in gnome-panel:
status: Confirmed → Triaged
fmaste (fmaste) wrote :

Confirmed running Gutsy Tribe 4 from livecd

Basilio Kublik (sourcercito) wrote :

same here, duplicate desktop entry, installed from tribe 4 with all updates to the date.
gnome-panel 1:2.19.6-0ubuntu1
gnome-panel-data 1:2.19.6-0ubuntu1

rtjmay (rtjmay) wrote :

Confirm with fully updated Gutsy. I have tried deleting the duplicate items out of the Nautilus Bookmarks, but they are re-created when I log back in. Only one occurrence of "Desktop" and "Documents" appears in the Bookmarks.

Changed in gnome-panel:
importance: Low → Medium
Dylan McCall (dylanmccall) wrote :

You guys probably already noticed this, but the duplicate bug #133565 contains an explanation of what probably is causing this for you, and why it is still a bug needing a fix even with the simple workaround.

In retrospect, I should have done that as a comment to this (thanks for pointing out the duplicate, Sebastien -- I don't know how I missed that), but it would be bad form to copy and paste it at this point.

Saivann Carignan (oxmosys) wrote :

I'm on Gutsy tribe 5 and this bug still exist. My Ubuntu version is the French version, What I get :

Dossier Personnels
Documents
Bureau
Documents
Music
Pictures
Video
Desktop

Music, Pictures and Video should be in french : Musique, Images et Vidéo.
Desktop is the double of Bureau
Documents is the double of Document

Dossier Personnels is the only one which doesn't have double and that is in the good language

Confirmed with Tribe 5 (downloaded 24-Aug-2007). My "Places" menu shows:

Home Folder
Documents
Desktop
Documents
Music
Pictures
Videos
Desktop

Ross Peoples (deejross) wrote :

This happened with the new gnome-menus update in which they fixed some problems with spaces and updates from alacarte. One of the other things it does now, which I'm not sure if I like is that all cifs mounts used to show up as a place, but now they have been moved into a Removable Devices submenu in places.

The moving drives into a submenu automatically happens when the places menu gets too large. Although I personally consider it only too large when it won't fit on the screen instead of half the screen. (the current behavior) .. but that's another bug/feature..

Andrew Frank (frank-geoinfo) wrote :

i observed the duplication when i installed gutsy from the life cd (before anything else done). places has duplicate entries for documents and desktop, but not for other entries.

this is a gutsy life cd downloaded on monday 3 sept!

andrew

Michael Rooney (mrooney) wrote :

Yes, confirmed in Tribe 5 for me as well. I shall try the workaround.

Alex Mayorga (alex-mayorga) wrote :

I still see the duplicates as in this screen shoot http://launchpadlibrarian.net/8525567/Screenshot.png on Ubuntu 2.6.22-11.32-generic

Eugenia Loli-Queru (eloli) wrote :

This bug must be fixed before the release of Gutsy. It was a preview article on Digg a month ago and had shots of Ubuntu, and guess what, the guy who had written that preview had the bug. This should be fixed as it's way too visible and easy to reproduce.

Sebastien Bacher (seb128) wrote :

Eugenia, the milestone is set to 7.10-beta which indicates we will work in it before gutsy

Paul Sladen (sladen) wrote :

<elmo> also, Documents appears in 'Places' twice in this fairly fresh gutsy install
<sladen> elmo: and in this upgrade

VLK (valentyn) wrote :

The bug is still present!

Mono, the milestone is set to 7.10-beta which indicates we will work in it before gutsy (Gutsy 7.10-beta is not released yet)
So please be patient.

Martin Olsson (mnemo) wrote :

I can also confirm this bug on fully updated gutsy T5.

Gao Xianchao (gxcmaillist) wrote :

I can also confirm this bug today

David Tomaschik (matir) wrote :

Please stop reconfirming the bug. Nobody has indicated that it should be fixed, thus mentioning that it still exists is redundant.

Sebastien Bacher (seb128) wrote :

The duplicate Desktop entry is because xdg-user-dirs-gtk creates the download directory, I'll upload a fix

Changed in xdg-user-dirs-gtk:
importance: Undecided → Medium
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

I'll upload a fix for the panel issue

Changed in gnome-panel:
status: Triaged → Fix Committed
Michael Rooney (mrooney) wrote :

Should this still be happening in the Gutsy Beta released today? I did a fresh install (over top of another Ubuntu install which also exhibited the bug, not sure if it somehow picked it up from there?).

@Charles : look at the Status

Fix are committed but not released yet.

Sebastien Bacher (seb128) wrote :

gnome-panel (1:2.20.0.1-0ubuntu4) gutsy; urgency=low

  * debian/patches/01_layout.patch:
    - don't special case the Documents directory xdg-user-dirs-gtk lists it
      as a bookmark (LP: #122602)

 -- Sebastien Bacher <email address hidden> Wed, 26 Sep 2007 15:24:21 +0200

Changed in gnome-panel:
status: Fix Committed → Fix Released

Is there a way to manually fix this? I installed the gnome-panel update (Synaptic reports the right version anyway), yet I still have the problem.

Mark (nix4me) wrote :

As of today's updates, the multiple documents listings is gone. Now only the Desktop entry is repeated.

Forlong (forlong) wrote :

> As of today's updates, the multiple documents listings is gone.
> Now only the Desktop entry is repeated.

I can confirm this on a fresh beta install with all available updates.

Removing the Desktop entry from ~/.gtk-bookmarks fixes this.

Tom Wright (twright-tdw) wrote :

same for me

the 2 desktops are in the latest version but the problem was apparent every version i have used (from tribe 5) and on several different formats of the disk

i don't know if it helps but i'm using amd64 and a DELL inspiron 1501

Tiago Silva (tiagosilva) wrote :

I've been getting this since the early alphas too. Documents and Desktop is repeated, but editing the ~/.gtk-bookmarks file like Nick suggested made it all good (sort of, "Open ~/Picturesorwhatever" is not a dandy description).

Thanks.

Sebastien Bacher (seb128) wrote :

No need to keep flooding the maintainers with comments, this bug has been confirmed and will be fixed soon as stated

Sebastien Bacher (seb128) wrote :

xdg-user-dirs-gtk (0.6-0ubuntu2) gutsy; urgency=low

  * debian/control.in:
    - Build-Depends on intltool so the translations template is updated
      (LP: #136411)
  * debian/patches/01_no_desktop_bookmark.patch:
    - don't bookmark the desktop directory since it's already handled
      as a special case by the GNOME desktop applications (LP: #122602)
  * debian/patches/90_from_svn_handle_en_us_variants.patch:
    - patch from SVN, handle correctly en_US variants

 -- Sebastien Bacher <email address hidden> Tue, 02 Oct 2007 19:22:54 +0200

Changed in xdg-user-dirs-gtk:
status: Fix Committed → Fix Released

There's something weird about this: today I noticed that I did not have any Documents shortcut in my Places menu, so I had to add a bookmark for it manually.

Wasn't the panel supposed to have a special case for the Documents folder, which was the source of this bug? 'cause it didn't seem like it did, adding my bookmark did not create a duplicate.

Sebastien Bacher (seb128) wrote :

no, the documents item is a bookmark and the desktop entry is special cased

ok, thanks for the clarification. It used to be that way though (I remember in edgy/feisty, if I had a folder called Documents on the desktop, it would be automatically shown in the Places menu, even when we didn't have that xdg users dirs package)

Artem Popov (artfwo) wrote :

Well, actually there IS some way to handle Documents in the gnome-panel:

I have chosen the Russian locale, and the bookmarked Documents folder is automatically created with a translated name: "Документы", and it is called "Документы" in gtk bookmarks and the panel.

But if I create a folder named exactly "Documents" (in English), it is showed in Places menu right under "Home folder" item, and it has a localized shortcut as well: "Документы"...

So, I guess the panel still handles Documents, ignoring the xdg-user-dirs mechanism.

dmf86 (diogomiguelferreira86) wrote :

Same bug here. English Gutsy.

Progress Nerd (progressnerd) wrote :

I can confirm this bug is still in the latest version of Gutsy

Sebastien Bacher (seb128) wrote :

Could you attach your .gtk-bookmarks to the bug?

Progress Nerd (progressnerd) wrote :

Here is my .gtk-bookmarks file, and I've also attached a screenshot of my Places menu where you can see the Desktop appears twice.

file:///home/gdennis/Documents
file:///home/gdennis/Music
file:///home/gdennis/Pictures
file:///home/gdennis/Videos
file:///home/gdennis/Desktop

Sebastien Bacher (seb128) wrote :

That's not a bug, as described the Desktop item is a special case and should not be bookmarked, if you used a buggy version of xdg-user-dirs-gtk you should remove the bookmark now and that will work correctly

Sebastien Bacher (seb128) wrote :

Reopening, there is still an issue because something create a non translated Desktop directory on the CD which takes over the xdg translated version for compatibility reasons

Changed in xdg-user-dirs-gtk:
importance: Medium → High
status: Fix Released → Triaged
Artem Popov (artfwo) wrote :

Thanks for clarifying this, Sebastien! Here's what I now get with my setup:

After removing the non-translated Desktop directory (leaving translated in Place), and logging in afterwise, the home directory magically becomes the desktop, cannot figure out why :(

But If I create a translated Desktop directory in an absolutely blank homedir (all dotfiles erased, then copied over from /etc/skel), only the translated folder remains in place, and Places Menu only points to the translated dir, just as expected :)

One solution to the problem might be running the user-dirs creation program before any other GNOME-ish stuff comes in and manages to create the bogus non-translated Desktop, that seems to ruin the whole xdg-user-dirs idea.

Another pointer is the /usr/bin/xdg-user-dir script itself:

#!/bin/bash

test -f ${XDG_CONFIG_HOME:-~/.config}/user-dirs.dirs && source ${XDG_CONFIG_HOME:-~/.config}/user-dirs.dirs
if [ "x$1" == "xDESKTOP" ]; then
  eval echo \${XDG_${1}_DIR:-$HOME/Desktop}
else
  eval echo \${XDG_${1}_DIR:-$HOME}
fi

It seems to always return "$HOME/Desktop" if the DESKTOP folder is requested, pretty strange, hmm?

"the home directory magically becomes the desktop"

Yeah, if it can't find the desk it does just that. There is actually identical behaviour with the Documents directory. If that exists with that exact name, file-dialogs default to it. Interesting side-node: on localized desktops the file dialogs will work differently.

All in all there are lots of bugs related to the gnome-panel doing weird stuff.
May I suggest that all this special folder crap is just stipped from its code? Completely.

Why would there be code to have a 'desktop' or 'documents' entry, when there is a bookmark system in place that works fine? Esspecially with localization now. With dutch localisation the desktop is called differently between the xdg-user-dirs-localization and the gnome-panel-language-template.

Considering all the issuess, especially with localisation. Why not just remove all that code? Just make the places start with nautilus-books, and then the rest. No magical 'folders'. No magical behavior. We have xdg-user-dirs and we have nautilus-bookmarks. We really don't need al those extra hacks that just break it down everwhere.

But can we convice upstream?

Sebastien Bacher (seb128) wrote :

That's not a gnome-panel bug, the issue is that on the CD there is a "Desktop" directory created to put the ubiquity icon and the Examples link, those ideally should use the xdg API and use the translated version. That points to an another bug though. When "Desktop" exists then DESKTOP xdg-user-dirs location fallback to it rather than using the translated version (there is a special case for that in the code). In this case the patch I added doesn't work because it compares DOWNLOAD to the translated DESKTOP and not to the fallback option

willz06jw (willz06jw) wrote :

I have the newest full version of gutsy and I still have duplicated Desktop entries in the places menu.

There is only one bookmark for Desktop in Nautilus, and if I delete that one bookmark then I get only one entry in the Places menu.

But then, if I am looking through folders in Nautilus, I don't have a bookmark to go to the Desktop folder.

jorno (jorn-odberg) wrote :

willz06jw; That was strange... I installed Gutsy from the released CD on both my computers, and I didn't get duplicated entries in the "Places" menu on either PC...

Did you do an dist-upgrade/full-upgrade, or did you fully reinstall from the newest CD ?

if he does a clean install from the cd/dvd, if he keeps his /home folder, he will still have the problem though.

jorno schrieb:
> willz06jw; That was strange... I installed Gutsy from the released CD on
> both my computers, and I didn't get duplicated entries in the "Places"
> menu on either PC...
>
> Did you do an dist-upgrade/full-upgrade, or did you fully reinstall from
> the newest CD ?
>
>
It was in Gutsy Beta and is fixed yet

sgies1963 (sgies1963) wrote :

Duplicate entries on the desktop

Saivann Carignan (oxmosys) wrote :

When installed from Final Release CD, it's also solved for me.

This appears to be solved in the final release of Ubuntu 7.10. Should this bug be closed?

Thermaltaker (dennis-benndorf) wrote :

Christer Edwards schrieb:
> This appears to be solved in the final release of Ubuntu 7.10. Should
> this bug be closed?
>
>
Sry. Yes it can be closed.

Dylan McCall (dylanmccall) wrote :

In terms of the problem being painted over with reasonable success such that
the problem being unearthed may be blamed on the user instead of erroneous
system design, it is solved. However, I request that another bug or
blueprint, destined for Hardy, be opened that explains the problem of these
disagreeing Places menus.

Try this: Create a bookmark to every location that is missing in every
Places list in Ubuntu. (That is Nautilus, the file opener widget and
gnome-panel). Count the duplicates in each menu. The other problem this
causes is a more simple case of accessibility. The user should be able to
anticipate the contents of the Places menus to be all identical, just as he
can expect every window to have a Close button. After all, those menus all
show the same bookmarks and have the same title! However, for everything
that is not a bookmark, this is certainly not the case...

We have a perfectly good global bookmarks system; let's use it for the more
rigid places as well. (Perhaps the bookmarks that aren't usually edited
could placed in /etc, which is a globally accessible application).

On 11/4/07, Thermaltaker <email address hidden> wrote:
>
> Christer Edwards schrieb:
> > This appears to be solved in the final release of Ubuntu 7.10. Should
> > this bug be closed?
> >
> >
> Sry. Yes it can be closed.
>
> --
> Duplicated entries in Places Menu
> https://bugs.launchpad.net/bugs/122602
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Dylan McCall (dylanmccall) wrote :

Sorry about the double post.
"Request", of course, means suggest :/
Weird typo. I'm not /that/ lazy!

Sebastien Bacher (seb128) wrote :

the bug has been fixed in gutsy

Changed in xdg-user-dirs-gtk:
status: Triaged → Fix Released
Raigedas (raigedas) wrote :

the bug (or variation of it) still exists in Lucid.
i have placed several records in fstab that connect me to samba shares. Some of those mounted samba shares are displayed two times in "Places". Strange thing: everytime one of the two links is working and the other is not (when i click it, it says that the share is not connected).

screenshot taken from nautilus, but it contains same content as "Places". you can see that:
1) "server_media" and "server_raigedas.info" (which are actually connected) are shown two times - one as connected (with eject button) and others as disconnected.
2) "om" (which is actually not connected) shown only one time.
3) "server_rgd" (which is actually connected) shown only one time.
therefore the conclusion is that connection state of the share does not relate with the bug.

abloylas (abloylas) wrote :

This affects me too on Mint 10, which is built on the latest Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers