Switch Flashback sessions to XDG_CURRENT_DESKTOP=Unity

Bug #1224217 reported by Doug McMahon
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Fix Released
Undecided
Dmitry Shachnev
gnome-session (Ubuntu)
Fix Released
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Fix Released
Undecided
Tim Lunn
unity-settings-daemon (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

No errors in logs, no nothing. Just a desktop with right click
Tried with existing & a new user account, same thing.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-session-flashback 1:3.6.2-0ubuntu14
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
Date: Wed Sep 11 20:27:28 2013
GsettingsChanges:

InstallationDate: Installed on 2013-08-07 (35 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130803)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: gnome-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Doug McMahon (mc3man) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:3.6.2-0ubuntu15

---------------
gnome-panel (1:3.6.2-0ubuntu15) saucy; urgency=low

  * Identify as GNOME; identifying as Unity is buggy (LP: #1224217)
 -- Jeremy Bicha <email address hidden> Thu, 12 Sep 2013 22:29:02 -0400

Changed in gnome-panel (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Tim Lunn (darkxst) wrote :

I had a super quick look into why this buggy when identifying as Unity

gnome-panel.desktop and nautilus-classic.desktop, will need to have Unity added to "OnlyShowIn".

Still indicators won't load, this is probably something similar, but not sure where that would be controlled from?

Revision history for this message
Tim Lunn (darkxst) wrote :

I will also add, that using Unity, should mean you will load Unity-control-center and unity-settings-daemon (once it happens ), which will be required since legacy code in the gnome- packages will be dropped once the forking is complete.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Tim wrote:
> gnome-panel.desktop and nautilus-classic.desktop, will need to have Unity added to "OnlyShowIn".

Adding a nautilus task then.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Re-using this bug report to track the switch to Unity identification. The only remaining blocker is non-working indicators:

- All .desktop autostart files for indicators have NotShowIn=Unity;
- In Unity sessions, indicators are autostarted by Upstart:
   unity-panel-service calls "upstart_emit_event_sync (NULL, priv->upstart, "indicator-services-start", NULL, 0);" on startup
   and "upstart_emit_event_sync (NULL, priv->upstart, "indicator-services-end", NULL, 0);" on shutdown.

Possible solutions:

- Add upstart support to indicator-applet (looks too late at this point in release cycle);
- Do not identify as Unity, but only switch to unity-s-d/unity-c-c.

Tim, what do you think?

summary: - 50_ubuntu_sessions.patch causes gnome-flashback sessions not to load
+ Switch Flashback sessions to XDG_CURRENT_DESKTOP=Unity
Changed in gnome-panel (Ubuntu):
status: Fix Released → New
Revision history for this message
Tim Lunn (darkxst) wrote :

Dimtry, while g-s-d and g-c-c are the main components affected by XDG_CURRENT_DESKTOP, it is also used in other places such as client side decorations on nautilus/epiphany, goa vs uoa in empathy/gnome-contacts, and probably other things also .

This is in particular a bigger issue for components started from upstart user sessions, since they don't even have access to DESKTOP_SESSION (my proposed displayconfig package falls into this group).

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

OK, I have applied a hack I mentioned to you earlier today on IRC. Test packages are available in ppa:mitya57/gnome-test.

Known issue: gnome-settings-daemon is still started by something.

Revision history for this message
Tim Lunn (darkxst) wrote :

gnome-settings-daemon is started by upstart user session

Revision history for this message
Dmitry Shachnev (mitya57) wrote : Re: [Bug 1224217] Re: Switch Flashback sessions to XDG_CURRENT_DESKTOP=Unity

Can we just delete that user session or at least disable it in Unity?

Revision history for this message
Tim Lunn (darkxst) wrote :

I will patch the upstart config to check XDG_CURRENT_DESKTOP rather than INSTANCE!=ubuntu

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Tim (darkxst)
status: New → In Progress
Revision history for this message
Tim Lunn (darkxst) wrote :

looks like will need to patch gnome-session, u-s-d and g-s-d to make this work, I will prepare some patches tomorrow.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Thanks Tim!

I've managed to make the gnome-panel code a bit less hacky (by using initctl emit), and uploaded.

Nautilus task seems to be no longer needed.

no longer affects: nautilus (Ubuntu)
Changed in gnome-panel (Ubuntu):
status: New → Fix Committed
assignee: nobody → Dmitry Shachnev (mitya57)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:3.8.0-1ubuntu9

---------------
gnome-panel (1:3.8.0-1ubuntu9) trusty; urgency=low

  * Revert changes to 41_classic_layout.patch introduced in -1ubuntu4,
    this causes two keyboard indicators to be visible.
  * Identify as Unity, again (LP: #1224217).
  * Use unity-settings-daemon instead of gnome-settings-daemon.
  * Add gnome-flashback-services.desktop to autostart indicators.
  * Bump Standards-Version to 3.9.5, no changes needed.
 -- Dmitry Shachnev <email address hidden> Sat, 01 Mar 2014 14:39:38 +0400

Changed in gnome-panel (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.8.6.1-0ubuntu10

---------------
gnome-settings-daemon (3.8.6.1-0ubuntu10) trusty; urgency=medium

  * gnome-settings-daemon.user-session.upstart: Use XDG_CURRENT_DESKTOP
    as the instance specifier for gnome-session upstart jobs, since
    other sessions apart from ubuntu will need to use u-s-d (LP: #1224217)
 -- Tim Lunn <email address hidden> Wed, 12 Mar 2014 16:47:04 +1100

Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.9.90-0ubuntu12

---------------
gnome-session (3.9.90-0ubuntu12) trusty; urgency=medium

  * gnome-session-bin.user-session.upstart: Use XDG_CURRENT_DESKTOP
    as the instance specifier for gnome-session upstart jobs, since
    other sessions apart from ubuntu will need to use u-s-d (LP: #1224217)
 -- Tim Lunn <email address hidden> Wed, 12 Mar 2014 16:27:59 +1100

Changed in gnome-session (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 14.04.0+14.04.20140310-0ubuntu2

---------------
unity-settings-daemon (14.04.0+14.04.20140310-0ubuntu2) trusty; urgency=medium

  * unity-settings-demon.user-session.upstart: Use XDG_CURRENT_DESKTOP
    as the instance specifier for gnome-session upstart jobs, since
    other sessions apart from ubuntu will need to use u-s-d (LP: #1224217)
 -- Tim Lunn <email address hidden> Wed, 12 Mar 2014 16:45:51 +1100

Changed in unity-settings-daemon (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers